aboutsummaryrefslogtreecommitdiff
path: root/x11-servers
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-12-20 18:41:56 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-12-20 18:41:56 +0000
commit491ba8c3a65a9d9bddbcbeb3e3064571b4d55abd (patch)
treef1a6d5e30573319c7624e11c70f585d6991648ae /x11-servers
parent811498a678914a5815f3689fba46adc944ba6c36 (diff)
downloadports-491ba8c3a65a9d9bddbcbeb3e3064571b4d55abd.tar.gz
ports-491ba8c3a65a9d9bddbcbeb3e3064571b4d55abd.zip
- Support CC/CFLAGS properly
- Update MASTER_SITES - Port supports staging PR: ports/184875 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=337067
Diffstat (limited to 'x11-servers')
-rw-r--r--x11-servers/x2x/Makefile23
-rw-r--r--x11-servers/x2x/files/patch-aa10
2 files changed, 18 insertions, 15 deletions
diff --git a/x11-servers/x2x/Makefile b/x11-servers/x2x/Makefile
index 962953839e59..b3e1ed4aac9d 100644
--- a/x11-servers/x2x/Makefile
+++ b/x11-servers/x2x/Makefile
@@ -3,17 +3,30 @@
PORTNAME= x2x
PORTVERSION= 1.27
-PORTREVISION= 3
CATEGORIES= x11-servers
-MASTER_SITES= http://cloud.github.com/downloads/dottedmag/x2x/
+MASTER_SITES= GHC
MAINTAINER= ports@FreeBSD.org
COMMENT= Program to link multiple X servers together
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= dottedmag
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
USES= imake
USE_XORG= x11 xext xtst
-MAN1= x2x.1
-PLIST_FILES= bin/x2x
-NO_STAGE= yes
+PLIST_FILES= bin/x2x man/man1/x2x.1.gz
+
+post-extract:
+ @${LN} -sf x2x.1 ${WRKSRC}/x2x.man
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/CC =/s|^|XCOMM| ; \
+ /CDEBUGFLAGS =/s|^|XCOMM|' ${WRKSRC}/Imakefile
+
.include <bsd.port.mk>
diff --git a/x11-servers/x2x/files/patch-aa b/x11-servers/x2x/files/patch-aa
deleted file mode 100644
index ceab5355f6f8..000000000000
--- a/x11-servers/x2x/files/patch-aa
+++ /dev/null
@@ -1,10 +0,0 @@
---- Imakefile~ Thu Aug 21 01:44:52 1997
-+++ Imakefile Sun Sep 3 16:44:47 2000
-@@ -10,3 +10,7 @@
- CDEBUGFLAGS = -O
-
- ComplexProgramTarget(x2x)
-+# Added by Greg Lehey <grog@FreeBSD.org> for FreeBSD port
-+x2x.man: x2x.1
-+ rm -f x2x.man
-+ ln x2x.1 x2x.man