aboutsummaryrefslogtreecommitdiff
path: root/x11-servers
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2002-10-09 04:26:41 +0000
committerEric Anholt <anholt@FreeBSD.org>2002-10-09 04:26:41 +0000
commit21a4666d2c1c3a802faaabe3e3458000572ac372 (patch)
treefda695b254d6daf00ee4963f7c170605d0ca2f33 /x11-servers
parent178f505f94a757d2c027a57dc2c4e1190d0e9081 (diff)
downloadports-21a4666d2c1c3a802faaabe3e3458000572ac372.tar.gz
ports-21a4666d2c1c3a802faaabe3e3458000572ac372.zip
o Back out a patch from the 4.2.1 update which broke DPMS on Rage 128 hardware
o Use XFree86's mga driver, even in the WITH_MATROX_GXX_DRIVER case. (it now only adds installation of the hal library)
Notes
Notes: svn path=/head/; revision=67682
Diffstat (limited to 'x11-servers')
-rw-r--r--x11-servers/XFree86-4-Server-snap/Makefile51
-rw-r--r--x11-servers/XFree86-4-Server-snap/distinfo3
-rw-r--r--x11-servers/XFree86-4-Server-snap/pkg-message-drm11
-rw-r--r--x11-servers/XFree86-4-Server/Makefile51
-rw-r--r--x11-servers/XFree86-4-Server/distinfo3
-rw-r--r--x11-servers/XFree86-4-Server/pkg-message-drm11
6 files changed, 24 insertions, 106 deletions
diff --git a/x11-servers/XFree86-4-Server-snap/Makefile b/x11-servers/XFree86-4-Server-snap/Makefile
index cf26c3753736..2b6ea4554a28 100644
--- a/x11-servers/XFree86-4-Server-snap/Makefile
+++ b/x11-servers/XFree86-4-Server-snap/Makefile
@@ -7,26 +7,21 @@
PORTNAME= Server
PORTVERSION= 4.2.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-servers
MASTER_SITES= ${MASTER_SITE_XFREE:S/$/:x/} \
- ${MASTER_SITE_XFREE:S/source//g:S/$/:x421patch/} \
- ${MASTER_SITE_XFREE:S/source//g:S/$/:x421fixes/} \
${MASTER_SITE_LOCAL:S/$/:local/}
MASTER_SITE_SUBDIR= 4.2.0/:x \
- ${PORTVERSION}/patches/:x421patch \
- ${PORTVERSION}/fixes/:x421fixes \
anholt/:local
PKGNAMEPREFIX= XFree86-
DISTFILES= X420src-1.tgz:x \
- 4.2.0-4.2.1.diff.gz:x421patch \
- 4.2.1-mit-shm-security.patch:x421fixes \
Wraphelp.gz:local
EXTRACT_ONLY= X420src-1.tgz
PATCH_SITES= ${MASTER_SITE_LOCAL}
PATCH_SITE_SUBDIR= anholt/patches-4.2.0/
-PATCHFILES= patch-nvchips.gz
+PATCHFILES= 4.2.0-4.2.1-1-freebsd.patch.gz \
+ patch-nvchips.gz
MAINTAINER= anholt@freebsd.org
@@ -35,7 +30,7 @@ USE_IMAKE= YES
DIST_SUBDIR= xc
WRKSRC= ${WRKDIR}/xc
PATCHDIR= ${.CURDIR}/../../x11/XFree86-4-libraries/files
-.for pf in patch-text-mode.c patch-xf86Configure.c patch-xf86config.c
+.for pf in patch-text-mode.c patch-xf86Configure.c patch-xf86config.c patch-mga_driver.c
EXTRA_PATCHES+= ${.CURDIR}/files/${pf}
.endfor
SCRIPTS_ENV= OSVERSION=${OSVERSION} \
@@ -157,27 +152,14 @@ MAN4+= citron.4 \
PLIST_SUB+= XIE:="@comment "
.endif
-# matrox BETA driver is not ready for 4.2.0.
-# I don't confirm feather it is newer than the one which included in 4.2.0,
-# but you can try the BETA driver. Just set that variable.
-
-pre-everything::
- @${ECHO_MSG} "********************************************************"
- @${ECHO_MSG} "WARNING: MATROX DRIVERS NOT FULLY TESTED WITH XFREE86"
- @${ECHO_MSG} "4.2.0! ENABLE AT YOUR OWN RISK!"
- @${ECHO_MSG} "********************************************************"
-
.if ${ARCH} == i386
.if !defined(WITH_MATROX_GXX_DRIVER)
HaveMatroxHal= NO
PLIST_SUB+= MATROX="@comment "
pre-fetch::
@${ECHO_MSG} "********************************************************"
- @${ECHO_MSG} "Define WITH_MATROX_GXX_DRIVER to enable the official"
- @${ECHO_MSG} "Matrox drivers for the G200, G400, G450, and G550"
- @${ECHO_MSG} "graphic adapters."
- @${ECHO_MSG} ""
- @${ECHO_MSG} "This has been tested on a G400 AGP card."
+ @${ECHO_MSG} "Define WITH_MATROX_GXX_DRIVER to include Matrox's extra"
+ @${ECHO_MSG} "\"HALLIB\" binary driver"
@${ECHO_MSG} "********************************************************"
.else
NO_PACKAGE= "Matrox drivers may not be distributed"
@@ -189,33 +171,22 @@ DISTFILES+= mgadrivers-${MGA_DRIVER_VERSION}-src.tgz:mga
EXTRACT_ONLY+= mgadrivers-${MGA_DRIVER_VERSION}-src.tgz
RESTRICTED_FILES= mgadrivers-${MGA_DRIVER_VERSION}-src.tgz
PLIST_SUB+= MATROX=""
-post-patch::
- @(cd ${WRKSRC}; \
- ${MV} programs/Xserver/hw/xfree86/drivers/mga \
- programs/Xserver/hw/xfree86/drivers/mga.old; \
- ${MV} ../mgadrivers-${MGA_DRIVER_VERSION}-src/4.2.0/drivers/src programs/Xserver/hw/xfree86/drivers/mga)
+post-extract::
+ ${MV} ${WRKDIR}/mgadrivers-${MGA_DRIVER_VERSION}-src/4.2.0/drivers/src/HALlib/* \
+ ${WRKSRC}/programs/Xserver/hw/xfree86/drivers/mga/HALlib/
post-install::
- ${INSTALL_DATA} ${WRKSRC}/programs/Xserver/hw/xfree86/drivers/mga/README_HALLIB ${PREFIX}/lib/X11/doc/README.mga_HALLIB
+ ${INSTALL_DATA} ${WRKDIR}/mgadrivers-${MGA_DRIVER_VERSION}-src/4.2.0/drivers/src/README_HALLIB \
+ ${PREFIX}/lib/X11/doc/README.mga_HALLIB
.endif # !WITH_MATROX_GXX_DRIVER
.else
HaveMatroxHal= NO
PLIST_SUB+= MATROX="@comment "
.endif
-.if ${HaveMatroxHal} == NO
-EXTRA_PATCHES+= ${.CURDIR}/files/patch-mga_driver.c
-.endif
-
post-extract::
${GUNZIP_CMD} -c ${DISTDIR}/${DIST_SUBDIR}/Wraphelp.gz > \
${WRKSRC}/lib/Xdmcp/Wraphelp.c
-pre-patch::
- -@${GZCAT} ${DISTDIR}/${DIST_SUBDIR}/4.2.0-4.2.1.diff.gz \
- | ${PATCH} -d ${PATCH_WRKSRC} --forward --quiet -E -p1 --batch
- -@${CAT} ${DISTDIR}/${DIST_SUBDIR}/4.2.1-mit-shm-security.patch \
- | ${PATCH} -d ${PATCH_WRKSRC} --forward --quiet -E -p1 --batch
-
post-build:
@${RM} -f ${PKGMESSAGE}
@${CAT} ${.CURDIR}/pkg-message >> ${PKGMESSAGE}
diff --git a/x11-servers/XFree86-4-Server-snap/distinfo b/x11-servers/XFree86-4-Server-snap/distinfo
index 068c83b6dc13..bc9a0a483315 100644
--- a/x11-servers/XFree86-4-Server-snap/distinfo
+++ b/x11-servers/XFree86-4-Server-snap/distinfo
@@ -1,7 +1,6 @@
MD5 (xc/X420src-1.tgz) = ad43a8e9e39703322005cd6f7145b77f
-MD5 (xc/4.2.0-4.2.1.diff.gz) = 38adc94a4953a6b29e8619c25dda4887
MD5 (xc/Wraphelp.gz) = 7ee30e397359e8d64ab23f29aa551659
MD5 (xc/freebsd-glide3headers.tar.gz) = 2bb614c909898a17c05e43e60cfb8e3b
MD5 (xc/mgadrivers-2.0-src.tgz) = 877db503967ae837c147953dbcd8ee6d
-MD5 (xc/4.2.1-mit-shm-security.patch) = 18eb56110c7f66895111bd9f3513b54e
+MD5 (xc/4.2.0-4.2.1-1-freebsd.patch.gz) = 1d4c49d7f354b307b7961e6d8e6c4274
MD5 (xc/patch-nvchips.gz) = bcb190d3f2c26d993a3a3c1512cf9bc9
diff --git a/x11-servers/XFree86-4-Server-snap/pkg-message-drm b/x11-servers/XFree86-4-Server-snap/pkg-message-drm
deleted file mode 100644
index d908ba10b2a7..000000000000
--- a/x11-servers/XFree86-4-Server-snap/pkg-message-drm
+++ /dev/null
@@ -1,11 +0,0 @@
-To use the Direct Rendering Infrastructure, you need to do the following:
-
-- Enable agp support in your kernel, or load the agp kernel module at
- boot time. You can do this by editing /boot/loader.conf(5)
-- Load the appropriate kernel module from /usr/X11R6/lib/X11/kernel at
- boot time:
- - tdfx.ko for 3Dfx cards
- - mga.ko for Matrox G200/G400/G450
-- Add the following lines to the "Module" section of your XF86Config:
- Load "glx"
- Load "dri"
diff --git a/x11-servers/XFree86-4-Server/Makefile b/x11-servers/XFree86-4-Server/Makefile
index cf26c3753736..2b6ea4554a28 100644
--- a/x11-servers/XFree86-4-Server/Makefile
+++ b/x11-servers/XFree86-4-Server/Makefile
@@ -7,26 +7,21 @@
PORTNAME= Server
PORTVERSION= 4.2.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-servers
MASTER_SITES= ${MASTER_SITE_XFREE:S/$/:x/} \
- ${MASTER_SITE_XFREE:S/source//g:S/$/:x421patch/} \
- ${MASTER_SITE_XFREE:S/source//g:S/$/:x421fixes/} \
${MASTER_SITE_LOCAL:S/$/:local/}
MASTER_SITE_SUBDIR= 4.2.0/:x \
- ${PORTVERSION}/patches/:x421patch \
- ${PORTVERSION}/fixes/:x421fixes \
anholt/:local
PKGNAMEPREFIX= XFree86-
DISTFILES= X420src-1.tgz:x \
- 4.2.0-4.2.1.diff.gz:x421patch \
- 4.2.1-mit-shm-security.patch:x421fixes \
Wraphelp.gz:local
EXTRACT_ONLY= X420src-1.tgz
PATCH_SITES= ${MASTER_SITE_LOCAL}
PATCH_SITE_SUBDIR= anholt/patches-4.2.0/
-PATCHFILES= patch-nvchips.gz
+PATCHFILES= 4.2.0-4.2.1-1-freebsd.patch.gz \
+ patch-nvchips.gz
MAINTAINER= anholt@freebsd.org
@@ -35,7 +30,7 @@ USE_IMAKE= YES
DIST_SUBDIR= xc
WRKSRC= ${WRKDIR}/xc
PATCHDIR= ${.CURDIR}/../../x11/XFree86-4-libraries/files
-.for pf in patch-text-mode.c patch-xf86Configure.c patch-xf86config.c
+.for pf in patch-text-mode.c patch-xf86Configure.c patch-xf86config.c patch-mga_driver.c
EXTRA_PATCHES+= ${.CURDIR}/files/${pf}
.endfor
SCRIPTS_ENV= OSVERSION=${OSVERSION} \
@@ -157,27 +152,14 @@ MAN4+= citron.4 \
PLIST_SUB+= XIE:="@comment "
.endif
-# matrox BETA driver is not ready for 4.2.0.
-# I don't confirm feather it is newer than the one which included in 4.2.0,
-# but you can try the BETA driver. Just set that variable.
-
-pre-everything::
- @${ECHO_MSG} "********************************************************"
- @${ECHO_MSG} "WARNING: MATROX DRIVERS NOT FULLY TESTED WITH XFREE86"
- @${ECHO_MSG} "4.2.0! ENABLE AT YOUR OWN RISK!"
- @${ECHO_MSG} "********************************************************"
-
.if ${ARCH} == i386
.if !defined(WITH_MATROX_GXX_DRIVER)
HaveMatroxHal= NO
PLIST_SUB+= MATROX="@comment "
pre-fetch::
@${ECHO_MSG} "********************************************************"
- @${ECHO_MSG} "Define WITH_MATROX_GXX_DRIVER to enable the official"
- @${ECHO_MSG} "Matrox drivers for the G200, G400, G450, and G550"
- @${ECHO_MSG} "graphic adapters."
- @${ECHO_MSG} ""
- @${ECHO_MSG} "This has been tested on a G400 AGP card."
+ @${ECHO_MSG} "Define WITH_MATROX_GXX_DRIVER to include Matrox's extra"
+ @${ECHO_MSG} "\"HALLIB\" binary driver"
@${ECHO_MSG} "********************************************************"
.else
NO_PACKAGE= "Matrox drivers may not be distributed"
@@ -189,33 +171,22 @@ DISTFILES+= mgadrivers-${MGA_DRIVER_VERSION}-src.tgz:mga
EXTRACT_ONLY+= mgadrivers-${MGA_DRIVER_VERSION}-src.tgz
RESTRICTED_FILES= mgadrivers-${MGA_DRIVER_VERSION}-src.tgz
PLIST_SUB+= MATROX=""
-post-patch::
- @(cd ${WRKSRC}; \
- ${MV} programs/Xserver/hw/xfree86/drivers/mga \
- programs/Xserver/hw/xfree86/drivers/mga.old; \
- ${MV} ../mgadrivers-${MGA_DRIVER_VERSION}-src/4.2.0/drivers/src programs/Xserver/hw/xfree86/drivers/mga)
+post-extract::
+ ${MV} ${WRKDIR}/mgadrivers-${MGA_DRIVER_VERSION}-src/4.2.0/drivers/src/HALlib/* \
+ ${WRKSRC}/programs/Xserver/hw/xfree86/drivers/mga/HALlib/
post-install::
- ${INSTALL_DATA} ${WRKSRC}/programs/Xserver/hw/xfree86/drivers/mga/README_HALLIB ${PREFIX}/lib/X11/doc/README.mga_HALLIB
+ ${INSTALL_DATA} ${WRKDIR}/mgadrivers-${MGA_DRIVER_VERSION}-src/4.2.0/drivers/src/README_HALLIB \
+ ${PREFIX}/lib/X11/doc/README.mga_HALLIB
.endif # !WITH_MATROX_GXX_DRIVER
.else
HaveMatroxHal= NO
PLIST_SUB+= MATROX="@comment "
.endif
-.if ${HaveMatroxHal} == NO
-EXTRA_PATCHES+= ${.CURDIR}/files/patch-mga_driver.c
-.endif
-
post-extract::
${GUNZIP_CMD} -c ${DISTDIR}/${DIST_SUBDIR}/Wraphelp.gz > \
${WRKSRC}/lib/Xdmcp/Wraphelp.c
-pre-patch::
- -@${GZCAT} ${DISTDIR}/${DIST_SUBDIR}/4.2.0-4.2.1.diff.gz \
- | ${PATCH} -d ${PATCH_WRKSRC} --forward --quiet -E -p1 --batch
- -@${CAT} ${DISTDIR}/${DIST_SUBDIR}/4.2.1-mit-shm-security.patch \
- | ${PATCH} -d ${PATCH_WRKSRC} --forward --quiet -E -p1 --batch
-
post-build:
@${RM} -f ${PKGMESSAGE}
@${CAT} ${.CURDIR}/pkg-message >> ${PKGMESSAGE}
diff --git a/x11-servers/XFree86-4-Server/distinfo b/x11-servers/XFree86-4-Server/distinfo
index 068c83b6dc13..bc9a0a483315 100644
--- a/x11-servers/XFree86-4-Server/distinfo
+++ b/x11-servers/XFree86-4-Server/distinfo
@@ -1,7 +1,6 @@
MD5 (xc/X420src-1.tgz) = ad43a8e9e39703322005cd6f7145b77f
-MD5 (xc/4.2.0-4.2.1.diff.gz) = 38adc94a4953a6b29e8619c25dda4887
MD5 (xc/Wraphelp.gz) = 7ee30e397359e8d64ab23f29aa551659
MD5 (xc/freebsd-glide3headers.tar.gz) = 2bb614c909898a17c05e43e60cfb8e3b
MD5 (xc/mgadrivers-2.0-src.tgz) = 877db503967ae837c147953dbcd8ee6d
-MD5 (xc/4.2.1-mit-shm-security.patch) = 18eb56110c7f66895111bd9f3513b54e
+MD5 (xc/4.2.0-4.2.1-1-freebsd.patch.gz) = 1d4c49d7f354b307b7961e6d8e6c4274
MD5 (xc/patch-nvchips.gz) = bcb190d3f2c26d993a3a3c1512cf9bc9
diff --git a/x11-servers/XFree86-4-Server/pkg-message-drm b/x11-servers/XFree86-4-Server/pkg-message-drm
deleted file mode 100644
index d908ba10b2a7..000000000000
--- a/x11-servers/XFree86-4-Server/pkg-message-drm
+++ /dev/null
@@ -1,11 +0,0 @@
-To use the Direct Rendering Infrastructure, you need to do the following:
-
-- Enable agp support in your kernel, or load the agp kernel module at
- boot time. You can do this by editing /boot/loader.conf(5)
-- Load the appropriate kernel module from /usr/X11R6/lib/X11/kernel at
- boot time:
- - tdfx.ko for 3Dfx cards
- - mga.ko for Matrox G200/G400/G450
-- Add the following lines to the "Module" section of your XF86Config:
- Load "glx"
- Load "dri"