aboutsummaryrefslogtreecommitdiff
path: root/x11-servers
diff options
context:
space:
mode:
authorPaul Traina <pst@FreeBSD.org>1995-11-07 16:17:03 +0000
committerPaul Traina <pst@FreeBSD.org>1995-11-07 16:17:03 +0000
commitc568b5d2856a17b4cb6a5c4dfba3b50eaf6ac6ac (patch)
treec70685685cb2e4582438440c360cf6d1f7e69b00 /x11-servers
parent9a5ea851d46d5477bcd289288ba23b5852106f73 (diff)
downloadports-c568b5d2856a17b4cb6a5c4dfba3b50eaf6ac6ac.tar.gz
ports-c568b5d2856a17b4cb6a5c4dfba3b50eaf6ac6ac.zip
Add optional support for enabling MIT's DES based authentication and
also rolled in Kerberos V4 support so xdm can aquire your tickets for you. Approved by: jmz & asami
Notes
Notes: svn path=/head/; revision=2395
Diffstat (limited to 'x11-servers')
-rw-r--r--x11-servers/XFree86-4-Server-snap/distinfo1
-rw-r--r--x11-servers/XFree86-4-Server-snap/scripts/configure68
-rw-r--r--x11-servers/XFree86-4-Server/distinfo1
-rw-r--r--x11-servers/XFree86-4-Server/scripts/configure68
4 files changed, 136 insertions, 2 deletions
diff --git a/x11-servers/XFree86-4-Server-snap/distinfo b/x11-servers/XFree86-4-Server-snap/distinfo
index d926e9cffbee..f5632de974ec 100644
--- a/x11-servers/XFree86-4-Server-snap/distinfo
+++ b/x11-servers/XFree86-4-Server-snap/distinfo
@@ -2,4 +2,5 @@ MD5 (xc-1.tar.gz) = b5ae499273bddce4add5b62fc2b0b810
MD5 (xc-2.tar.gz) = e81d2d235dd517c3e36f588221910b03
MD5 (xc-3.tar.gz) = 01bb42c399a542395f0e17a182ba0e96
MD5 (XFree86-3.1.2.diff.gz) = cbb4ca154ed0882b1ee75326089ef4b5
+MD5 (3.1.2-3.1.2-S.diff.gz) = 773acfe51ebbb4e557f4a14905b28f3f
MD5 (cfont312.tgz) = 89a8e082dbbcfc2fd09cfedc47a54ff0
diff --git a/x11-servers/XFree86-4-Server-snap/scripts/configure b/x11-servers/XFree86-4-Server-snap/scripts/configure
index 1d41e71a2f09..8e3892b682db 100644
--- a/x11-servers/XFree86-4-Server-snap/scripts/configure
+++ b/x11-servers/XFree86-4-Server-snap/scripts/configure
@@ -94,6 +94,66 @@ fi
echo
yesno "Do you want your X applications linked with gnu malloc? [YES] "
gnumalloc=$answ
+
+cat <<'END'
+
+ MIT supplies an authentication mechanism that relies upon DES, this is
+ called XDM-AUTHORIZATION-1.
+
+ Source code for this authentication mechanism may not be exported from
+ the United States, however, there are compatible replacements for this
+ mechanism available elsewhere. Also, while this scheme is not used for
+ general purpose encryption, some countries restrict the use of strong
+ cryptography.
+
+ If you have aquired a copy of "Wraphelp.c" and it currently resides in
+ the same location as the XFree86 upgrade patches or in the ports "files"
+ subdirectory, it will be copied into the right place in the X11 source
+ distribution and support for this feature will be enabled if you answer
+ YES to the following question.
+
+ If you do not have a copy of this file, even if you answer YES to this
+ question, support will not be enabled. If you wish to change this later,
+ the option controling this is contined the file xc/config/cf/xf86site.def.
+
+END
+yesno "Do you want to enable XDM-AUTHORIZATION-1 support? [YES] "
+if [ $answ = YES ]; then
+ WH=$WRKDIR/xc/lib/Xdmcp/Wraphelp.c
+
+ if [ -f $WH ] ; then
+ echo "==> $WH found in source distribution."
+ elif [ -f $X11FIXES/Wraphelp.c ] ; then
+ echo "==> Wraphelp.c found in fix directory, copying to source tree."
+ cp $X11FIXES/Wraphelp.c $WH
+ elif [ -f $FILESDIR/Wraphelp.c ] ; then
+ echo "==> Wraphelp.c found in files directory, copying to source tree."
+ cp $FILESDIR/Wraphelp.c $WH
+ else
+ echo "==> Wraphelp.c not found, DES support NOT enabled."
+ answ=NO
+ fi
+fi
+echo "#undef HadXdmAuth" >> $F
+echo "#define HasXdmAuth $answ" >> $F
+
+cat <<'END'
+
+ Additional support for Kerberos V4 is available should you chose to
+ install it. If you choose to install the Kerberos V4 patches, you
+ will also be asked if you want to enable Kerberos V4 support.
+
+END
+
+yesno "Do you want to add the Kerberos V4 support patches? [YES] "
+k4patch=$answ
+if [ $k4patch = YES ] ; then
+ echo
+ yesno "Do you want to enable Kerberos V4 support? [YES] "
+ echo "#undef HasKrb4" >>$F
+ echo "#define HasKrb4 $answ" >>$F
+fi
+
echo
echo "End of configuration questions. No more user input required"
echo
@@ -187,8 +247,14 @@ echo
echo "==> applying XFree86 patches"
zcat $X11FIXES/XFree86-3.1.2.diff.gz | patch -d $WRKSRC --forward --quiet -E -p1
tar xzf $X11FIXES/cfont312.tgz -C $WRKDIR
-zcat $X11FIXES/3.1.2-3.1.2-S.diff.gz | patch -d $WRKSRC --forward --quiet -E -p1
+zcat $X11FIXES/3.1.2-3.1.2-S.diff.gz | patch -d $WRKSRC --forward --quiet -E -p1
+if [ $k4patch = YES ] ; then
+ echo
+ echo "==> applying Kerberos-V4 support patch"
+ zcat $FILESDIR/kerberos4.diffs.gz | \
+ patch -d $WRKSRC --forward --quiet -E -p1
+fi
cat $F >> $WRKSRC/config/cf/xf86site.def
diff --git a/x11-servers/XFree86-4-Server/distinfo b/x11-servers/XFree86-4-Server/distinfo
index d926e9cffbee..f5632de974ec 100644
--- a/x11-servers/XFree86-4-Server/distinfo
+++ b/x11-servers/XFree86-4-Server/distinfo
@@ -2,4 +2,5 @@ MD5 (xc-1.tar.gz) = b5ae499273bddce4add5b62fc2b0b810
MD5 (xc-2.tar.gz) = e81d2d235dd517c3e36f588221910b03
MD5 (xc-3.tar.gz) = 01bb42c399a542395f0e17a182ba0e96
MD5 (XFree86-3.1.2.diff.gz) = cbb4ca154ed0882b1ee75326089ef4b5
+MD5 (3.1.2-3.1.2-S.diff.gz) = 773acfe51ebbb4e557f4a14905b28f3f
MD5 (cfont312.tgz) = 89a8e082dbbcfc2fd09cfedc47a54ff0
diff --git a/x11-servers/XFree86-4-Server/scripts/configure b/x11-servers/XFree86-4-Server/scripts/configure
index 1d41e71a2f09..8e3892b682db 100644
--- a/x11-servers/XFree86-4-Server/scripts/configure
+++ b/x11-servers/XFree86-4-Server/scripts/configure
@@ -94,6 +94,66 @@ fi
echo
yesno "Do you want your X applications linked with gnu malloc? [YES] "
gnumalloc=$answ
+
+cat <<'END'
+
+ MIT supplies an authentication mechanism that relies upon DES, this is
+ called XDM-AUTHORIZATION-1.
+
+ Source code for this authentication mechanism may not be exported from
+ the United States, however, there are compatible replacements for this
+ mechanism available elsewhere. Also, while this scheme is not used for
+ general purpose encryption, some countries restrict the use of strong
+ cryptography.
+
+ If you have aquired a copy of "Wraphelp.c" and it currently resides in
+ the same location as the XFree86 upgrade patches or in the ports "files"
+ subdirectory, it will be copied into the right place in the X11 source
+ distribution and support for this feature will be enabled if you answer
+ YES to the following question.
+
+ If you do not have a copy of this file, even if you answer YES to this
+ question, support will not be enabled. If you wish to change this later,
+ the option controling this is contined the file xc/config/cf/xf86site.def.
+
+END
+yesno "Do you want to enable XDM-AUTHORIZATION-1 support? [YES] "
+if [ $answ = YES ]; then
+ WH=$WRKDIR/xc/lib/Xdmcp/Wraphelp.c
+
+ if [ -f $WH ] ; then
+ echo "==> $WH found in source distribution."
+ elif [ -f $X11FIXES/Wraphelp.c ] ; then
+ echo "==> Wraphelp.c found in fix directory, copying to source tree."
+ cp $X11FIXES/Wraphelp.c $WH
+ elif [ -f $FILESDIR/Wraphelp.c ] ; then
+ echo "==> Wraphelp.c found in files directory, copying to source tree."
+ cp $FILESDIR/Wraphelp.c $WH
+ else
+ echo "==> Wraphelp.c not found, DES support NOT enabled."
+ answ=NO
+ fi
+fi
+echo "#undef HadXdmAuth" >> $F
+echo "#define HasXdmAuth $answ" >> $F
+
+cat <<'END'
+
+ Additional support for Kerberos V4 is available should you chose to
+ install it. If you choose to install the Kerberos V4 patches, you
+ will also be asked if you want to enable Kerberos V4 support.
+
+END
+
+yesno "Do you want to add the Kerberos V4 support patches? [YES] "
+k4patch=$answ
+if [ $k4patch = YES ] ; then
+ echo
+ yesno "Do you want to enable Kerberos V4 support? [YES] "
+ echo "#undef HasKrb4" >>$F
+ echo "#define HasKrb4 $answ" >>$F
+fi
+
echo
echo "End of configuration questions. No more user input required"
echo
@@ -187,8 +247,14 @@ echo
echo "==> applying XFree86 patches"
zcat $X11FIXES/XFree86-3.1.2.diff.gz | patch -d $WRKSRC --forward --quiet -E -p1
tar xzf $X11FIXES/cfont312.tgz -C $WRKDIR
-zcat $X11FIXES/3.1.2-3.1.2-S.diff.gz | patch -d $WRKSRC --forward --quiet -E -p1
+zcat $X11FIXES/3.1.2-3.1.2-S.diff.gz | patch -d $WRKSRC --forward --quiet -E -p1
+if [ $k4patch = YES ] ; then
+ echo
+ echo "==> applying Kerberos-V4 support patch"
+ zcat $FILESDIR/kerberos4.diffs.gz | \
+ patch -d $WRKSRC --forward --quiet -E -p1
+fi
cat $F >> $WRKSRC/config/cf/xf86site.def