aboutsummaryrefslogtreecommitdiff
path: root/x11-servers
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-12-12 18:38:28 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-12-12 18:38:28 +0000
commit4e06c5d4b81ac13fd33ec8acca0816dfb9844816 (patch)
tree6a36c58031c8490a7ddd52c1802d6a1222e5ce5c /x11-servers
parent3b9a8a38241d1256e82ec91f4af861086ea8f9cc (diff)
downloadports-4e06c5d4b81ac13fd33ec8acca0816dfb9844816.tar.gz
ports-4e06c5d4b81ac13fd33ec8acca0816dfb9844816.zip
- OPTIONS'ify.
- Fix build and register dependency when compiled with HAL support.
Notes
Notes: svn path=/head/; revision=203377
Diffstat (limited to 'x11-servers')
-rw-r--r--x11-servers/xorg-dmx/Makefile14
-rw-r--r--x11-servers/xorg-dmx/files/patch-hw_dmx_Makefile.in10
-rw-r--r--x11-servers/xorg-dmx/files/patch-hw_dmx_dmxinput.c17
3 files changed, 40 insertions, 1 deletions
diff --git a/x11-servers/xorg-dmx/Makefile b/x11-servers/xorg-dmx/Makefile
index a62198ab80a2..b8626d13751a 100644
--- a/x11-servers/xorg-dmx/Makefile
+++ b/x11-servers/xorg-dmx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xorg-dmx
PORTVERSION= 1.4
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= x11-servers
@@ -35,4 +36,15 @@ MAN1= Xdmx.1 dmxtodmx.1 vdltodmx.1 xdmxconfig.1
do-install:
cd ${WRKSRC}/hw/dmx; ${MAKE} install
-.include <bsd.port.mk>
+OPTIONS= HAL "Compile with HAL config support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_HAL)
+LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
+CONFIGURE_ARGS+= --enable-config-hal=yes
+.else
+CONFIGURE_ARGS+= --enable-config-hal=no
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-servers/xorg-dmx/files/patch-hw_dmx_Makefile.in b/x11-servers/xorg-dmx/files/patch-hw_dmx_Makefile.in
new file mode 100644
index 000000000000..be7571e1aefa
--- /dev/null
+++ b/x11-servers/xorg-dmx/files/patch-hw_dmx_Makefile.in
@@ -0,0 +1,10 @@
+--- hw/dmx/Makefile.in.orig 2007-12-12 17:55:26.000000000 +0000
++++ hw/dmx/Makefile.in 2007-12-12 17:55:56.000000000 +0000
+@@ -476,6 +476,7 @@
+ Xdmx_LDADD = $(XORG_CORE_LIBS) \
+ $(XDMX_LIBS) \
+ $(GLX_LIBS) \
++ $(XSERVER_LIBS) \
+ input/libdmxinput.a \
+ config/libdmxconfig.a \
+ @DMXMODULES_LIBS@
diff --git a/x11-servers/xorg-dmx/files/patch-hw_dmx_dmxinput.c b/x11-servers/xorg-dmx/files/patch-hw_dmx_dmxinput.c
new file mode 100644
index 000000000000..c860dc10b278
--- /dev/null
+++ b/x11-servers/xorg-dmx/files/patch-hw_dmx_dmxinput.c
@@ -0,0 +1,17 @@
+--- hw/dmx/dmxinput.c.orig 2007-12-12 17:52:53.000000000 +0000
++++ hw/dmx/dmxinput.c 2007-12-12 17:53:22.000000000 +0000
+@@ -105,3 +105,14 @@
+ if (!dmxInput->detached && dmxInput->updateWindowInfo)
+ dmxInput->updateWindowInfo(dmxInput, type, pWindow);
+ }
++
++int
++NewInputDeviceRequest(InputOption *options, DeviceIntPtr *pdev)
++{
++ return BadValue;
++}
++
++void
++DeleteInputDeviceRequest(DeviceIntPtr dev)
++{
++}