aboutsummaryrefslogtreecommitdiff
path: root/x11-servers
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-08-12 18:35:37 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-08-12 18:35:37 +0000
commitf6c848659e70e7d31289bd7d3b927fe037655162 (patch)
tree0171dcce959cf8bc4aa5880e2f3dfdf691b7a0f5 /x11-servers
parente235486a470e8420c88533e090e20562c89de4da (diff)
downloadports-f6c848659e70e7d31289bd7d3b927fe037655162.tar.gz
ports-f6c848659e70e7d31289bd7d3b927fe037655162.zip
[1] Fix xdmcp queries in the X servers (bug 277)
[2] Fix underlining in the freetype backend (bug 330) PR: [1] ports/52387 [2] ports/55134 Submitted by: [1] Joel Ray Holveck <joelh@piqnet.org> [2] Ariff Abdullah <skywizard@MyBSD.org.my>
Notes
Notes: svn path=/head/; revision=86852
Diffstat (limited to 'x11-servers')
-rw-r--r--x11-servers/XFree86-4-NestServer/Makefile2
-rw-r--r--x11-servers/XFree86-4-Server/Makefile4
-rw-r--r--x11-servers/XFree86-4-Server/files/patch-ftfuncs.c16
-rw-r--r--x11-servers/XFree86-4-VirtualFramebufferServer/Makefile2
4 files changed, 20 insertions, 4 deletions
diff --git a/x11-servers/XFree86-4-NestServer/Makefile b/x11-servers/XFree86-4-NestServer/Makefile
index 0f091c248606..7128611c7a82 100644
--- a/x11-servers/XFree86-4-NestServer/Makefile
+++ b/x11-servers/XFree86-4-NestServer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= NestServer
PORTVERSION= 4.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-servers
MASTER_SITES= ${MASTER_SITE_XFREE:S/$/:x/} \
${MASTER_SITE_LOCAL:S/$/:local/}
diff --git a/x11-servers/XFree86-4-Server/Makefile b/x11-servers/XFree86-4-Server/Makefile
index 63f9b1ce71d5..c156a2963c0d 100644
--- a/x11-servers/XFree86-4-Server/Makefile
+++ b/x11-servers/XFree86-4-Server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Server
PORTVERSION= 4.3.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= x11-servers
MASTER_SITES= ${MASTER_SITE_XFREE:S/$/:x/} \
${MASTER_SITE_LOCAL:S/$/:local/}
@@ -35,7 +35,7 @@ COMMENT= XFree86-4 X server and related programs
patch-compiler.h patch-os-support_Imakefile patch-bsd_Imakefile \
patch-freebsdPci.c patch-bus_Imakefile patch-xf86Sbus.h patch-loader.c \
patch-Sbus.c patch-elfloader.c patch-xfree86.cf patch-FreeBSD.cf \
- patch-sunffb_Imakefile patch-xf86sym.c patch-xf86Events.c
+ patch-sunffb_Imakefile patch-xf86sym.c patch-xf86Events.c patch-ftfuncs.c
EXTRA_PATCHES+= ${FILESDIR}/${pf}
.endfor
SCRIPTS_ENV= OSVERSION=${OSVERSION} \
diff --git a/x11-servers/XFree86-4-Server/files/patch-ftfuncs.c b/x11-servers/XFree86-4-Server/files/patch-ftfuncs.c
new file mode 100644
index 000000000000..91fa2471a90f
--- /dev/null
+++ b/x11-servers/XFree86-4-Server/files/patch-ftfuncs.c
@@ -0,0 +1,16 @@
+--- lib/font/FreeType/ftfuncs.c~ 2003-02-13 06:01:45.000000000 +0300
++++ lib/font/FreeType/ftfuncs.c 2003-03-04 20:27:16.000000000 +0300
+@@ -959,11 +959,11 @@
+ int underlinePosition, underlineThickness;
+
+ if(post) {
+- underlinePosition = TRANSFORM_FUNITS_Y(post->underlinePosition);
++ underlinePosition = TRANSFORM_FUNITS_Y(-post->underlinePosition);
+ underlineThickness = TRANSFORM_FUNITS_Y(post->underlineThickness);
+ } else {
+ underlinePosition =
+- TRANSFORM_FUNITS_Y(t1info->underline_position);
++ TRANSFORM_FUNITS_Y(-t1info->underline_position);
+ underlineThickness =
+ TRANSFORM_FUNITS_Y(t1info->underline_thickness);
+ } \ No newline at end of file
diff --git a/x11-servers/XFree86-4-VirtualFramebufferServer/Makefile b/x11-servers/XFree86-4-VirtualFramebufferServer/Makefile
index 0810fe46ed18..d0f8988314e9 100644
--- a/x11-servers/XFree86-4-VirtualFramebufferServer/Makefile
+++ b/x11-servers/XFree86-4-VirtualFramebufferServer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= VirtualFramebufferServer
PORTVERSION= 4.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-servers
MASTER_SITES= ${MASTER_SITE_XFREE:S/$/:x/} \
${MASTER_SITE_LOCAL:S/$/:local/}