aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/e17-splash-azul/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-07 08:10:24 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-07 08:10:24 +0000
commit0e5347d7bfd87616c242ee97c82cde8b92ddf864 (patch)
treebd315716598ae75557cfd0edb392597f4522b86d /x11-themes/e17-splash-azul/Makefile
parent27d94a06dec3fd704e91e2a84dae67274bc6ce74 (diff)
downloadports-0e5347d7bfd87616c242ee97c82cde8b92ddf864.tar.gz
ports-0e5347d7bfd87616c242ee97c82cde8b92ddf864.zip
Add e17-splash-azul 1.0, azul splash screen for e17 window manager.
PR: ports/101375 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Notes
Notes: svn path=/head/; revision=169924
Diffstat (limited to 'x11-themes/e17-splash-azul/Makefile')
-rw-r--r--x11-themes/e17-splash-azul/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-themes/e17-splash-azul/Makefile b/x11-themes/e17-splash-azul/Makefile
new file mode 100644
index 000000000000..c8b5dcdbbee6
--- /dev/null
+++ b/x11-themes/e17-splash-azul/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: e17-splash-azul
+# Date created: 4 Aug 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= azul
+PORTVERSION= 1.0
+CATEGORIES= x11-themes
+MASTER_SITES= http://www0.get-e.org/Themes/Startup/_files/
+PKGNAMEPREFIX= e17-splash-
+DISTNAME= init_azul
+EXTRACT_SUFX= .edj
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= Azul splash screen for e17 window manager
+
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
+
+USE_X_PREFIX= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= share/enlightenment/data/init/init_azul.edj
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/enlightenment/data/init
+ ${INSTALL_DATA} ${WRKSRC}/${DISTFILES} \
+ ${PREFIX}/share/enlightenment/data/init
+
+.include <bsd.port.mk>