aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gtk-engines2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-10 05:22:13 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-10 05:22:13 +0000
commit610ae5681637c1051a0c17b54e29d97f53da2f3a (patch)
treec231a1eb74b07e444fa7363012cb84bf23d83ce0 /x11-themes/gtk-engines2/Makefile
parent15b6544926b07a98710eeb765baf03e3fc9a195c (diff)
downloadports-610ae5681637c1051a0c17b54e29d97f53da2f3a.tar.gz
ports-610ae5681637c1051a0c17b54e29d97f53da2f3a.zip
Presenting GNOME 2.24 for FreeBSD.
See http://library.gnome.org/misc/release-notes/2.24/ for the general release notes. On the FreeBSD front, this release introduces Fuse support in HAL, adds multi-CPU support to libgtop, WebKit updates, and fixes some long-standing seahorse and gnome-keyring bugs. The documentation updates to the website are forthcoming. This release features commits by adamw, ahze, kwm, mezz, and myself. It would not have been possible without are contributors and testers: Alexander Loginov Craig Butler [1] Dmitry Marakasov [6] Eric L. Chen Joseph S. Atkinson Kris Moore Lapo Luchini [7] Nikos Ntarmos Pawel Worach Romain Tartiere TAOKA Fumiyoshi [3] Yasuda Keisuke Zyl aZ [4] bf [2] [5] Florent Thoumie Peter Wemm pluknet PR: 125857 [1] 126993 [2] 130031 [3] 127399 [4] 127661 [5] 124302 [6] 129570 [7] 129936 123790
Notes
Notes: svn path=/head/; revision=225629
Diffstat (limited to 'x11-themes/gtk-engines2/Makefile')
-rw-r--r--x11-themes/gtk-engines2/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/x11-themes/gtk-engines2/Makefile b/x11-themes/gtk-engines2/Makefile
index d86e0ca9b8b3..9c98f0049882 100644
--- a/x11-themes/gtk-engines2/Makefile
+++ b/x11-themes/gtk-engines2/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11-themes/gtk-engines2/Makefile,v 1.59 2008/03/18 12:15:18 ahze Exp $
+# $MCom: ports/x11-themes/gtk-engines2/Makefile,v 1.69 2009/01/10 01:59:22 mezz Exp $
#
PORTNAME= gtk-engines2
-PORTVERSION= 2.14.3
+PORTVERSION= 2.16.1
CATEGORIES= x11-themes
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -15,14 +15,14 @@ DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= Theme engine for the Gtk+-2.0 toolkit
+COMMENT= Theme engine for the GTK+-2.0 toolkit
CONFLICTS= gtk-smooth-engine-[0-9]* clearlooks-[0-9]*
USE_GMAKE= yes
USE_BZIP2= yes
USE_GNOME= gnomehack gtk20 intlhack ltasneededhack
-#USE_GETTEXT= yes
+USE_GETTEXT= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
@@ -35,4 +35,7 @@ OPTIONS= ANIMATION "Enable experimental animated progressbars" off
CONFIGURE_ARGS+= --enable-animation
.endif
+post-install:
+ @(cd ${WRKSRC}/po && ${GMAKE} install)
+
.include <bsd.port.post.mk>