aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gtk-engines2/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>1999-01-30 19:42:47 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>1999-01-30 19:42:47 +0000
commit8c60a5a8fcb156e60830773709d7b9ae2298464f (patch)
tree11314fdf8647ce2375b8f4d498c839520b23b5ba /x11-themes/gtk-engines2/Makefile
parent88dfcd3fce9d5eb8eea3f822dc9242519775d5bd (diff)
downloadports-8c60a5a8fcb156e60830773709d7b9ae2298464f.tar.gz
ports-8c60a5a8fcb156e60830773709d7b9ae2298464f.zip
Submitter say:
"The biggest change is to the gtk-engines port, where I've made the gtkrc files get the correct prefix. I've added the path to all the files, which may be overkill (it's only really needed for the pixmap theme), but was easier to do in an automated way, and provides a better example for people making their own themes." Submitted by: Jeremy Lea <reg@shale.csir.co.za>
Notes
Notes: svn path=/head/; revision=16434
Diffstat (limited to 'x11-themes/gtk-engines2/Makefile')
-rw-r--r--x11-themes/gtk-engines2/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/x11-themes/gtk-engines2/Makefile b/x11-themes/gtk-engines2/Makefile
index bb7b87ade3dc..6e23b568eed7 100644
--- a/x11-themes/gtk-engines2/Makefile
+++ b/x11-themes/gtk-engines2/Makefile
@@ -3,7 +3,7 @@
# Date Created: 23 Dec 1998
# Whom: Vanilla I. Shu <vanilla@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.3 1999/01/26 02:22:29 foxfair Exp $
+# $Id: Makefile,v 1.4 1999/01/27 08:31:54 fenner Exp $
#
DISTNAME= gtk-engines-0.1
@@ -19,8 +19,16 @@ LIB_DEPENDS= gtk11d.1:${PORTSDIR}/x11-toolkits/gtk11-devel \
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk11d-config" \
- GLIB_CONFIG="${LOCALBASE}/bin/glib11d-config"
+CONFIGURE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk11d-config"
+
+THEMES= metal notif pixmap redmond95
+
+post-patch:
+ @for theme in ${THEMES}; do \
+ cd ${WRKSRC}/$$theme/Theme/gtk; \
+ ${MV} gtkrc gtkrc.tmp; \
+ ${SED} -e s^%%PREFIX%%^${PREFIX}^g < gtkrc.tmp > gtkrc; \
+ done
post-install:
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib