aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gtk-engines2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /x11-themes/gtk-engines2
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
downloadports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.tar.gz
ports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.zip
Presenting GNOME 2.10 for FreeBSD!
The release notes can be found at http://www.gnome.org/start/2.10/notes/rnwhatsnew.html, and will give you a good idea of what has gone into this release overall. However, a lot of FreeBSD specific additions and fixes have been made. For example, this release offers fixed ACPI support as well as new CPU freqeuncy monitoring support. See the FreeBSD GNOME 2.10 upgrade page at http://www.FreeBSD.org/gnome/docs/faq210.html for the entire list as well as a list of known issues and upgrade instructions. GNOME 2.10, as well as all of our releases, would not be possible without the great team that goes into porting and testign each and every component. Thanks definitely goes out to ahze, adamw, bland, kwm, mezz, and pav for all their work. We would also like to thank our adventurous users that chose to ride the walrus. We'd especially like to thank the following users that provided patches for GNOME 2.10: ade Yasuda Keisuke Franz Klammer Khairil Yusof Radek Kozlowsk And anyone else I may have accidentally omitted. As with GNOME 2.8, 2.10 comes with a brand-spankin' new splashscreen courtesy of Franz Klammer. However, unlike GNOME 2.8, we've included all of the FreeBSD GNOME splashscreen entries with gnomesession. You can use the deskutils/splashsetter port to choose the one you like best. As always, GNOME users should _not_ use portupgrade alone to upgrade to 2.10. Instead, get the gnome_upgrade.sh script from http://www.FreeBSD.org/gnome/gnome_upgrade.sh. Enjoy!
Notes
Notes: svn path=/head/; revision=130972
Diffstat (limited to 'x11-themes/gtk-engines2')
-rw-r--r--x11-themes/gtk-engines2/Makefile18
-rw-r--r--x11-themes/gtk-engines2/distinfo4
-rw-r--r--x11-themes/gtk-engines2/files/patch-engines_crux_src_crux-gradient.c31
-rw-r--r--x11-themes/gtk-engines2/files/patch-engines_industrial_src_industrial_style.c10
-rw-r--r--x11-themes/gtk-engines2/files/patch-pixbuf_pixbuf-draw.c11
-rw-r--r--x11-themes/gtk-engines2/pkg-plist107
6 files changed, 152 insertions, 29 deletions
diff --git a/x11-themes/gtk-engines2/Makefile b/x11-themes/gtk-engines2/Makefile
index f38c53bb4745..ce8640dfc4c4 100644
--- a/x11-themes/gtk-engines2/Makefile
+++ b/x11-themes/gtk-engines2/Makefile
@@ -6,30 +6,28 @@
#
PORTNAME= gtk-engines2
-PORTVERSION= 2.2.0
-PORTREVISION= 6
+PORTVERSION= 2.6.2
CATEGORIES= x11-themes
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.6
DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Theme engine for the gtk+-2.0 toolkit
+CONFLICTS= gtk-smooth-engine-[0-9]*
+
USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
USE_LIBTOOL_VER=15
USE_GNOME= gnomehack gtk20
PLIST_SUB= GTK_VERSION="2.4.0"
-THEMES= metal redmond95
-
+# Disable the gtk1 theme.
post-patch:
- @for theme in ${THEMES}; do \
- cd ${WRKSRC}/$$theme/Theme/gtk-2.0; \
- ${MV} gtkrc gtkrc.tmp; \
- ${SED} -e s^%%PREFIX%%^${PREFIX}^g < gtkrc.tmp > gtkrc; \
- done
+ @${REINPLACE_CMD} -e 's|gtk gtk-2.0|gtk-2.0|' \
+ ${WRKSRC}/themes/Redmond/Makefile.in
.include <bsd.port.mk>
diff --git a/x11-themes/gtk-engines2/distinfo b/x11-themes/gtk-engines2/distinfo
index c1a36b1eebbf..39e695fd0838 100644
--- a/x11-themes/gtk-engines2/distinfo
+++ b/x11-themes/gtk-engines2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gtk-engines-2.2.0.tar.bz2) = 78e9276c28b509f3203de4873c20a263
-SIZE (gnome2/gtk-engines-2.2.0.tar.bz2) = 401883
+MD5 (gnome2/gtk-engines-2.6.2.tar.bz2) = 11f9a1dcabf002aa904facac4293c1fd
+SIZE (gnome2/gtk-engines-2.6.2.tar.bz2) = 444092
diff --git a/x11-themes/gtk-engines2/files/patch-engines_crux_src_crux-gradient.c b/x11-themes/gtk-engines2/files/patch-engines_crux_src_crux-gradient.c
new file mode 100644
index 000000000000..ec5a85340f62
--- /dev/null
+++ b/x11-themes/gtk-engines2/files/patch-engines_crux_src_crux-gradient.c
@@ -0,0 +1,31 @@
+--- engines/crux/src/crux-gradient.c.orig Thu Oct 16 20:57:05 2003
++++ engines/crux/src/crux-gradient.c Thu Oct 16 21:01:18 2003
+@@ -207,7 +207,7 @@
+ const eazel_engine_gradient *gradient)
+ {
+ int rgb_size = clip_rect->height;
+- guchar *rgb = alloca (rgb_size * 3), *ptr;
++ guchar *rgb = g_malloc (rgb_size * 3), *ptr;
+
+ eazel_engine_fill_gradient_rgb_buffer (gradient, full_rect->height, rgb,
+ clip_rect->y - full_rect->y,
+@@ -239,7 +239,7 @@
+ }
+ else
+ {
+- guchar *xrgb = alloca (clip_rect->width * clip_rect->height * 3);
++ guchar *xrgb = g_malloc (clip_rect->width * clip_rect->height * 3);
+ int x, y;
+ guchar *ptr_in = rgb, *ptr_out = xrgb;
+ for (y = 0; y < clip_rect->height; y++)
+@@ -257,7 +257,10 @@
+ gdk_draw_rgb_image (drawable, gc, clip_rect->x, clip_rect->y,
+ clip_rect->width, clip_rect->height,
+ dither_mode, xrgb, clip_rect->width * 3);
++ g_free (xrgb);
+ }
++
++ g_free (rgb);
+ }
+
+ static void
diff --git a/x11-themes/gtk-engines2/files/patch-engines_industrial_src_industrial_style.c b/x11-themes/gtk-engines2/files/patch-engines_industrial_src_industrial_style.c
new file mode 100644
index 000000000000..f545a6a65ec5
--- /dev/null
+++ b/x11-themes/gtk-engines2/files/patch-engines_industrial_src_industrial_style.c
@@ -0,0 +1,10 @@
+--- engines/industrial/src/industrial_style.c.orig Tue Mar 16 16:55:11 2004
++++ engines/industrial/src/industrial_style.c Tue Mar 16 16:58:23 2004
+@@ -1801,6 +1801,7 @@
+ gint width,
+ gint height)
+ {
++ g_return_if_fail (widget != NULL);
+ #if DEBUG
+ printf ("draw_shadow: %p %p %s %i %i %i %i\n", widget, window, detail, x, y,
+ width, height);
diff --git a/x11-themes/gtk-engines2/files/patch-pixbuf_pixbuf-draw.c b/x11-themes/gtk-engines2/files/patch-pixbuf_pixbuf-draw.c
deleted file mode 100644
index 7d26e2d451bf..000000000000
--- a/x11-themes/gtk-engines2/files/patch-pixbuf_pixbuf-draw.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- pixbuf/pixbuf-draw.c.orig Mon Aug 23 11:59:28 2004
-+++ pixbuf/pixbuf-draw.c Mon Aug 23 12:00:13 2004
-@@ -75,7 +75,7 @@
- continue;
-
- if (image->match_data.detail &&
-- (!image->match_data.detail ||
-+ (!match_data->detail ||
- strcmp (match_data->detail, image->match_data.detail) != 0))
- continue;
-
diff --git a/x11-themes/gtk-engines2/pkg-plist b/x11-themes/gtk-engines2/pkg-plist
index 5f867a912e1c..9d469f0d6c79 100644
--- a/x11-themes/gtk-engines2/pkg-plist
+++ b/x11-themes/gtk-engines2/pkg-plist
@@ -1,12 +1,107 @@
+lib/gtk-2.0/%%GTK_VERSION%%/engines/libcrux-engine.so
+lib/gtk-2.0/%%GTK_VERSION%%/engines/libhcengine.so
+lib/gtk-2.0/%%GTK_VERSION%%/engines/libindustrial.so
+lib/gtk-2.0/%%GTK_VERSION%%/engines/liblighthouseblue.so
lib/gtk-2.0/%%GTK_VERSION%%/engines/libmetal.so
-lib/gtk-2.0/%%GTK_VERSION%%/engines/libpixmap.so
+lib/gtk-2.0/%%GTK_VERSION%%/engines/libmist.so
lib/gtk-2.0/%%GTK_VERSION%%/engines/libredmond95.so
+lib/gtk-2.0/%%GTK_VERSION%%/engines/libsmooth.so
+lib/gtk-2.0/%%GTK_VERSION%%/engines/libthinice.so
libdata/pkgconfig/gtk-engines-2.pc
-share/themes/Metal/README.html
+share/themes/Crux/gtk-2.0/gtkrc
+share/themes/Crux/pixmaps/arrow_down-spinner.png
+share/themes/Crux/pixmaps/arrow_down.png
+share/themes/Crux/pixmaps/arrow_left.png
+share/themes/Crux/pixmaps/arrow_right.png
+share/themes/Crux/pixmaps/arrow_up-spinner.png
+share/themes/Crux/pixmaps/arrow_up.png
+share/themes/Crux/pixmaps/check-active-default-focus.png
+share/themes/Crux/pixmaps/check-active-default.png
+share/themes/Crux/pixmaps/check-active-hilight-focus.png
+share/themes/Crux/pixmaps/check-active-hilight.png
+share/themes/Crux/pixmaps/check-active-insensitive.png
+share/themes/Crux/pixmaps/check-active-pressed-focus.png
+share/themes/Crux/pixmaps/check-active-pressed.png
+share/themes/Crux/pixmaps/check-default-focus.png
+share/themes/Crux/pixmaps/check-default.png
+share/themes/Crux/pixmaps/check-hilight-focus.png
+share/themes/Crux/pixmaps/check-hilight.png
+share/themes/Crux/pixmaps/check-insensitive.png
+share/themes/Crux/pixmaps/check-pressed-focus.png
+share/themes/Crux/pixmaps/check-pressed.png
+share/themes/Crux/pixmaps/progressbar-left.png
+share/themes/Crux/pixmaps/progressbar-right.png
+share/themes/Crux/pixmaps/progressbar.png
+share/themes/Crux/pixmaps/progressbar_trough.png
+share/themes/Crux/pixmaps/radio-active-default-focus.png
+share/themes/Crux/pixmaps/radio-active-default.png
+share/themes/Crux/pixmaps/radio-active-hilight-focus.png
+share/themes/Crux/pixmaps/radio-active-hilight.png
+share/themes/Crux/pixmaps/radio-active-insensitive.png
+share/themes/Crux/pixmaps/radio-active-pressed-focus.png
+share/themes/Crux/pixmaps/radio-active-pressed.png
+share/themes/Crux/pixmaps/radio-default-focus.png
+share/themes/Crux/pixmaps/radio-default.png
+share/themes/Crux/pixmaps/radio-hilight-focus.png
+share/themes/Crux/pixmaps/radio-hilight.png
+share/themes/Crux/pixmaps/radio-insensitive.png
+share/themes/Crux/pixmaps/radio-pressed-focus.png
+share/themes/Crux/pixmaps/radio-pressed.png
+share/themes/Crux/pixmaps/scroller-arrow-down-hilight.png
+share/themes/Crux/pixmaps/scroller-arrow-down-pressed.png
+share/themes/Crux/pixmaps/scroller-arrow-down.png
+share/themes/Crux/pixmaps/scroller-arrow-left-hilight.png
+share/themes/Crux/pixmaps/scroller-arrow-left-pressed.png
+share/themes/Crux/pixmaps/scroller-arrow-left.png
+share/themes/Crux/pixmaps/scroller-arrow-right-hilight.png
+share/themes/Crux/pixmaps/scroller-arrow-right-pressed.png
+share/themes/Crux/pixmaps/scroller-arrow-right.png
+share/themes/Crux/pixmaps/scroller-arrow-up-hilight.png
+share/themes/Crux/pixmaps/scroller-arrow-up-pressed.png
+share/themes/Crux/pixmaps/scroller-arrow-up.png
+share/themes/Crux/pixmaps/scroller-h-hilight.png
+share/themes/Crux/pixmaps/scroller-h-thumb-hilight.png
+share/themes/Crux/pixmaps/scroller-h-thumb.png
+share/themes/Crux/pixmaps/scroller-h-trough.png
+share/themes/Crux/pixmaps/scroller-h.png
+share/themes/Crux/pixmaps/scroller-v-hilight.png
+share/themes/Crux/pixmaps/scroller-v-thumb-hilight.png
+share/themes/Crux/pixmaps/scroller-v-thumb.png
+share/themes/Crux/pixmaps/scroller-v-trough.png
+share/themes/Crux/pixmaps/scroller-v.png
+share/themes/Crux/pixmaps/slider_h_thumb.png
+share/themes/Crux/pixmaps/slider_h_trough.png
+share/themes/Crux/pixmaps/slider_h_trough_focus.png
+share/themes/Crux/pixmaps/slider_v_thumb.png
+share/themes/Crux/pixmaps/slider_v_trough.png
+share/themes/Crux/pixmaps/slider_v_trough_focus.png
+share/themes/Crux/pixmaps/tab_left-unsel.png
+share/themes/Crux/pixmaps/tab_left.png
+share/themes/Crux/pixmaps/tab_right.png
+share/themes/Crux/pixmaps/tab_sel-bottom.png
+share/themes/Crux/pixmaps/tab_sel.png
+share/themes/Crux/pixmaps/tab_usel-bottom-left.png
+share/themes/Crux/pixmaps/tab_usel-bottom.png
+share/themes/Crux/pixmaps/tab_usel-left.png
+share/themes/Crux/pixmaps/tab_usel.png
+share/themes/Industrial/gtk-2.0/gtkrc
+share/themes/LighthouseBlue/gtk-2.0/gtkrc
share/themes/Metal/gtk-2.0/gtkrc
-share/themes/Redmond95/README.html
-share/themes/Redmond95/gtk-2.0/gtkrc
-@dirrm share/themes/Redmond95/gtk-2.0
+share/themes/Mist/gtk-2.0/gtkrc
+share/themes/Redmond/gtk-2.0/gtkrc
+share/themes/ThinIce/gtk-2.0/gtkrc
+@dirrm share/themes/ThinIce/gtk-2.0
+@dirrm share/themes/Redmond/gtk-2.0
+@dirrm share/themes/Mist/gtk-2.0
@dirrm share/themes/Metal/gtk-2.0
-@unexec /bin/rmdir %D/share/themes/Redmond95 2>/dev/null || /usr/bin/true
+@dirrm share/themes/LighthouseBlue/gtk-2.0
+@dirrm share/themes/Industrial/gtk-2.0
+@dirrm share/themes/Crux/pixmaps
+@dirrm share/themes/Crux/gtk-2.0
+@unexec /bin/rmdir %D/share/themes/ThinIce 2>/dev/null || true
+@unexec /bin/rmdir %D/share/themes/Redmond 2>/dev/null || true
+@unexec /bin/rmdir %D/share/themes/Mist 2>/dev/null || true
@unexec /bin/rmdir %D/share/themes/Metal 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/share/themes/LighthouseBlue 2>/dev/null || true
+@unexec /bin/rmdir %D/share/themes/Industrial 2>/dev/null || true
+@unexec /bin/rmdir %D/share/themes/Crux 2>/dev/null || true