aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/phase
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-08-01 18:47:11 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-08-01 18:47:11 +0000
commitc7a556e470e0e1cc740e9e84db459f910c88cd1e (patch)
tree1ecc3cf810ea92214ece4c4db3a1fcbee314351b /x11-themes/phase
parentb9f21a8c3b845468c59b6bb21366e49f1de66965 (diff)
downloadports-c7a556e470e0e1cc740e9e84db459f910c88cd1e.tar.gz
ports-c7a556e470e0e1cc740e9e84db459f910c88cd1e.zip
Add phase, a Qt/KDE widget style
PR: 68885 Submitted by: David Johnson <david@usermode.org>
Notes
Notes: svn path=/head/; revision=115215
Diffstat (limited to 'x11-themes/phase')
-rw-r--r--x11-themes/phase/Makefile21
-rw-r--r--x11-themes/phase/distinfo2
-rw-r--r--x11-themes/phase/files/patch-phasestyle.cc29
-rw-r--r--x11-themes/phase/pkg-descr7
-rw-r--r--x11-themes/phase/pkg-plist11
5 files changed, 70 insertions, 0 deletions
diff --git a/x11-themes/phase/Makefile b/x11-themes/phase/Makefile
new file mode 100644
index 000000000000..381f41378d1c
--- /dev/null
+++ b/x11-themes/phase/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: Phase
+# Date created: July 9th, 2004
+# Whom: David Johnson <david@usermode.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phase
+PORTVERSION= 0.4
+CATEGORIES= x11-themes kde
+MASTER_SITES= http://www.usermode.org/code/
+
+MAINTAINER= david@usermode.org
+COMMENT= An original Qt/KDE widget style
+
+USE_KDEBASE_VER=3
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/x11-themes/phase/distinfo b/x11-themes/phase/distinfo
new file mode 100644
index 000000000000..70b7d9e79e74
--- /dev/null
+++ b/x11-themes/phase/distinfo
@@ -0,0 +1,2 @@
+MD5 (phase-0.4.tar.gz) = 4e5f5bf08e0b185318e5d2d4df5b1b5b
+SIZE (phase-0.4.tar.gz) = 474702
diff --git a/x11-themes/phase/files/patch-phasestyle.cc b/x11-themes/phase/files/patch-phasestyle.cc
new file mode 100644
index 000000000000..4ab6e5dff406
--- /dev/null
+++ b/x11-themes/phase/files/patch-phasestyle.cc
@@ -0,0 +1,29 @@
+--- phasestyle/phasestyle.cc.orig Mon Jul 5 19:38:55 2004
++++ phasestyle/phasestyle.cc Sun Jul 25 20:58:33 2004
+@@ -1085,7 +1085,7 @@
+ case KPE_SliderHandle: {
+ const QSlider* slider = dynamic_cast<const QSlider*>(widget);
+ if (slider) {
+- QColor color = (slider==hover_)
++ QColor color = ((QWidget*)slider==hover_)
+ ? group.button().light(contrast)
+ : group.button();
+ if (slider->orientation() == Horizontal) {
+@@ -1619,7 +1619,7 @@
+
+ sunken = (active == SC_ComboBoxArrow);
+ drawPhaseButton(painter, x, y, w, h, group,
+- (combo==hover_)
++ ((QWidget*)combo==hover_)
+ ? group.button().light(contrast)
+ : group.button(), sunken);
+
+@@ -1774,7 +1774,7 @@
+ if (reverse_) subrect.moveLeft(spin->upRect().left());
+ drawPhaseBevel(painter, subrect.x(), subrect.y(),
+ subrect.width(), subrect.height(), group,
+- (spin==hover_)
++ ((QWidget*)spin==hover_)
+ ? group.button().light(contrast)
+ : group.button(), false, false, false);
+ }
diff --git a/x11-themes/phase/pkg-descr b/x11-themes/phase/pkg-descr
new file mode 100644
index 000000000000..68f44caf3204
--- /dev/null
+++ b/x11-themes/phase/pkg-descr
@@ -0,0 +1,7 @@
+Phase is an original Qt/KDE widget style. It is designed to be functional but
+not drab and aesthetic but not distracting.
+
+WWW: http://www.usermode.org/code.html
+
+- David Johnson
+david@usermode.org
diff --git a/x11-themes/phase/pkg-plist b/x11-themes/phase/pkg-plist
new file mode 100644
index 000000000000..13b7277bcc53
--- /dev/null
+++ b/x11-themes/phase/pkg-plist
@@ -0,0 +1,11 @@
+lib/kde3/kstyle_phase_config.la
+lib/kde3/kstyle_phase_config.so
+lib/kde3/plugins/styles/phasestyle.la
+lib/kde3/plugins/styles/phasestyle.so
+share/apps/kstyle/themes/phase.themerc
+@dirrm share/apps/kstyle/themes
+@dirrm share/apps/kstyle
+@dirrm share/apps
+@dirrm lib/kde3/plugins/styles
+@dirrm lib/kde3/plugins
+@dirrm lib/kde3