aboutsummaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-01-15 21:09:43 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-01-15 21:09:43 +0000
commit29dcc36c0483afe7d16b63e82dc682328d67ce1a (patch)
tree5358cba5fc911706639b6f37afac1926f8225077 /x11-themes
parent21efedc6e0dcef3b438f7451d33c9b59334a270e (diff)
downloadports-29dcc36c0483afe7d16b63e82dc682328d67ce1a.tar.gz
ports-29dcc36c0483afe7d16b63e82dc682328d67ce1a.zip
Fix build on 7.x and drop support for 6.x
Reported by: pointyhat Feature safe: yes
Notes
Notes: svn path=/head/; revision=267863
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/qtcurve-gtk2/Makefile6
-rw-r--r--x11-themes/qtcurve-gtk2/files/extra-patch-style-qt_settings.c18
-rw-r--r--x11-themes/qtcurve-gtk2/files/getline.c1
-rw-r--r--x11-themes/qtcurve-gtk2/files/getline_strndup.c184
4 files changed, 11 insertions, 198 deletions
diff --git a/x11-themes/qtcurve-gtk2/Makefile b/x11-themes/qtcurve-gtk2/Makefile
index d98a7c935cf1..9170297d13e5 100644
--- a/x11-themes/qtcurve-gtk2/Makefile
+++ b/x11-themes/qtcurve-gtk2/Makefile
@@ -32,11 +32,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-style-qt_settings.c
post-extract:
.if ${OSVERSION} < 800067
${CP} ${FILESDIR}/getline.h ${WRKSRC}/style
-.if ${OSVERSION} < 701101
- ${CP} ${FILESDIR}/getline_strndup.c ${WRKSRC}/style/getline.c
-.else
- ${CP} ${FILESDIR}/getline.c ${WRKSRC}/style/getline.c
-.endif
+ ${CP} ${FILESDIR}/getline.c ${WRKSRC}/style
.endif
.include <bsd.port.post.mk>
diff --git a/x11-themes/qtcurve-gtk2/files/extra-patch-style-qt_settings.c b/x11-themes/qtcurve-gtk2/files/extra-patch-style-qt_settings.c
index 6ad7a45ddb18..c5a1d2822f6a 100644
--- a/x11-themes/qtcurve-gtk2/files/extra-patch-style-qt_settings.c
+++ b/x11-themes/qtcurve-gtk2/files/extra-patch-style-qt_settings.c
@@ -1,11 +1,11 @@
---- style/qt_settings.c.o 2010-05-06 14:56:53.000000000 +0000
-+++ style/qt_settings.c 2010-05-06 15:00:46.000000000 +0000
-@@ -22,6 +22,8 @@
- #include "common.h"
- #define CONFIG_READ
- #include "config_file.c"
+--- ./style/qt_settings.c.orig 2011-01-03 00:41:06.000000000 +0300
++++ ./style/qt_settings.c 2011-01-15 21:01:39.529481980 +0300
+@@ -35,6 +35,8 @@
+ #include <dirent.h>
+ #include <errno.h>
+ #include <locale.h>
+#include "getline.h"
+#include "getline.c"
- #include <gtk/gtk.h>
- #include <time.h>
- #include <gdk/gdkcolor.h>
+
+ QtCPalette qtcPalette;
+ Options opts;
diff --git a/x11-themes/qtcurve-gtk2/files/getline.c b/x11-themes/qtcurve-gtk2/files/getline.c
index cdcb2add5e20..1fcf9adece88 100644
--- a/x11-themes/qtcurve-gtk2/files/getline.c
+++ b/x11-themes/qtcurve-gtk2/files/getline.c
@@ -19,6 +19,7 @@ General Public License for more details. */
#endif
#include <sys/types.h>
+#include <stdlib.h>
#include <stdio.h>
#include <assert.h>
#include <errno.h>
diff --git a/x11-themes/qtcurve-gtk2/files/getline_strndup.c b/x11-themes/qtcurve-gtk2/files/getline_strndup.c
deleted file mode 100644
index 2ee51b571409..000000000000
--- a/x11-themes/qtcurve-gtk2/files/getline_strndup.c
+++ /dev/null
@@ -1,184 +0,0 @@
-/* Copyright (C) 1993 Free Software Foundation, Inc.
-
-This program is free software; you can redistribute it and/or
-modify it under the terms of the GNU General Public License as
-published by the Free Software Foundation; either version 2 of the
-License, or (at your option) any later version.
-
-This program is distributed in the hope that it will be useful, but
-WITHOUT ANY WARRANTY; without even the implied warranty of
-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-General Public License for more details. */
-
-#ifdef HAVE_CONFIG_H
-#include <config.h>
-#endif
-
-#include <sys/types.h>
-#include <stdio.h>
-#include <stdlib.h>
-#include <assert.h>
-#include <errno.h>
-#include "getline.h"
-
-/* Always add at least this many bytes when extending the buffer. */
-#define MIN_CHUNK 64
-
-/* Read up to (and including) a TERMINATOR from STREAM into *LINEPTR
- + OFFSET (and null-terminate it). If LIMIT is non-negative, then
- read no more than LIMIT chars.
-
- *LINEPTR is a pointer returned from malloc (or NULL), pointing to
- *N characters of space. It is realloc'd as necessary.
-
- Return the number of characters read (not including the null
- terminator), or -1 on error or EOF. On a -1 return, the caller
- should check feof(), if not then errno has been set to indicate the
- error. */
-
-int
-getstr (lineptr, n, stream, terminator, offset, limit)
- char **lineptr;
- size_t *n;
- FILE *stream;
- int terminator;
- int offset;
- int limit;
-{
- int nchars_avail; /* Allocated but unused chars in *LINEPTR. */
- char *read_pos; /* Where we're reading into *LINEPTR. */
- int ret;
-
- if (!lineptr || !n || !stream)
- {
- errno = EINVAL;
- return -1;
- }
-
- if (!*lineptr)
- {
- *n = MIN_CHUNK;
- *lineptr = malloc (*n);
- if (!*lineptr)
- {
- errno = ENOMEM;
- return -1;
- }
- *lineptr[0] = '\0';
- }
-
- nchars_avail = *n - offset;
- read_pos = *lineptr + offset;
-
- for (;;)
- {
- int save_errno;
- register int c;
-
- if (limit == 0)
- break;
- else
- {
- c = getc (stream);
-
- /* If limit is negative, then we shouldn't pay attention to
- it, so decrement only if positive. */
- if (limit > 0)
- limit--;
- }
-
- save_errno = errno;
-
- /* We always want at least one char left in the buffer, since we
- always (unless we get an error while reading the first char)
- NUL-terminate the line buffer. */
-
- assert((*lineptr + *n) == (read_pos + nchars_avail));
- if (nchars_avail < 2)
- {
- if (*n > MIN_CHUNK)
- *n *= 2;
- else
- *n += MIN_CHUNK;
-
- nchars_avail = *n + *lineptr - read_pos;
- *lineptr = realloc (*lineptr, *n);
- if (!*lineptr)
- {
- errno = ENOMEM;
- return -1;
- }
- read_pos = *n - nchars_avail + *lineptr;
- assert((*lineptr + *n) == (read_pos + nchars_avail));
- }
-
- if (ferror (stream))
- {
- /* Might like to return partial line, but there is no
- place for us to store errno. And we don't want to just
- lose errno. */
- errno = save_errno;
- return -1;
- }
-
- if (c == EOF)
- {
- /* Return partial line, if any. */
- if (read_pos == *lineptr)
- return -1;
- else
- break;
- }
-
- *read_pos++ = c;
- nchars_avail--;
-
- if (c == terminator)
- /* Return the line. */
- break;
- }
-
- /* Done - NUL terminate and return the number of chars read. */
- *read_pos = '\0';
-
- ret = read_pos - (*lineptr + offset);
- return ret;
-}
-
-int
-getline (lineptr, n, stream)
- char **lineptr;
- size_t *n;
- FILE *stream;
-{
- return getstr (lineptr, n, stream, '\n', 0, GETLINE_NO_LIMIT);
-}
-
-int
-getline_safe (lineptr, n, stream, limit)
- char **lineptr;
- size_t *n;
- FILE *stream;
- int limit;
-{
- return getstr (lineptr, n, stream, '\n', 0, limit);
-}
-
-char *
-strndup (str, n)
- const char *str;
- size_t n;
-{
- size_t len;
- char *copy;
-
- len = strlen(str);
- if (n < len)
- len = n;
- copy = malloc(len + 1);
- if (copy == NULL)
- return NULL;
- memcpy(copy, str, len);
- copy[len] = '\0';
- return copy;
-}