aboutsummaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-05-23 15:48:46 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-05-23 15:48:46 +0000
commitfc561b597c438c92edfa7582175cfb085558d2f1 (patch)
tree95f626eef7fdf4155f1964bece3e96523496378e /x11-themes
parenta170ea92f4e316845a2a33877b33b5936fbf77f7 (diff)
downloadports-fc561b597c438c92edfa7582175cfb085558d2f1.tar.gz
ports-fc561b597c438c92edfa7582175cfb085558d2f1.zip
Add gtk-engines2 after repo copy from gtk-engines. Gtk-engines is the theme
engine for GTK+-2.0.
Notes
Notes: svn path=/head/; revision=59807
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-engines2/Makefile25
-rw-r--r--x11-themes/gtk-engines2/distinfo2
-rw-r--r--x11-themes/gtk-engines2/files/patch-configure21
-rw-r--r--x11-themes/gtk-engines2/files/patch-pixmap::pixmap_theme_draw.c74
-rw-r--r--x11-themes/gtk-engines2/files/patch-pixmap_Theme_gtk_gtkrc13
-rw-r--r--x11-themes/gtk-engines2/pkg-comment2
-rw-r--r--x11-themes/gtk-engines2/pkg-descr4
-rw-r--r--x11-themes/gtk-engines2/pkg-plist105
8 files changed, 39 insertions, 207 deletions
diff --git a/x11-themes/gtk-engines2/Makefile b/x11-themes/gtk-engines2/Makefile
index 3dcc75125ae7..3a5c1e165335 100644
--- a/x11-themes/gtk-engines2/Makefile
+++ b/x11-themes/gtk-engines2/Makefile
@@ -1,28 +1,33 @@
-# New ports collection makefile for: gtk-engines
-# Date Created: 23 Dec 1998
-# Whom: Vanilla I. Shu <vanilla@FreeBSD.org>
+# New ports collection makefile for: gtk-engines2
+# Date Created: 21 May 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= gtk-engines
-PORTVERSION= 0.12
-PORTREVISION= 2
+PORTNAME= gtk-engines2
+PORTVERSION= 1.9.0
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= stable/sources/gtk-engines
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta5
+DISTNAME= gtk-engines-${PORTVERSION}
+DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
+LIB_DEPENDS= gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20
+
+USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_IMLIB= yes
USE_LIBTOOL= yes
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+PLIST_SUB= VERSION=2.0.0
-THEMES= metal notif pixmap raleigh redmond95
+THEMES= metal redmond95
post-patch:
@for theme in ${THEMES}; do \
- cd ${WRKSRC}/$$theme/Theme/gtk; \
+ cd ${WRKSRC}/$$theme/Theme/gtk-2.0; \
${MV} gtkrc gtkrc.tmp; \
${SED} -e s^%%PREFIX%%^${PREFIX}^g < gtkrc.tmp > gtkrc; \
done
diff --git a/x11-themes/gtk-engines2/distinfo b/x11-themes/gtk-engines2/distinfo
index 2ad4263586fd..a025fd2ab81a 100644
--- a/x11-themes/gtk-engines2/distinfo
+++ b/x11-themes/gtk-engines2/distinfo
@@ -1 +1 @@
-MD5 (gtk-engines-0.12.tar.gz) = c867d1ebd6dbea355765d689a11330ec
+MD5 (gnome2/gtk-engines-1.9.0.tar.bz2) = d77b10a9e73226a306a32d5c89ba066d
diff --git a/x11-themes/gtk-engines2/files/patch-configure b/x11-themes/gtk-engines2/files/patch-configure
index 75a816a54cd9..606b17960f77 100644
--- a/x11-themes/gtk-engines2/files/patch-configure
+++ b/x11-themes/gtk-engines2/files/patch-configure
@@ -1,11 +1,10 @@
---- configure.orig Tue Mar 20 03:08:42 2001
-+++ configure Tue Mar 20 03:08:57 2001
-@@ -2177,7 +2177,7 @@
- echo $ac_n "(cached) $ac_c" 1>&6
- else
- ac_save_LIBS="$LIBS"
--LIBS="-lgtk $GTK_LIBS $LIBS"
-+LIBS="$GTK_LIBS $LIBS"
- cat > conftest.$ac_ext <<EOF
- #line 2183 "configure"
- #include "confdefs.h"
+--- configure.orig Tue May 21 16:33:53 2002
++++ configure Tue May 21 16:34:13 2002
+@@ -6994,6 +6994,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/x11-themes/gtk-engines2/files/patch-pixmap::pixmap_theme_draw.c b/x11-themes/gtk-engines2/files/patch-pixmap::pixmap_theme_draw.c
deleted file mode 100644
index b3e522813d8b..000000000000
--- a/x11-themes/gtk-engines2/files/patch-pixmap::pixmap_theme_draw.c
+++ /dev/null
@@ -1,74 +0,0 @@
---- pixmap/pixmap_theme_draw.c.orig Mon Feb 7 03:33:43 2000
-+++ pixmap/pixmap_theme_draw.c Fri Apr 12 15:24:40 2002
-@@ -403,8 +403,9 @@
- gdk_gc_set_clip_origin(gc, 0, 0);
- }
- }
-- gdk_imlib_free_pixmap(p);
- }
-+ if (p)
-+ gdk_imlib_free_pixmap(p);
- gdk_imlib_destroy_image(im);
- }
- }
-@@ -467,8 +468,9 @@
- gdk_gc_set_clip_mask(gc, NULL);
- gdk_gc_set_clip_origin(gc, 0, 0);
- }
-- gdk_imlib_free_pixmap(p);
- }
-+ if (p)
-+ gdk_imlib_free_pixmap(p);
- gdk_imlib_destroy_image(im);
- }
-
-@@ -591,8 +593,9 @@
- gdk_gc_set_clip_mask(gc, NULL);
- gdk_gc_set_clip_origin(gc, 0, 0);
- }
-- gdk_imlib_free_pixmap(p);
- }
-+ if (p)
-+ gdk_imlib_free_pixmap(p);
- gdk_imlib_destroy_image(im);
- }
- }
-@@ -956,11 +959,13 @@
- gdk_gc_set_clip_mask(gc, NULL);
- gdk_gc_set_clip_origin(gc, 0, 0);
- }
--
-- gdk_imlib_free_pixmap(p);
-- gdk_imlib_free_pixmap(p1);
-- gdk_imlib_free_pixmap(p2);
- }
-+ if (p)
-+ gdk_imlib_free_pixmap(p);
-+ if (p1)
-+ gdk_imlib_free_pixmap(p1);
-+ if (p2)
-+ gdk_imlib_free_pixmap(p2);
- gdk_imlib_destroy_image(im);
- gdk_imlib_destroy_image(im1);
- gdk_imlib_destroy_image(im2);
-@@ -1202,11 +1207,15 @@
- gdk_gc_set_clip_mask(gc, NULL);
- gdk_gc_set_clip_origin(gc, 0, 0);
- }
-- gdk_imlib_free_pixmap(p);
-- gdk_imlib_free_pixmap(p1);
-- gdk_imlib_free_pixmap(p2);
-- gdk_imlib_free_pixmap(p3);
- }
-+ if (p)
-+ gdk_imlib_free_pixmap(p);
-+ if (p1)
-+ gdk_imlib_free_pixmap(p1);
-+ if (p2)
-+ gdk_imlib_free_pixmap(p2);
-+ if (p3)
-+ gdk_imlib_free_pixmap(p3);
- gdk_imlib_destroy_image(im);
- gdk_imlib_destroy_image(im1);
- gdk_imlib_destroy_image(im2);
-
diff --git a/x11-themes/gtk-engines2/files/patch-pixmap_Theme_gtk_gtkrc b/x11-themes/gtk-engines2/files/patch-pixmap_Theme_gtk_gtkrc
deleted file mode 100644
index 81c3bc781101..000000000000
--- a/x11-themes/gtk-engines2/files/patch-pixmap_Theme_gtk_gtkrc
+++ /dev/null
@@ -1,13 +0,0 @@
---- pixmap/Theme/gtk/gtkrc.orig Sun Nov 19 21:53:57 2000
-+++ pixmap/Theme/gtk/gtkrc Tue Mar 20 02:49:23 2001
-@@ -13,7 +13,9 @@
- # testgtkrc2 sets all the buttons in the main window to blue by default
- #include "testgtkrc2"
-
--#module_path ".:/home/raster/themes"
-+#module_path "%%PREFIX%%/lib/gtk/themes"
-+
-+pixmap_path "%%PREFIX%%/share/themes/Pixmap/gtk"
-
- style "eventbox" {
- bg_pixmap[NORMAL] = "<parent>"
diff --git a/x11-themes/gtk-engines2/pkg-comment b/x11-themes/gtk-engines2/pkg-comment
index bc31903b7d69..5f0762d3497e 100644
--- a/x11-themes/gtk-engines2/pkg-comment
+++ b/x11-themes/gtk-engines2/pkg-comment
@@ -1 +1 @@
-Theme engine for gtk+ toolkits
+Theme engine for the gtk+-2.0 toolkit
diff --git a/x11-themes/gtk-engines2/pkg-descr b/x11-themes/gtk-engines2/pkg-descr
index cebd49ca902c..e787f789bb62 100644
--- a/x11-themes/gtk-engines2/pkg-descr
+++ b/x11-themes/gtk-engines2/pkg-descr
@@ -1,3 +1,3 @@
-Theme engine for gtk+ toolkits.
+Theme engine for the gtk+-2.0 toolkit.
-WWW: http://www.gnome.org/
+WWW: http://www.gtk.org/
diff --git a/x11-themes/gtk-engines2/pkg-plist b/x11-themes/gtk-engines2/pkg-plist
index c1cc20cb6dfd..1888a2ba8fcd 100644
--- a/x11-themes/gtk-engines2/pkg-plist
+++ b/x11-themes/gtk-engines2/pkg-plist
@@ -1,99 +1,14 @@
-lib/gtk/themes/engines/libmetal.so
-lib/gtk/themes/engines/libnotif.so
-lib/gtk/themes/engines/libpixmap.so
-lib/gtk/themes/engines/libraleigh.so
-lib/gtk/themes/engines/libredmond95.so
+lib/gtk-2.0/%%VERSION%%/engines/libmetal.so
+lib/gtk-2.0/%%VERSION%%/engines/libpixmap.so
+lib/gtk-2.0/%%VERSION%%/engines/libredmond95.so
share/themes/Metal/ICON.png
share/themes/Metal/README.html
-share/themes/Metal/gtk/gtkrc
-share/themes/Notif/ICON.png
-share/themes/Notif/README.html
-share/themes/Notif/gtk/gtkrc
-share/themes/Pixmap/ICON.png
-share/themes/Pixmap/README.html
-share/themes/Pixmap/gtk/arrow_down1.png
-share/themes/Pixmap/gtk/arrow_down2.png
-share/themes/Pixmap/gtk/arrow_down3.png
-share/themes/Pixmap/gtk/arrow_left1.png
-share/themes/Pixmap/gtk/arrow_left2.png
-share/themes/Pixmap/gtk/arrow_left3.png
-share/themes/Pixmap/gtk/arrow_right1.png
-share/themes/Pixmap/gtk/arrow_right2.png
-share/themes/Pixmap/gtk/arrow_right3.png
-share/themes/Pixmap/gtk/arrow_up1.png
-share/themes/Pixmap/gtk/arrow_up2.png
-share/themes/Pixmap/gtk/arrow_up3.png
-share/themes/Pixmap/gtk/brown_bg1.png
-share/themes/Pixmap/gtk/brown_bg2.png
-share/themes/Pixmap/gtk/button1.png
-share/themes/Pixmap/gtk/button2.png
-share/themes/Pixmap/gtk/button3.png
-share/themes/Pixmap/gtk/button4.png
-share/themes/Pixmap/gtk/button5.png
-share/themes/Pixmap/gtk/button6.png
-share/themes/Pixmap/gtk/button7.png
-share/themes/Pixmap/gtk/button8.png
-share/themes/Pixmap/gtk/button9.png
-share/themes/Pixmap/gtk/button_def.png
-share/themes/Pixmap/gtk/check1.png
-share/themes/Pixmap/gtk/check2.png
-share/themes/Pixmap/gtk/curve_bg1.png
-share/themes/Pixmap/gtk/entry1.png
-share/themes/Pixmap/gtk/entry2.png
-share/themes/Pixmap/gtk/extension_bottom1.png
-share/themes/Pixmap/gtk/extension_left1.png
-share/themes/Pixmap/gtk/extension_right1.png
-share/themes/Pixmap/gtk/extension_top1.png
-share/themes/Pixmap/gtk/focus.png
-share/themes/Pixmap/gtk/frame1.png
-share/themes/Pixmap/gtk/frame2.png
-share/themes/Pixmap/gtk/frame_gap.png
-share/themes/Pixmap/gtk/frame_gap_top_end.png
-share/themes/Pixmap/gtk/frame_gap_top_start.png
-share/themes/Pixmap/gtk/gap_bottom.png
-share/themes/Pixmap/gtk/gap_bottom_end.png
-share/themes/Pixmap/gtk/gap_bottom_start.png
-share/themes/Pixmap/gtk/gap_left.png
-share/themes/Pixmap/gtk/gap_left_end.png
-share/themes/Pixmap/gtk/gap_left_start.png
-share/themes/Pixmap/gtk/gap_right.png
-share/themes/Pixmap/gtk/gap_right_end.png
-share/themes/Pixmap/gtk/gap_right_start.png
-share/themes/Pixmap/gtk/gap_top.png
-share/themes/Pixmap/gtk/gap_top_end.png
-share/themes/Pixmap/gtk/gap_top_start.png
-share/themes/Pixmap/gtk/gtkrc
-share/themes/Pixmap/gtk/handle_vert_thumb.png
-share/themes/Pixmap/gtk/hline.png
-share/themes/Pixmap/gtk/menubar.png
-share/themes/Pixmap/gtk/notebook1.png
-share/themes/Pixmap/gtk/option1.png
-share/themes/Pixmap/gtk/option2.png
-share/themes/Pixmap/gtk/option_menu.png
-share/themes/Pixmap/gtk/progressbar.png
-share/themes/Pixmap/gtk/ruler_horiz.png
-share/themes/Pixmap/gtk/ruler_vert.png
-share/themes/Pixmap/gtk/scrollbar_horiz1.png
-share/themes/Pixmap/gtk/scrollbar_thumb.png
-share/themes/Pixmap/gtk/scrollbar_thumb2.png
-share/themes/Pixmap/gtk/scrollbar_vert1.png
-share/themes/Pixmap/gtk/shadow1.png
-share/themes/Pixmap/gtk/shadow2.png
-share/themes/Pixmap/gtk/trough.png
-share/themes/Pixmap/gtk/vline.png
-share/themes/Raleigh/ICON.png
-share/themes/Raleigh/README.html
-share/themes/Raleigh/gtk/gtkrc
+share/themes/Metal/gtk-2.0/gtkrc
share/themes/Redmond95/ICON.png
share/themes/Redmond95/README.html
-share/themes/Redmond95/gtk/gtkrc
-@dirrm share/themes/Redmond95/gtk
-@dirrm share/themes/Redmond95
-@dirrm share/themes/Raleigh/gtk
-@dirrm share/themes/Raleigh
-@dirrm share/themes/Pixmap/gtk
-@dirrm share/themes/Pixmap
-@dirrm share/themes/Notif/gtk
-@dirrm share/themes/Notif
-@dirrm share/themes/Metal/gtk
-@dirrm share/themes/Metal
+share/themes/Redmond95/gtk-2.0/gtkrc
+@dirrm share/themes/Redmond95/gtk-2.0
+@dirrm share/themes/Metal/gtk-2.0
+@dirrm lib/gtk-2.0/%%VERSION%%/engines
+@unexec /bin/rmdir %D/share/themes/Redmond95 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/share/themes/Metal 2>/dev/null || /usr/bin/true