aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/bakery
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2003-12-04 07:26:59 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2003-12-04 07:26:59 +0000
commit4f1fdd153fb293ff8bc58e96cc6181fc4c834aa6 (patch)
tree271135fa41836ebf748ba6bc470a5d883ba8c08f /x11-toolkits/bakery
parent9619fa8313432f4c5aeb71cfa83b805a939f4a2c (diff)
downloadports-4f1fdd153fb293ff8bc58e96cc6181fc4c834aa6.tar.gz
ports-4f1fdd153fb293ff8bc58e96cc6181fc4c834aa6.zip
Patches missed from just commited 1.3.11 update.
Notes
Notes: svn path=/head/; revision=94889
Diffstat (limited to 'x11-toolkits/bakery')
-rw-r--r--x11-toolkits/bakery/files/patch-bakery::Makefile.in11
-rw-r--r--x11-toolkits/bakery/files/patch-ltmain.sh51
2 files changed, 62 insertions, 0 deletions
diff --git a/x11-toolkits/bakery/files/patch-bakery::Makefile.in b/x11-toolkits/bakery/files/patch-bakery::Makefile.in
new file mode 100644
index 000000000000..0d41c80e1647
--- /dev/null
+++ b/x11-toolkits/bakery/files/patch-bakery::Makefile.in
@@ -0,0 +1,11 @@
+--- bakery/Makefile.in.orig Fri Nov 28 11:44:02 2003
++++ bakery/Makefile.in Fri Nov 28 11:44:17 2003
+@@ -192,7 +192,7 @@
+ View/libbakery_view.la \
+ $(BAKERY_LIBS)
+
+-libbakery_1_3_la_LDFLAGS = -version-info $(GENERIC_LIBRARY_VERSION) -release $(GENERIC_RELEASE)
++libbakery_1_3_la_LDFLAGS = -version-info $(GENERIC_LIBRARY_VERSION)
+ subdir = bakery
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/x11-toolkits/bakery/files/patch-ltmain.sh b/x11-toolkits/bakery/files/patch-ltmain.sh
new file mode 100644
index 000000000000..1d5a5c7b87e1
--- /dev/null
+++ b/x11-toolkits/bakery/files/patch-ltmain.sh
@@ -0,0 +1,51 @@
+--- ltmain.sh.orig Fri Sep 12 14:51:51 2003
++++ ltmain.sh Sun Sep 21 17:49:07 2003
+@@ -1280,7 +1280,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1290,8 +1290,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -3000,6 +3008,9 @@
+ # problems, so we reset it completely
+ verstring=
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ verstring="0.0"
+ ;;
+@@ -5428,10 +5439,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"