aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/eel2
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-12-20 14:04:25 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-12-20 14:04:25 +0000
commit089fc7522f1a485db2b908a81e467c9e606792c9 (patch)
tree1a25d5b83499ff0ce3d8d4cf156a3b19bc97a781 /x11-toolkits/eel2
parent7284424fab3033b3fcfd9203ba8a2fc9336ba467 (diff)
downloadports-089fc7522f1a485db2b908a81e467c9e606792c9.tar.gz
ports-089fc7522f1a485db2b908a81e467c9e606792c9.zip
In a function eel_read_entire_file() allocate extra byte and ensure that the
read buffer is terminated by '\0', because it seems that Nautilus expects it to be. The proper fix would be to fix Nautilus instead, but I'll leave this excersise to Nautilus developers. This should fix one of the most frequent crashes I've saw in Nautilus so far. Bump PORTREVISION. Recommended update.
Notes
Notes: svn path=/head/; revision=51888
Diffstat (limited to 'x11-toolkits/eel2')
-rw-r--r--x11-toolkits/eel2/Makefile1
-rw-r--r--x11-toolkits/eel2/files/patch-eel::eel-vfs-extensions.c15
2 files changed, 16 insertions, 0 deletions
diff --git a/x11-toolkits/eel2/Makefile b/x11-toolkits/eel2/Makefile
index 85e367b6a654..5f201335e082 100644
--- a/x11-toolkits/eel2/Makefile
+++ b/x11-toolkits/eel2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= eel
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/eel
diff --git a/x11-toolkits/eel2/files/patch-eel::eel-vfs-extensions.c b/x11-toolkits/eel2/files/patch-eel::eel-vfs-extensions.c
new file mode 100644
index 000000000000..a71c0f102a7b
--- /dev/null
+++ b/x11-toolkits/eel2/files/patch-eel::eel-vfs-extensions.c
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- eel/eel-vfs-extensions.c 2001/12/20 13:41:21 1.1
++++ eel/eel-vfs-extensions.c 2001/12/20 13:47:36
+@@ -116,7 +116,8 @@
+
+ /* Return the file. */
+ *file_size = total_bytes_read;
+- *file_contents = g_realloc (buffer, total_bytes_read);
++ *file_contents = g_realloc (buffer, total_bytes_read + 1);
++ (*file_contents)[total_bytes_read] = '\0';
+ return GNOME_VFS_OK;
+ }
+