aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/eel2
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-05-20 17:47:26 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-05-20 17:47:26 +0000
commit3c0571ab41d1978c9e87c7a183d39acca4b7b93f (patch)
tree047f394436c40e9a5fb9afe8818a4c0b2aca58e9 /x11-toolkits/eel2
parentfe2f15e2d003d8fa342fb2d8d7078cb04b95fbeb (diff)
downloadports-3c0571ab41d1978c9e87c7a183d39acca4b7b93f.tar.gz
ports-3c0571ab41d1978c9e87c7a183d39acca4b7b93f.zip
Update eel2 to version 1.1.14 after a repo-copy from ports/x11-toolkits/eel
and connect it to the build.
Notes
Notes: svn path=/head/; revision=59541
Diffstat (limited to 'x11-toolkits/eel2')
-rw-r--r--x11-toolkits/eel2/Makefile26
-rw-r--r--x11-toolkits/eel2/distinfo2
-rw-r--r--x11-toolkits/eel2/files/patch-Makefile.in23
-rw-r--r--x11-toolkits/eel2/files/patch-po::Makefile.in.in14
-rw-r--r--x11-toolkits/eel2/pkg-plist213
5 files changed, 113 insertions, 165 deletions
diff --git a/x11-toolkits/eel2/Makefile b/x11-toolkits/eel2/Makefile
index 607b75d2472a..aede6af7b686 100644
--- a/x11-toolkits/eel2/Makefile
+++ b/x11-toolkits/eel2/Makefile
@@ -1,36 +1,44 @@
-# New ports collection makefile for: eel
+# New ports collection makefile for: eel2
# Date created: 8th May 2001
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= eel
-PORTVERSION= 1.0.2
-PORTREVISION= 1
+PORTNAME= eel2
+PORTVERSION= 1.1.14
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= stable/sources/eel
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta5
+DIST_SUBDIR= gnome2
+DISTNAME= eel-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2 # XXX
-LIB_DEPENDS= rsvg.1:${PORTSDIR}/graphics/librsvg
+LIB_DEPENDS= gnomevfs-2.0:${PORTSDIR}/devel/gnomevfs2 \
+ gailutil.13:${PORTSDIR}/x11-toolkits/gail \
+ gnomeui-2.0:${PORTSDIR}/x11-toolkits/libgnomeui
+USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --enable-shared --enable-static
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --with-html-dir=${PREFIX}/share/doc \
+ --disable-gtk-doc --enable-shared --enable-static
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
+ s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
.include <bsd.port.mk>
diff --git a/x11-toolkits/eel2/distinfo b/x11-toolkits/eel2/distinfo
index 89fa5a78ec65..80b08a508504 100644
--- a/x11-toolkits/eel2/distinfo
+++ b/x11-toolkits/eel2/distinfo
@@ -1 +1 @@
-MD5 (eel-1.0.2.tar.gz) = 9e4e4d9d3b688ea34351f2aa6112fd81
+MD5 (gnome2/eel-1.1.14.tar.bz2) = 67f9dfbe4fd24ab6d97e2b237701ba58
diff --git a/x11-toolkits/eel2/files/patch-Makefile.in b/x11-toolkits/eel2/files/patch-Makefile.in
deleted file mode 100644
index a6d10b9b4b4e..000000000000
--- a/x11-toolkits/eel2/files/patch-Makefile.in
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.in.orig Fri Jul 6 12:57:01 2001
-+++ Makefile.in Fri Jul 6 12:58:14 2001
-@@ -159,7 +159,7 @@
-
- NULL =
-
--SUBDIRS = data intl eel test po $(NULL)
-+SUBDIRS = data intl eel po $(NULL)
-
-
- EXTRA_DIST = COPYING.LIB HACKING MAINTAINERS eel.spec.in eelConf.sh.in eel-config.in xml-i18n-extract.in xml-i18n-merge.in xml-i18n-update.in $(NULL)
-@@ -167,7 +167,7 @@
-
- bin_SCRIPTS = $(top_builddir)/eel-config
-
--confexecdir = $(libdir)
-+confexecdir = $(sysconfdir)
- confexec_DATA = eelConf.sh $(NULL)
-
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/x11-toolkits/eel2/files/patch-po::Makefile.in.in b/x11-toolkits/eel2/files/patch-po::Makefile.in.in
deleted file mode 100644
index 54a45551f75a..000000000000
--- a/x11-toolkits/eel2/files/patch-po::Makefile.in.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- po/Makefile.in.in 2001/07/06 10:12:53 1.1
-+++ po/Makefile.in.in 2001/07/06 10:13:11
-@@ -104,7 +104,7 @@
- @catalogs='$(CATALOGS)'; \
- for cat in $$catalogs; do \
- cat=`basename $$cat`; \
-- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
-+ lang=`echo $$cat | sed 's/\.mo$$//'`; \
- dir=$(localedir)/$$lang/LC_MESSAGES; \
- $(mkinstalldirs) $(DESTDIR)$$dir; \
- if test -r $$cat; then \
diff --git a/x11-toolkits/eel2/pkg-plist b/x11-toolkits/eel2/pkg-plist
index 048b46f8d4cd..679735c8ba35 100644
--- a/x11-toolkits/eel2/pkg-plist
+++ b/x11-toolkits/eel2/pkg-plist
@@ -1,118 +1,95 @@
-bin/eel-config
-etc/eelConf.sh
-include/eel-1/eel/eel-art-extensions.h
-include/eel-1/eel/eel-art-gtk-extensions.h
-include/eel-1/eel/eel-background.h
-include/eel-1/eel/eel-canvas-rect.h
-include/eel-1/eel/eel-caption-table.h
-include/eel-1/eel/eel-caption.h
-include/eel-1/eel/eel-clickable-image.h
-include/eel-1/eel/eel-clist.h
-include/eel-1/eel/eel-ctree.h
-include/eel-1/eel/eel-dateedit-extensions.h
-include/eel-1/eel/eel-debug-drawing.h
-include/eel-1/eel/eel-debug.h
-include/eel-1/eel/eel-dnd.h
-include/eel-1/eel/eel-ellipsizing-label.h
-include/eel-1/eel/eel-enumeration.h
-include/eel-1/eel/eel-features.h
-include/eel-1/eel/eel-font-manager.h
-include/eel-1/eel/eel-font-picker.h
-include/eel-1/eel/eel-gconf-extensions.h
-include/eel-1/eel/eel-gdk-extensions.h
-include/eel-1/eel/eel-gdk-font-extensions.h
-include/eel-1/eel/eel-gdk-pixbuf-extensions.h
-include/eel-1/eel/eel-generous-bin.h
-include/eel-1/eel/eel-glib-extensions.h
-include/eel-1/eel/eel-glyph.h
-include/eel-1/eel/eel-gnome-extensions.h
-include/eel-1/eel/eel-graphic-effects.h
-include/eel-1/eel/eel-gtk-container.h
-include/eel-1/eel/eel-gtk-extensions.h
-include/eel-1/eel/eel-gtk-macros.h
-include/eel-1/eel/eel-image-chooser.h
-include/eel-1/eel/eel-image-table.h
-include/eel-1/eel/eel-image-with-background.h
-include/eel-1/eel/eel-image.h
-include/eel-1/eel/eel-label-with-background.h
-include/eel-1/eel/eel-label.h
-include/eel-1/eel/eel-labeled-image.h
-include/eel-1/eel/eel-list-column-title.h
-include/eel-1/eel/eel-list.h
-include/eel-1/eel/eel-password-dialog.h
-include/eel-1/eel/eel-preferences-box.h
-include/eel-1/eel/eel-preferences-group.h
-include/eel-1/eel/eel-preferences-item.h
-include/eel-1/eel/eel-preferences-pane.h
-include/eel-1/eel/eel-preferences.h
-include/eel-1/eel/eel-radio-button-group.h
-include/eel-1/eel/eel-region.h
-include/eel-1/eel/eel-scalable-font-private.h
-include/eel-1/eel/eel-scalable-font.h
-include/eel-1/eel/eel-self-checks.h
-include/eel-1/eel/eel-smooth-text-layout-cache.h
-include/eel-1/eel/eel-smooth-text-layout.h
-include/eel-1/eel/eel-smooth-widget.h
-include/eel-1/eel/eel-stock-dialogs.h
-include/eel-1/eel/eel-string-list.h
-include/eel-1/eel/eel-string-picker.h
-include/eel-1/eel/eel-string.h
-include/eel-1/eel/eel-text-caption.h
-include/eel-1/eel/eel-type-builtins.h
-include/eel-1/eel/eel-types.h
-include/eel-1/eel/eel-vfs-extensions.h
-include/eel-1/eel/eel-viewport.h
-include/eel-1/eel/eel-wrap-table.h
-include/eel-1/eel/eel-xml-extensions.h
-include/eel-1/eel/eel.h
-lib/libeel.a
-lib/libeel.so
-lib/libeel.so.0
-share/gnome/eel/fonts/urw/fonts.dir
-share/gnome/eel/fonts/urw/n019003l.afm
-share/gnome/eel/fonts/urw/n019003l.pfb
-share/gnome/eel/fonts/urw/n019003l.pfm
-share/gnome/eel/fonts/urw/n019004l.afm
-share/gnome/eel/fonts/urw/n019004l.pfb
-share/gnome/eel/fonts/urw/n019004l.pfm
-share/gnome/eel/fonts/urw/n019023l.afm
-share/gnome/eel/fonts/urw/n019023l.pfb
-share/gnome/eel/fonts/urw/n019023l.pfm
-share/gnome/eel/fonts/urw/n019024l.afm
-share/gnome/eel/fonts/urw/n019024l.pfb
-share/gnome/eel/fonts/urw/n019024l.pfm
-share/locale/az/LC_MESSAGES/eel.mo
-share/locale/ca/LC_MESSAGES/eel.mo
-share/locale/cs/LC_MESSAGES/eel.mo
-share/locale/da/LC_MESSAGES/eel.mo
-share/locale/de/LC_MESSAGES/eel.mo
-share/locale/el/LC_MESSAGES/eel.mo
-share/locale/en_GB/LC_MESSAGES/eel.mo
-share/locale/es/LC_MESSAGES/eel.mo
-share/locale/fi/LC_MESSAGES/eel.mo
-share/locale/fr/LC_MESSAGES/eel.mo
-share/locale/ga/LC_MESSAGES/eel.mo
-share/locale/gl/LC_MESSAGES/eel.mo
-share/locale/hu/LC_MESSAGES/eel.mo
-share/locale/it/LC_MESSAGES/eel.mo
-share/locale/ja/LC_MESSAGES/eel.mo
-share/locale/ko/LC_MESSAGES/eel.mo
-share/locale/lt/LC_MESSAGES/eel.mo
-share/locale/nl/LC_MESSAGES/eel.mo
-share/locale/nn/LC_MESSAGES/eel.mo
-share/locale/no/LC_MESSAGES/eel.mo
-share/locale/pl/LC_MESSAGES/eel.mo
-share/locale/pt_BR/LC_MESSAGES/eel.mo
-share/locale/ru/LC_MESSAGES/eel.mo
-share/locale/sk/LC_MESSAGES/eel.mo
-share/locale/sl/LC_MESSAGES/eel.mo
-share/locale/sv/LC_MESSAGES/eel.mo
-share/locale/ta/LC_MESSAGES/eel.mo
-share/locale/tr/LC_MESSAGES/eel.mo
-share/locale/uk/LC_MESSAGES/eel.mo
-share/locale/zh_TW/LC_MESSAGES/eel.mo
-@dirrm share/gnome/eel/fonts/urw
-@dirrm share/gnome/eel/fonts
-@dirrm share/gnome/eel
-@dirrm include/eel-1/eel
-@dirrm include/eel-1
+include/eel-2/eel/eel-accessibility.h
+include/eel-2/eel/eel-art-extensions.h
+include/eel-2/eel/eel-art-gtk-extensions.h
+include/eel-2/eel/eel-background-style.h
+include/eel-2/eel/eel-background.h
+include/eel-2/eel/eel-canvas-rect.h
+include/eel-2/eel/eel-caption-table.h
+include/eel-2/eel/eel-caption.h
+include/eel-2/eel/eel-cell-renderer-pixbuf-list.h
+include/eel-2/eel/eel-dateedit-extensions.h
+include/eel-2/eel/eel-debug-drawing.h
+include/eel-2/eel/eel-debug.h
+include/eel-2/eel/eel-ellipsizing-label.h
+include/eel-2/eel/eel-enumeration.h
+include/eel-2/eel/eel-features.h
+include/eel-2/eel/eel-font-picker.h
+include/eel-2/eel/eel-gconf-extensions.h
+include/eel-2/eel/eel-gdk-extensions.h
+include/eel-2/eel/eel-gdk-pixbuf-extensions.h
+include/eel-2/eel/eel-generous-bin.h
+include/eel-2/eel/eel-glib-extensions.h
+include/eel-2/eel/eel-gnome-extensions.h
+include/eel-2/eel/eel-graphic-effects.h
+include/eel-2/eel/eel-gtk-container.h
+include/eel-2/eel/eel-gtk-extensions.h
+include/eel-2/eel/eel-gtk-macros.h
+include/eel-2/eel/eel-image-chooser.h
+include/eel-2/eel/eel-image-table.h
+include/eel-2/eel/eel-labeled-image.h
+include/eel-2/eel/eel-marshal.h
+include/eel-2/eel/eel-pango-extensions.h
+include/eel-2/eel/eel-password-dialog.h
+include/eel-2/eel/eel-preferences-box.h
+include/eel-2/eel/eel-preferences-group.h
+include/eel-2/eel/eel-preferences-item.h
+include/eel-2/eel/eel-preferences-pane.h
+include/eel-2/eel/eel-preferences.h
+include/eel-2/eel/eel-radio-button-group.h
+include/eel-2/eel/eel-self-checks.h
+include/eel-2/eel/eel-stock-dialogs.h
+include/eel-2/eel/eel-string-list.h
+include/eel-2/eel/eel-string-picker.h
+include/eel-2/eel/eel-string.h
+include/eel-2/eel/eel-text-caption.h
+include/eel-2/eel/eel-type-builtins.h
+include/eel-2/eel/eel-types.h
+include/eel-2/eel/eel-vfs-extensions.h
+include/eel-2/eel/eel-wrap-table.h
+include/eel-2/eel/eel-xml-extensions.h
+include/eel-2/eel/eel.h
+lib/libeel-2.a
+lib/libeel-2.so
+lib/libeel-2.so.2
+libdata/pkgconfig/eel-2.0.pc
+share/locale/az/LC_MESSAGES/eel-2.0.mo
+share/locale/ca/LC_MESSAGES/eel-2.0.mo
+share/locale/cs/LC_MESSAGES/eel-2.0.mo
+share/locale/da/LC_MESSAGES/eel-2.0.mo
+share/locale/de/LC_MESSAGES/eel-2.0.mo
+share/locale/el/LC_MESSAGES/eel-2.0.mo
+share/locale/en_GB/LC_MESSAGES/eel-2.0.mo
+share/locale/es/LC_MESSAGES/eel-2.0.mo
+share/locale/et/LC_MESSAGES/eel-2.0.mo
+share/locale/eu/LC_MESSAGES/eel-2.0.mo
+share/locale/fi/LC_MESSAGES/eel-2.0.mo
+share/locale/fr/LC_MESSAGES/eel-2.0.mo
+share/locale/ga/LC_MESSAGES/eel-2.0.mo
+share/locale/gl/LC_MESSAGES/eel-2.0.mo
+share/locale/hu/LC_MESSAGES/eel-2.0.mo
+share/locale/it/LC_MESSAGES/eel-2.0.mo
+share/locale/ja/LC_MESSAGES/eel-2.0.mo
+share/locale/ko/LC_MESSAGES/eel-2.0.mo
+share/locale/lt/LC_MESSAGES/eel-2.0.mo
+share/locale/lv/LC_MESSAGES/eel-2.0.mo
+share/locale/ms/LC_MESSAGES/eel-2.0.mo
+share/locale/nl/LC_MESSAGES/eel-2.0.mo
+share/locale/nn/LC_MESSAGES/eel-2.0.mo
+share/locale/no/LC_MESSAGES/eel-2.0.mo
+share/locale/pl/LC_MESSAGES/eel-2.0.mo
+share/locale/pt/LC_MESSAGES/eel-2.0.mo
+share/locale/pt_BR/LC_MESSAGES/eel-2.0.mo
+share/locale/ro/LC_MESSAGES/eel-2.0.mo
+share/locale/ru/LC_MESSAGES/eel-2.0.mo
+share/locale/sk/LC_MESSAGES/eel-2.0.mo
+share/locale/sl/LC_MESSAGES/eel-2.0.mo
+share/locale/sv/LC_MESSAGES/eel-2.0.mo
+share/locale/ta/LC_MESSAGES/eel-2.0.mo
+share/locale/tr/LC_MESSAGES/eel-2.0.mo
+share/locale/uk/LC_MESSAGES/eel-2.0.mo
+share/locale/vi/LC_MESSAGES/eel-2.0.mo
+share/locale/wa/LC_MESSAGES/eel-2.0.mo
+share/locale/zh_CN/LC_MESSAGES/eel-2.0.mo
+share/locale/zh_TW/LC_MESSAGES/eel-2.0.mo
+@dirrm include/eel-2/eel
+@dirrm include/eel-2