aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fox/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-10-30 09:36:55 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-10-30 09:36:55 +0000
commit31698bea42ff8318dbbd73b5092ed4cb800c877e (patch)
tree1d36e03d149cd2d0ca3e803912986d5a7e208c09 /x11-toolkits/fox/Makefile
parent51d207c2fc98efec682f2bf07896c706b5af8327 (diff)
downloadports-31698bea42ff8318dbbd73b5092ed4cb800c877e.tar.gz
ports-31698bea42ff8318dbbd73b5092ed4cb800c877e.zip
- Unbreak the support for jpeg and png.
Reported by: Jim Freeze <jfreeze@freebsdportal.com> - Fix the name of the macro to enable the Unicode support. Submitted by: HIDAKA Takahiro <cv8t-hdk@asahi-net.or.jp> - Bump the PORTREVISION accordingly.
Notes
Notes: svn path=/head/; revision=49367
Diffstat (limited to 'x11-toolkits/fox/Makefile')
-rw-r--r--x11-toolkits/fox/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/x11-toolkits/fox/Makefile b/x11-toolkits/fox/Makefile
index 211e4b8dc1f4..f0191c9fe8b7 100644
--- a/x11-toolkits/fox/Makefile
+++ b/x11-toolkits/fox/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fox
PORTVERSION?= 0.99.174
+PORTREVISION?= 1
CATEGORIES= x11-toolkits
MASTER_SITES= http://www.fox-toolkit.org/ftp/ \
ftp://ftp.fox-toolkit.org/pub/ \
@@ -29,7 +30,7 @@ PATCH_DIST_STRIP= -p1
BUILD_DEPENDS= ${X11BASE}/include/xunicode/xunicode.h:${PORTSDIR}/converters/xunicode
-CONFIGURE_ENV= X_CFLAGS=-DUSE_XUNICODE
+CONFIGURE_ENV= X_CFLAGS=-DUSE_UNICODE
PLIST_SUB= NEWFILE="@comment "
.else
@@ -38,7 +39,9 @@ PLIST_SUB= NEWFILE=""
USE_MESA= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS}"
+CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+=--with-opengl=mesa --with-x
.if defined(NO_SHM)
CONFIGURE_ARGS+=--with-shm=no