aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fox/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-04-30 16:39:03 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-04-30 16:39:03 +0000
commit4a936ae0aa9450679d4031c26b55aba1058eb954 (patch)
treed12f16ef59fb9949c274ba34f28b490e6e51871b /x11-toolkits/fox/Makefile
parent72293a0b34f6f6eb3f64b2b01f4d1edc64c2a7e1 (diff)
downloadports-4a936ae0aa9450679d4031c26b55aba1058eb954.tar.gz
ports-4a936ae0aa9450679d4031c26b55aba1058eb954.zip
Note the default optimization flags used by the vendor in a comment.
Comment out redundant lines rather than deleting them. (Just my taste)
Notes
Notes: svn path=/head/; revision=42088
Diffstat (limited to 'x11-toolkits/fox/Makefile')
-rw-r--r--x11-toolkits/fox/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/x11-toolkits/fox/Makefile b/x11-toolkits/fox/Makefile
index f91b89a6ed96..3354a4916f21 100644
--- a/x11-toolkits/fox/Makefile
+++ b/x11-toolkits/fox/Makefile
@@ -32,6 +32,7 @@ PATCHVERSION= ${PORTVERSION}
USE_MESA= yes
INSTALLS_SHLIB= yes
+CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS}"
CONFIGURE_ARGS+=--with-opengl=mesa --with-x
.if defined(NO_SHM)
CONFIGURE_ARGS+=--with-shm=no
@@ -53,6 +54,9 @@ MAKE_ENV+= LT_CURRENT="${SHLIB_MAJ}" LT_REVISION="${SHLIB_MIN}"
PLIST_SUB+= LIBVER="${SHLIB_MAJ}"
MAN1= reswrap.1
+# Uncomment this to turn the default optimization flags on.
+CXXFLAGS= -O2 -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fexpensive-optimizations
+
.if defined(WITH_XUNICODE)
post-extract:
cd ${WRKSRC} && ${LN} -s ${X11BASE}/include/xunicode