aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fox16
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-05-03 02:53:45 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-05-03 02:53:45 +0000
commit02c0e92bcbecb4b6a3b87caaa1bbac4c9fc9bb2f (patch)
treef726000fdbc7e712c93cac7b661838a21d4a4790 /x11-toolkits/fox16
parenta640c7bf04c3a63d19670480aa94f3b4c32d59f8 (diff)
downloadports-02c0e92bcbecb4b6a3b87caaa1bbac4c9fc9bb2f.tar.gz
ports-02c0e92bcbecb4b6a3b87caaa1bbac4c9fc9bb2f.zip
[repocopy] update x11-toolkits/fox12 to x11-toolkits/fox16
This shar is a replacement for x11-toolkits/fox12 so that it supports FOX 1.6. Please note the deleted files from fox16/files/ PR: ports/95244 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Notes
Notes: svn path=/head/; revision=161238
Diffstat (limited to 'x11-toolkits/fox16')
-rw-r--r--x11-toolkits/fox16/Makefile11
-rw-r--r--x11-toolkits/fox16/distinfo6
-rw-r--r--x11-toolkits/fox16/files/patch-configure8
-rw-r--r--x11-toolkits/fox16/files/patch-src_FXFile.cpp29
-rw-r--r--x11-toolkits/fox16/files/patch-utils_Makefile.in14
-rw-r--r--x11-toolkits/fox16/pkg-plist99
6 files changed, 105 insertions, 62 deletions
diff --git a/x11-toolkits/fox16/Makefile b/x11-toolkits/fox16/Makefile
index 930ea0cf02d5..7f1466eb510c 100644
--- a/x11-toolkits/fox16/Makefile
+++ b/x11-toolkits/fox16/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: fox
+# New ports collection makefile for: x11-toolkits/fox16
# Date created: 28 Jul 2005
# Whom: Alexander Novitsky <alecn2002@yandex.ru>
#
@@ -7,7 +7,6 @@
PORTNAME= fox
PORTVERSION= ${MAJORVER}.${SHVER}
-PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= http://www.fox-toolkit.org/ftp/ \
ftp://ftp.fox-toolkit.org/pub/ \
@@ -22,16 +21,14 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
Xft.2:${PORTSDIR}/x11-fonts/libXft
CONFLICTS= fox-1.0.* fox-1.4.*
+LATEST_LINK= fox16
-LATEST_LINK= fox12
-
-MAJORVER= 1.2
-SHVER= 16
+MAJORVER= 1.6
+SHVER= 1
PLIST_SUB+= MAJORVER=${MAJORVER} SHVER=${SHVER}
USE_GNOME= lthack
USE_GL= yes
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-opengl --with-x --enable-threadsafe
diff --git a/x11-toolkits/fox16/distinfo b/x11-toolkits/fox16/distinfo
index 1fb4cddd6708..0c2fcad2d2e5 100644
--- a/x11-toolkits/fox16/distinfo
+++ b/x11-toolkits/fox16/distinfo
@@ -1,3 +1,3 @@
-MD5 (fox-1.2.16.tar.gz) = f898da23fe7678faf5380224fbf0b3c3
-SHA256 (fox-1.2.16.tar.gz) = 8a08e30064d4a7bae74f7896d8e097449359e846fed6f732a5139f1e5dc498f0
-SIZE (fox-1.2.16.tar.gz) = 3896051
+MD5 (fox-1.6.1.tar.gz) = 4848b7a1431a8406a316530b0cd04197
+SHA256 (fox-1.6.1.tar.gz) = 0908e92fb215123b82a08d0d0cfb11493ec0d02017cb731f2b271e4856a311b4
+SIZE (fox-1.6.1.tar.gz) = 4331736
diff --git a/x11-toolkits/fox16/files/patch-configure b/x11-toolkits/fox16/files/patch-configure
index cd0f6671becd..665af90b7c2d 100644
--- a/x11-toolkits/fox16/files/patch-configure
+++ b/x11-toolkits/fox16/files/patch-configure
@@ -1,10 +1,10 @@
---- configure.orig Tue Feb 4 18:33:38 2003
-+++ configure Tue Feb 4 18:34:51 2003
-@@ -7498,7 +7498,7 @@
+--- configure.orig Mon Apr 3 09:41:29 2006
++++ configure Mon Apr 3 09:43:03 2006
+@@ -25483,7 +25483,7 @@
if test "x$enable_release" = "xyes" ; then
CXXFLAGS="${CXXFLAGS} -O2 -DNDEBUG"
if test "${GXX}" = "yes" ; then
--CXXFLAGS="${CXXFLAGS} -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fexpensive-optimizations"
+-CXXFLAGS="${CXXFLAGS} -Wuninitialized -ffast-math -fstrict-aliasing -finline-functions -fomit-frame-pointer -fexpensive-optimizations"
+CXXFLAGS="${CXXFLAGS} -Wuninitialized"
fi
fi
diff --git a/x11-toolkits/fox16/files/patch-src_FXFile.cpp b/x11-toolkits/fox16/files/patch-src_FXFile.cpp
deleted file mode 100644
index 1edb77d8c85f..000000000000
--- a/x11-toolkits/fox16/files/patch-src_FXFile.cpp
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/FXFile.cpp.orig Fri Apr 16 23:25:33 2004
-+++ src/FXFile.cpp Sat May 22 13:13:48 2004
-@@ -159,7 +159,7 @@
- // Get home directory for a given user
- FXString FXFile::getUserDirectory(const FXString& user){
- #ifndef WIN32
--#ifdef FOX_THREAD_SAFE
-+#if defined(FOX_THREAD_SAFE) && !defined(__FreeBSD__)
- struct passwd pwdresult,*pwd;
- char buffer[1024];
- if(user.empty()){
-@@ -1032,7 +1032,7 @@
- FXString FXFile::owner(FXuint uid){
- FXchar result[64];
- #ifndef WIN32
--#ifdef FOX_THREAD_SAFE
-+#if defined(FOX_THREAD_SAFE) && !defined(__FreeBSD__)
- struct passwd pwdresult,*pwd;
- char buffer[1024];
- if(getpwuid_r(uid,&pwdresult,buffer,sizeof(buffer),&pwd)==0 && pwd) return pwd->pw_name;
-@@ -1050,7 +1050,7 @@
- FXString FXFile::group(FXuint gid){
- FXchar result[64];
- #ifndef WIN32
--#ifdef FOX_THREAD_SAFE
-+#if defined(FOX_THREAD_SAFE) && !defined(__FreeBSD__)
- ::group grpresult;
- ::group *grp;
- char buffer[1024];
diff --git a/x11-toolkits/fox16/files/patch-utils_Makefile.in b/x11-toolkits/fox16/files/patch-utils_Makefile.in
index ea447c9dbea3..af4b1cbf4497 100644
--- a/x11-toolkits/fox16/files/patch-utils_Makefile.in
+++ b/x11-toolkits/fox16/files/patch-utils_Makefile.in
@@ -1,11 +1,11 @@
---- utils/Makefile.in.orig Sun Aug 15 11:30:45 2004
-+++ utils/Makefile.in Sun Aug 15 11:30:55 2004
-@@ -106,7 +106,7 @@
- DEFS = @DEFS@ -I. -I$(srcdir)
+--- utils/Makefile.in.orig Sat Apr 1 12:22:43 2006
++++ utils/Makefile.in Mon Apr 3 09:45:33 2006
+@@ -123,7 +123,7 @@
CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
--LIBS = @LIBS@
-+LIBS = @LIBS@ -lX11 -lXext
X_CFLAGS = @X_CFLAGS@
- X_LIBS = @X_LIBS@
+-X_LIBS = @X_LIBS@
++X_LIBS = @X_LIBS@ -lX11 -lXext
X_EXTRA_LIBS = @X_EXTRA_LIBS@
+ X_PRE_LIBS = @X_PRE_LIBS@
+ reswrap_OBJECTS = reswrap.$(OBJEXT)
diff --git a/x11-toolkits/fox16/pkg-plist b/x11-toolkits/fox16/pkg-plist
index 4fbc2eed8ba0..052b35100c54 100644
--- a/x11-toolkits/fox16/pkg-plist
+++ b/x11-toolkits/fox16/pkg-plist
@@ -4,6 +4,82 @@
bin/reswrap
bin/shutterbug
bin/fox-config
+include/fox-%%MAJORVER%%/FX88591Codec.h
+include/fox-%%MAJORVER%%/FX88592Codec.h
+include/fox-%%MAJORVER%%/FX88593Codec.h
+include/fox-%%MAJORVER%%/FX88594Codec.h
+include/fox-%%MAJORVER%%/FX88595Codec.h
+include/fox-%%MAJORVER%%/FX88596Codec.h
+include/fox-%%MAJORVER%%/FX88597Codec.h
+include/fox-%%MAJORVER%%/FX88598Codec.h
+include/fox-%%MAJORVER%%/FX88599Codec.h
+include/fox-%%MAJORVER%%/FX885910Codec.h
+include/fox-%%MAJORVER%%/FX885911Codec.h
+include/fox-%%MAJORVER%%/FX885913Codec.h
+include/fox-%%MAJORVER%%/FX885914Codec.h
+include/fox-%%MAJORVER%%/FX885915Codec.h
+include/fox-%%MAJORVER%%/FX885916Codec.h
+include/fox-%%MAJORVER%%/FXCP437Codec.h
+include/fox-%%MAJORVER%%/FXCP850Codec.h
+include/fox-%%MAJORVER%%/FXCP852Codec.h
+include/fox-%%MAJORVER%%/FXCP855Codec.h
+include/fox-%%MAJORVER%%/FXCP856Codec.h
+include/fox-%%MAJORVER%%/FXCP857Codec.h
+include/fox-%%MAJORVER%%/FXCP860Codec.h
+include/fox-%%MAJORVER%%/FXCP861Codec.h
+include/fox-%%MAJORVER%%/FXCP862Codec.h
+include/fox-%%MAJORVER%%/FXCP863Codec.h
+include/fox-%%MAJORVER%%/FXCP864Codec.h
+include/fox-%%MAJORVER%%/FXCP865Codec.h
+include/fox-%%MAJORVER%%/FXCP866Codec.h
+include/fox-%%MAJORVER%%/FXCP869Codec.h
+include/fox-%%MAJORVER%%/FXCP874Codec.h
+include/fox-%%MAJORVER%%/FXCP1250Codec.h
+include/fox-%%MAJORVER%%/FXCP1251Codec.h
+include/fox-%%MAJORVER%%/FXCP1252Codec.h
+include/fox-%%MAJORVER%%/FXCP1253Codec.h
+include/fox-%%MAJORVER%%/FXCP1254Codec.h
+include/fox-%%MAJORVER%%/FXCP1255Codec.h
+include/fox-%%MAJORVER%%/FXCP1256Codec.h
+include/fox-%%MAJORVER%%/FXCP1257Codec.h
+include/fox-%%MAJORVER%%/FXCP1258Codec.h
+include/fox-%%MAJORVER%%/FXKOI8RCodec.h
+include/fox-%%MAJORVER%%/FX7Segment.h
+include/fox-%%MAJORVER%%/FXBZFileStream.h
+include/fox-%%MAJORVER%%/FXChoiceBox.h
+include/fox-%%MAJORVER%%/FXColorList.h
+include/fox-%%MAJORVER%%/FXColorRing.h
+include/fox-%%MAJORVER%%/FXComposeContext.h
+include/fox-%%MAJORVER%%/FXDate.h
+include/fox-%%MAJORVER%%/FXDir.h
+include/fox-%%MAJORVER%%/FXDockBar.h
+include/fox-%%MAJORVER%%/FXDockHandler.h
+include/fox-%%MAJORVER%%/FXDockSite.h
+include/fox-%%MAJORVER%%/FXDockTitle.h
+include/fox-%%MAJORVER%%/FXExpression.h
+include/fox-%%MAJORVER%%/FXExtentd.h
+include/fox-%%MAJORVER%%/FXExtentf.h
+include/fox-%%MAJORVER%%/FXGUISignal.h
+include/fox-%%MAJORVER%%/FXGZFileStream.h
+include/fox-%%MAJORVER%%/FXIO.h
+include/fox-%%MAJORVER%%/FXIFFImage.h
+include/fox-%%MAJORVER%%/FXIFFIcon.h
+include/fox-%%MAJORVER%%/FXIconDict.h
+include/fox-%%MAJORVER%%/FXIconSource.h
+include/fox-%%MAJORVER%%/FXKnob.h
+include/fox-%%MAJORVER%%/FXMemMap.h
+include/fox-%%MAJORVER%%/FXPath.h
+include/fox-%%MAJORVER%%/FXPipe.h
+include/fox-%%MAJORVER%%/FXRASIcon.h
+include/fox-%%MAJORVER%%/FXRASImage.h
+include/fox-%%MAJORVER%%/FXRulerView.h
+include/fox-%%MAJORVER%%/FXSocket.h
+include/fox-%%MAJORVER%%/FXSplashWindow.h
+include/fox-%%MAJORVER%%/FXStat.h
+include/fox-%%MAJORVER%%/FXSystem.h
+include/fox-%%MAJORVER%%/FXTranslator.h
+include/fox-%%MAJORVER%%/fxascii.h
+include/fox-%%MAJORVER%%/fxunicode.h
include/fox-%%MAJORVER%%/FX4Splitter.h
include/fox-%%MAJORVER%%/FXAccelTable.h
include/fox-%%MAJORVER%%/FXApp.h
@@ -11,14 +87,12 @@ include/fox-%%MAJORVER%%/FXArray.h
include/fox-%%MAJORVER%%/FXArrowButton.h
include/fox-%%MAJORVER%%/FXBMPIcon.h
include/fox-%%MAJORVER%%/FXBMPImage.h
-include/fox-%%MAJORVER%%/FXBZStream.h
include/fox-%%MAJORVER%%/FXBitmap.h
include/fox-%%MAJORVER%%/FXBitmapFrame.h
include/fox-%%MAJORVER%%/FXBitmapView.h
include/fox-%%MAJORVER%%/FXButton.h
include/fox-%%MAJORVER%%/FXCURCursor.h
include/fox-%%MAJORVER%%/FXCanvas.h
-include/fox-%%MAJORVER%%/FXCharset.h
include/fox-%%MAJORVER%%/FXCheckButton.h
include/fox-%%MAJORVER%%/FXColorBar.h
include/fox-%%MAJORVER%%/FXColorDialog.h
@@ -73,7 +147,6 @@ include/fox-%%MAJORVER%%/FXGLSphere.h
include/fox-%%MAJORVER%%/FXGLTriangleMesh.h
include/fox-%%MAJORVER%%/FXGLViewer.h
include/fox-%%MAJORVER%%/FXGLVisual.h
-include/fox-%%MAJORVER%%/FXGZStream.h
include/fox-%%MAJORVER%%/FXGradientBar.h
include/fox-%%MAJORVER%%/FXGroupBox.h
include/fox-%%MAJORVER%%/FXHash.h
@@ -204,7 +277,6 @@ include/fox-%%MAJORVER%%/FXVec4d.h
include/fox-%%MAJORVER%%/FXVec4f.h
include/fox-%%MAJORVER%%/FXVerticalFrame.h
include/fox-%%MAJORVER%%/FXVisual.h
-include/fox-%%MAJORVER%%/FXWString.h
include/fox-%%MAJORVER%%/FXWindow.h
include/fox-%%MAJORVER%%/FXWizard.h
include/fox-%%MAJORVER%%/FXXBMIcon.h
@@ -226,6 +298,17 @@ lib/libFOX-%%MAJORVER%%.a
lib/libFOX-%%MAJORVER%%.la
lib/libFOX-%%MAJORVER%%.so
lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
+%%PORTDOCS%%%%DOCSDIR%%/html/pdiary.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/iims1.png
+%%PORTDOCS%%%%DOCSDIR%%/html/iims1_small.png
+%%PORTDOCS%%%%DOCSDIR%%/html/iims2.png
+%%PORTDOCS%%%%DOCSDIR%%/html/iims2_small.png
+%%PORTDOCS%%%%DOCSDIR%%/html/iims3.png
+%%PORTDOCS%%%%DOCSDIR%%/html/iims3_small.png
+%%PORTDOCS%%%%DOCSDIR%%/html/xtc.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/gpgkey.html
+%%PORTDOCS%%%%DOCSDIR%%/html/news2.html
+%%PORTDOCS%%%%DOCSDIR%%/html/news3.html
%%PORTDOCS%%%%DOCSDIR%%/html/SbSScreen1.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/SbSScreen1_small.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/adie.gif
@@ -306,7 +389,6 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/nerd_inside.gif
%%PORTDOCS%%%%DOCSDIR%%/html/news.html
%%PORTDOCS%%%%DOCSDIR%%/html/news1.html
-%%PORTDOCS%%%%DOCSDIR%%/html/oldfox.html
%%PORTDOCS%%%%DOCSDIR%%/html/oll.gif
%%PORTDOCS%%%%DOCSDIR%%/html/olr.gif
%%PORTDOCS%%%%DOCSDIR%%/html/opengl_logo.png
@@ -332,18 +414,11 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/serialization.html
%%PORTDOCS%%%%DOCSDIR%%/html/sgitextedit.png
%%PORTDOCS%%%%DOCSDIR%%/html/slingerzbutton1.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/ss1.png
-%%PORTDOCS%%%%DOCSDIR%%/html/ss1_small.png
-%%PORTDOCS%%%%DOCSDIR%%/html/ss2.png
-%%PORTDOCS%%%%DOCSDIR%%/html/ss2_small.png
-%%PORTDOCS%%%%DOCSDIR%%/html/ss3.png
-%%PORTDOCS%%%%DOCSDIR%%/html/ss3_small.png
%%PORTDOCS%%%%DOCSDIR%%/html/styles.css
%%PORTDOCS%%%%DOCSDIR%%/html/table.png
%%PORTDOCS%%%%DOCSDIR%%/html/timers.html
%%PORTDOCS%%%%DOCSDIR%%/html/tmp_vision_snap.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/top.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tux.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/tux_small.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/udine_physics.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/vorhour1.jpg