aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gauche-gtk
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-12-11 23:47:06 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-12-11 23:47:06 +0000
commit2cb8b80f5371f1a45a4bd9020b19e2b35cd7cd68 (patch)
tree77d398973fe15996b8ea2cc1c1443d419cc01d41 /x11-toolkits/gauche-gtk
parentcf66c62c7dab5c54377df4a2b4a61b9f275d804e (diff)
downloadports-2cb8b80f5371f1a45a4bd9020b19e2b35cd7cd68.tar.gz
ports-2cb8b80f5371f1a45a4bd9020b19e2b35cd7cd68.zip
Unbreak and fix build.
PR: ports/90249 Submitted by: Erik Greenwald <erik@smluc.org> (maintainer)
Notes
Notes: svn path=/head/; revision=150930
Diffstat (limited to 'x11-toolkits/gauche-gtk')
-rw-r--r--x11-toolkits/gauche-gtk/Makefile2
-rw-r--r--x11-toolkits/gauche-gtk/files/patch-src_gtktexttag.stub28
-rw-r--r--x11-toolkits/gauche-gtk/files/patch-src_gtktoolbar.stub11
3 files changed, 39 insertions, 2 deletions
diff --git a/x11-toolkits/gauche-gtk/Makefile b/x11-toolkits/gauche-gtk/Makefile
index c0c117ff2e48..213b7c10c061 100644
--- a/x11-toolkits/gauche-gtk/Makefile
+++ b/x11-toolkits/gauche-gtk/Makefile
@@ -21,8 +21,6 @@ COMMENT= GTK2 binding for Gauche
BUILD_DEPENDS= gosh:${PORTSDIR}/lang/gauche
RUN_DEPENDS= ${BUILD_DEPENDS}
-BROKEN= Does not compile
-
USE_GNOME= gtk20 # this alters CONFIGURE_TARGET!
GNU_CONFIGURE= yes
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}/gtk
diff --git a/x11-toolkits/gauche-gtk/files/patch-src_gtktexttag.stub b/x11-toolkits/gauche-gtk/files/patch-src_gtktexttag.stub
new file mode 100644
index 000000000000..346af66453d1
--- /dev/null
+++ b/x11-toolkits/gauche-gtk/files/patch-src_gtktexttag.stub
@@ -0,0 +1,28 @@
+--- src/gtktexttag.stub.orig Sat Dec 10 22:21:57 2005
++++ src/gtktexttag.stub Sat Dec 10 22:22:07 2005
+@@ -36,7 +36,6 @@
+ (language-set :type <uint>)
+ (pad1 :type <uint>)
+ (pad2 :type <uint>)
+- (pad3 :type <uint>)
+ )
+ (allocator (c "Scm_GtkObjectAllocate"))
+ )
+@@ -85,8 +84,6 @@
+ (is-text :type <uint>)
+ (pad1 :type <uint>)
+ (pad2 :type <uint>)
+- (pad3 :type <uint>)
+- (pad4 :type <uint>)
+ )
+ (allocator "return Scm_MakeGtkTextAppearance(NULL);")
+ )
+@@ -128,8 +125,6 @@
+ (realized :type <uint>)
+ (pad1 :type <uint>)
+ (pad2 :type <uint>)
+- (pad3 :type <uint>)
+- (pad4 :type <uint>)
+ )
+ (allocator "return Scm_MakeGtkTextAttributes(NULL);")
+ )
diff --git a/x11-toolkits/gauche-gtk/files/patch-src_gtktoolbar.stub b/x11-toolkits/gauche-gtk/files/patch-src_gtktoolbar.stub
new file mode 100644
index 000000000000..2ccba5efa410
--- /dev/null
+++ b/x11-toolkits/gauche-gtk/files/patch-src_gtktoolbar.stub
@@ -0,0 +1,11 @@
+--- src/gtktoolbar.stub.orig Sat Dec 10 22:36:08 2005
++++ src/gtktoolbar.stub Sat Dec 10 22:36:31 2005
+@@ -51,8 +51,6 @@
+ (tooltips :type <gtk-tooltips>)
+ (button-maxw :type <int>)
+ (button-maxh :type <int>)
+- (style-set-connection :type <uint>)
+- (icon-size-connection :type <uint>)
+ (style-set :type <uint>)
+ (icon-size-set :type <uint>)
+ )