aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtk20/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
commit3680f27ebff58ece429c4e032f9ad84fb1372114 (patch)
tree6c5ff4664c1a779ddad350ac887e5706dbfdd4eb /x11-toolkits/gtk20/Makefile
parent02c6e6b485454dc3f5a27cbc887d9e4aaf376a36 (diff)
downloadports-3680f27ebff58ece429c4e032f9ad84fb1372114.tar.gz
ports-3680f27ebff58ece429c4e032f9ad84fb1372114.zip
Presenting GNOME 2.32.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.32/ This will be the last release of the GNOME 2.x series, mainly a bugfix and bridge release to the first release of the GNOME 3.x series. This release features commits by avl, marcus, mezz and myself. The FreeBSD GNOME Team would like to thank the following contributors and testers for there help with this release: Zane C.B. <vvelox@vvelox.net> romain@ Olaf Seibert <O.Seibert@cs.ru.nl> DomiX Bapt <baptiste.daroussin@gmail.com> jsa@ miwi@ Sergio de Almeida Lenzi <lenzi.sergio@gmail.com> Maxim Samsonov <xors@mne.ru> Kris Moore And pav@ for 2 exp-runs PR: ports/152255 ports/143260 ports/141033 ports/149629 ports/150350 ports/151523 With hat: gnome@
Notes
Notes: svn path=/head/; revision=264837
Diffstat (limited to 'x11-toolkits/gtk20/Makefile')
-rw-r--r--x11-toolkits/gtk20/Makefile40
1 files changed, 15 insertions, 25 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index e38f8935ca4c..83d881b07752 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -3,12 +3,12 @@
# Whom: Vanilla I. Shu <vanilla@MinJe.com.TW>
#
# $FreeBSD$
-# $MCom: ports/x11-toolkits/gtk20/Makefile,v 1.191 2010/05/04 10:29:49 kwm Exp $
+# $MCom: ports/x11-toolkits/gtk20/Makefile,v 1.209 2010/11/15 21:17:48 kwm Exp $
#
PORTNAME= gtk
-PORTVERSION= 2.20.1
-PORTREVISION?= 2
+PORTVERSION= 2.22.1
+PORTREVISION?= 0
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/,} \
ftp://ftp.gtk.org/pub/gtk/%SUBDIR%/ \
@@ -24,24 +24,23 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Gimp Toolkit for X11 GUI (current stable version)
+LICENSE= LGPL20
+LICENSE_FILE= ${WRKSRC}/COPYING
USE_BZIP2= yes
LATEST_LINK= gtk20
.if !defined(REFERENCE_PORT)
BUILD_DEPENDS+= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
-LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- jasper.4:${PORTSDIR}/graphics/jasper
RUN_DEPENDS+= ${LOCALBASE}/share/mime/magic:${PORTSDIR}/misc/shared-mime-info \
${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
USE_GMAKE= yes
USE_PERL5_BUILD=yes
+MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:22
-USE_GNOME= gnomehack atk pango ltverhack
+USE_GNOME= gnomehack atk pango gdkpixbuf2 ltverhack
USE_GETTEXT= yes
USE_XORG= xext xrender x11 xinerama xi xrandr xcursor xfixes xdamage \
xcomposite
@@ -49,26 +48,22 @@ CONFIGURE_ARGS= --enable-static --with-xinput=yes --with-libjasper
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-GTK_VERSION= 2.10.0
-PLIST_SUB= GTK_VERSION="${GTK_VERSION}"
-gdk_pixbuf_MAN= gdk-pixbuf-query-loaders.1
-gtk_MAN= gtk-query-immodules-2.0.1 gtk-update-icon-cache.1
-
-MAN1= ${gdk_pixbuf_MAN} ${gtk_MAN}
+MAN1= gtk-query-immodules-2.0.1 gtk-update-icon-cache.1
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug=yes
.endif
+OPTIONS= CUPS "Enable cups printing support" on
+
.include <bsd.port.pre.mk>
.if ${ARCH} == powerpc64
-EXTRA_PATCHES= ${.CURDIR}/files/extra-arch-powerpc64
+EXTRA_PATCHES= ${.CURDIR}/files/extra-arch-powerpc64
.endif
-.if (defined(WITH_CUPS) || exists(${LOCALBASE}/lib/libcups.so)) && \
- !defined(WITHOUT_CUPS)
+.if defined(WITH_CUPS)
LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-client
CONFIGURE_ARGS+=--enable-cups=auto
PLIST_SUB+= CUPS:=""
@@ -82,10 +77,6 @@ post-patch:
${XARGS} ${REINPLACE_CMD} -e 's|-lgmodule|@GMODULE_LIBS@|g'
@${REINPLACE_CMD} -e 's|[{]libdir[}]/locale|{datadir}/locale|g' \
${WRKSRC}/configure
-# GnomeVFS needs pthread; gtk-demo may use GnomeVFS (via GtkFileChooser)
- @${REINPLACE_CMD} -e 's|@CFLAGS@|& ${PTHREAD_CFLAGS}|; \
- s|@LDFLAGS@|& ${PTHREAD_LIBS}|' \
- ${WRKSRC}/demos/gtk-demo/Makefile.in
@${REINPLACE_CMD} -e 's|@LN_S@|${LN} -sf|' ${WRKSRC}/gtk/Makefile.in
@${REINPLACE_CMD} -e 's|file,cups|file,cups,lpr|' \
${WRKSRC}/gtk/Makefile.in
@@ -97,10 +88,9 @@ post-install:
-@${FIND} ${LOCALBASE}/share/icons -type d -depth 1 -exec \
${PREFIX}/bin/gtk-update-icon-cache -q -f {} \; 2>/dev/null
@${MKDIR} ${PREFIX}/lib/gtk-2.0/modules
- @${MKDIR} ${PREFIX}/lib/gtk-2.0/${GTK_VERSION}/engines
- ${INSTALL_MAN} ${gdk_pixbuf_MAN:S|^|${WRKSRC}/docs/reference/gdk-pixbuf/|} \
- ${PREFIX}/man/man1
- ${INSTALL_MAN} ${gtk_MAN:S|^|${WRKSRC}/docs/reference/gtk/|} \
+ @${MKDIR} ${PREFIX}/lib/gtk-2.0/${GTK2_VERSION}/engines
+ @${MKDIR} ${PREFIX}/lib/gtk-2.0/${GTK2_VERSION}/loaders
+ ${INSTALL_MAN} ${MAN1:S|^|${WRKSRC}/docs/reference/gtk/|} \
${PREFIX}/man/man1
.include <bsd.port.post.mk>