aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtkdatabox
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-05-31 14:49:26 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-05-31 14:49:26 +0000
commitebb04f49c21a7da2953675b331eb7c9b1cb7d35b (patch)
tree334e2b5d414b5b4e2d6139fd6873cb1dfd72552a /x11-toolkits/gtkdatabox
parent1884ff8c5075f3e906d1bd2d422dba3269b523d8 (diff)
downloadports-ebb04f49c21a7da2953675b331eb7c9b1cb7d35b.tar.gz
ports-ebb04f49c21a7da2953675b331eb7c9b1cb7d35b.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=297880
Diffstat (limited to 'x11-toolkits/gtkdatabox')
-rw-r--r--x11-toolkits/gtkdatabox/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/x11-toolkits/gtkdatabox/Makefile b/x11-toolkits/gtkdatabox/Makefile
index 1c272b2cb458..0c27270ba029 100644
--- a/x11-toolkits/gtkdatabox/Makefile
+++ b/x11-toolkits/gtkdatabox/Makefile
@@ -22,16 +22,17 @@ USE_AUTOTOOLS= libtool
CONFIGURE_ARGS+= --includedir="${PREFIX}/include/${PORTNAME}" \
--with-html-dir="${PREFIX}/share/doc"
-OPTIONS= GLADE "Enable libglade2 support" off \
- GLADEUI "Enable glade3 support" off
+OPTIONS_DEFINE= GLADE GLADEUI DOCS EXAMPLES
+GLADE_DESC= Enable libglade2 support
+GLADEUI_DESC= Enable glade3 support
.include <bsd.port.pre.mk>
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
USE_GNOME+= referencehack
.endif
-.if !defined(WITHOUT_GLADE)
+.if ${PORT_OPTIONS:MGLADE}
USE_GNOME+= libglade2
CONFIGURE_ARGS+= --enable-libglade
PLIST_SUB+= GLADE=""
@@ -40,7 +41,7 @@ CONFIGURE_ARGS+= --disable-libglade
PLIST_SUB+= GLADE="@comment "
.endif
-.if !defined(WITHOUT_GLADEUI)
+.if ${PORT_OPTIONS:MGLADEUI}
LIB_DEPENDS+= gladeui-1.10:${PORTSDIR}/devel/glade3
CONFIGURE_ARGS+= --enable-glade
PLIST_SUB+= GLADEUI=""
@@ -58,7 +59,7 @@ post-patch:
${WRKSRC}/gtk/Makefile.in ${WRKSRC}/examples/Makefile.in
post-install:
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/*.c ${EXAMPLESDIR}
.endif