aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtkmm12/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>1998-08-31 22:01:46 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>1998-08-31 22:01:46 +0000
commitdb327d4fac5347569385f8d7153e63c5eed2a8e8 (patch)
tree44e08745227618513d100280bbbdafdea6a7b5f3 /x11-toolkits/gtkmm12/Makefile
parent09d62c707e74ffeabfa041d968c212a356462fc5 (diff)
downloadports-db327d4fac5347569385f8d7153e63c5eed2a8e8.tar.gz
ports-db327d4fac5347569385f8d7153e63c5eed2a8e8.zip
C++ wrapper for gtk, a x11 graphics library
PR: ports/6704 Submitted by: Yukihiro Nakai <Nakai@technologist.com>
Notes
Notes: svn path=/head/; revision=12973
Diffstat (limited to 'x11-toolkits/gtkmm12/Makefile')
-rw-r--r--x11-toolkits/gtkmm12/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-toolkits/gtkmm12/Makefile b/x11-toolkits/gtkmm12/Makefile
new file mode 100644
index 000000000000..62ca273522e6
--- /dev/null
+++ b/x11-toolkits/gtkmm12/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gtk--
+# Version required: 0.9.14
+# Date created: 11 May 1998
+# Whom: Yukihiro Nakai <Nakai@technologist.com>
+#
+# $Id$
+#
+
+DISTNAME= Gtk---0.9.14
+PKGNAME= gtk---0.9.14
+CATEGORIES= x11-toolkits
+MASTER_SITES= ftp://ftp.gimp.org/pub/gtk/gtk--/
+
+MAINTAINER= Nakai@technologist.com
+
+LIB_DEPENDS= gtk11\\.1\\.:${PORTSDIR}/x11-toolkits/gtk11
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+
+# Why gtk11 port renames gtk-config to gtk11-config? (patch-ae)
+#GNU_CONFIGURE= yes
+USE_AUTOCONF= yes
+# for the future GNOME support
+#CONFIGURE_ARGS+= --with-gnome=${X11BASE}
+USE_GMAKE= yes
+
+post-install:
+ ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>