aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtksourceview/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-05-08 00:34:09 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-05-08 00:34:09 +0000
commitd22e617995259c970604ecb95987596011fcab19 (patch)
treeaf804fe6ae63af80be9abbb30f08ca1dc55815a9 /x11-toolkits/gtksourceview/Makefile
parent0ee4b84c904dfdd063a47fddde47bab724e05301 (diff)
downloadports-d22e617995259c970604ecb95987596011fcab19.tar.gz
ports-d22e617995259c970604ecb95987596011fcab19.zip
Re-add gtksourceview under the x11-toolkits category. Gtksourceview is
an editor component that adds syntax highlighting support to the default GtkTextView widget.
Notes
Notes: svn path=/head/; revision=80408
Diffstat (limited to 'x11-toolkits/gtksourceview/Makefile')
-rw-r--r--x11-toolkits/gtksourceview/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-toolkits/gtksourceview/Makefile b/x11-toolkits/gtksourceview/Makefile
new file mode 100644
index 000000000000..ab5cbcd650c0
--- /dev/null
+++ b/x11-toolkits/gtksourceview/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gtksourceview
+# Date created: 07 May 2003
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtksourceview
+PORTVERSION= 0.2.0
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.2
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A text widget that adds syntax highlighting to the GtkTextView widget
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+USE_GNOME= gnomeprefix gnomehack libgnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lgnuregex"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>