aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/guile-gtk/Makefile
diff options
context:
space:
mode:
authorYukihiro Nakai <nakai@FreeBSD.org>2000-01-12 04:49:49 +0000
committerYukihiro Nakai <nakai@FreeBSD.org>2000-01-12 04:49:49 +0000
commit42d7c6194663fa5398ef11c35b319cc0bdf0659d (patch)
treebfc4c6253c7d852a73626d708337bfdb54edcf0a /x11-toolkits/guile-gtk/Makefile
parent0e2e06a88a2bf289d999d1c1d05cb549664b8f7c (diff)
downloadports-42d7c6194663fa5398ef11c35b319cc0bdf0659d.tar.gz
ports-42d7c6194663fa5398ef11c35b319cc0bdf0659d.zip
Initial import.
Guile binding for GTK+.
Notes
Notes: svn path=/head/; revision=24665
Diffstat (limited to 'x11-toolkits/guile-gtk/Makefile')
-rw-r--r--x11-toolkits/guile-gtk/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-toolkits/guile-gtk/Makefile b/x11-toolkits/guile-gtk/Makefile
new file mode 100644
index 000000000000..d44d91a470b5
--- /dev/null
+++ b/x11-toolkits/guile-gtk/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: guile-gtk
+# Version required: 0.17
+# Date created: 1 January 2000
+# Whom: Matt Braithwaite <mab@red-bean.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= guile-gtk-0.17
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://www.ping.de/sites/zagadka/guile-gtk/download/
+
+MAINTAINER= mab@red-bean.com
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
+ guile.6:${PORTSDIR}/lang/guile
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/giflib" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>