aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/irrlicht/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-12-25 03:11:39 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-12-25 03:11:39 +0000
commit9b29d084c23668199c6b635757f3e27785e7651b (patch)
tree7b6cd630753af90d2d8a9a2fa5834bbb33ca1b87 /x11-toolkits/irrlicht/Makefile
parent1275f475d4e20acc3f565886450c0a8a9b36e427 (diff)
downloadports-9b29d084c23668199c6b635757f3e27785e7651b.tar.gz
ports-9b29d084c23668199c6b635757f3e27785e7651b.zip
- Update to 1.4
Submitted by: Luke Dean <LukeD___ at _pobox.com> via email
Notes
Notes: svn path=/head/; revision=204481
Diffstat (limited to 'x11-toolkits/irrlicht/Makefile')
-rw-r--r--x11-toolkits/irrlicht/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/x11-toolkits/irrlicht/Makefile b/x11-toolkits/irrlicht/Makefile
index 270d25e663d0..34cdfb50b271 100644
--- a/x11-toolkits/irrlicht/Makefile
+++ b/x11-toolkits/irrlicht/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= irrlicht
-PORTVERSION= 1.3.1
+PORTVERSION= 1.4
CATEGORIES= x11-toolkits graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,7 +18,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
USE_ZIP= yes
-USE_DOS2UNIX= yes
+USE_DOS2UNIX= Makefile *.cpp *.h *.txt
USE_GMAKE= yes
USE_GL= yes
USE_XLIB= yes
@@ -29,13 +29,14 @@ PLIST_SUB+= SHARED_LIB_VER=${SHARED_LIB_VER}
SUB_FILES= pkg-message
BUILD_WRKSRC= ${WRKSRC}/source/Irrlicht
-SHARED_LIB_VER= 1.3.0
+SHARED_LIB_VER= 1.4
EXAMPLEDIRS= 01.HelloWorld 02.Quake3Map 03.CustomSceneNode 04.Movement 05.UserInterface \
06.2DGraphics 07.Collision 08.SpecialFX 09.Meshviewer 10.Shaders \
11.PerPixelLighting 12.TerrainRendering 13.RenderToTexture 15.LoadIrrFile \
Demo
-OPTIONS= EXAMPLES "Install example files" on
+OPTIONS= DEBUG "Compile with debugging simbols" off \
+ EXAMPLES "Install example files" on
.include <bsd.port.pre.mk>
@@ -49,6 +50,10 @@ PLIST_SUB+= EXAMPLES=""
PLIST_SUB+= EXAMPLES="@comment "
.endif
+.if !defined(WITH_DEBUG)
+MAKE_ENV+= NDEBUG=1
+.endif
+
do-install:
${MKDIR} ${PREFIX}/include/${PORTNAME}
cd ${WRKSRC}/include && \