aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libbonoboui/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-04-08 21:01:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-04-08 21:01:48 +0000
commit94472178617a67889b0c1030cff239b50e4c823a (patch)
tree102d7b2ba032fad67443ddc12167c1018661d768 /x11-toolkits/libbonoboui/Makefile
parenta6157ad4ec4e52d3b5c4ba6616ded40bd039dad3 (diff)
downloadports-94472178617a67889b0c1030cff239b50e4c823a.tar.gz
ports-94472178617a67889b0c1030cff239b50e4c823a.zip
Add libbonoboui, the GUI components for GOME 2.0 bonobo component.
Reviewed by: sobomax Approved by: sobomax
Notes
Notes: svn path=/head/; revision=57466
Diffstat (limited to 'x11-toolkits/libbonoboui/Makefile')
-rw-r--r--x11-toolkits/libbonoboui/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-toolkits/libbonoboui/Makefile b/x11-toolkits/libbonoboui/Makefile
new file mode 100644
index 000000000000..e3c79e43f071
--- /dev/null
+++ b/x11-toolkits/libbonoboui/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: libbonoboui
+# Date created: 04 April 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libbonoboui
+PORTVERSION= 1.113.0
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta3
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= gnomecanvas-2.0:${PORTSDIR}/graphics/libgnomecanvas \
+ gnome-2.0:${PORTSDIR}/x11/libgnome
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+pre-patch:
+ @find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
+ 's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
+ s|\$\(libdir\)/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g'
+
+.include <bsd.port.mk>