aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libwnck
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-04-24 16:06:45 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-04-24 16:06:45 +0000
commitec8563a2daa00635ccc6c6a601f4ec82f9b8625c (patch)
tree59d140704b4989ca53670f75ddd6f0b90537df2e /x11-toolkits/libwnck
parent3f6a14b8696883ecf8ad811408965690d003b58b (diff)
downloadports-ec8563a2daa00635ccc6c6a601f4ec82f9b8625c.tar.gz
ports-ec8563a2daa00635ccc6c6a601f4ec82f9b8625c.zip
Add libwnck, an GNOME 2.0 API for building pagers and tasklists.
Reviewed by: sobomax Approved by: sobomax
Notes
Notes: svn path=/head/; revision=58067
Diffstat (limited to 'x11-toolkits/libwnck')
-rw-r--r--x11-toolkits/libwnck/Makefile35
-rw-r--r--x11-toolkits/libwnck/distinfo1
-rw-r--r--x11-toolkits/libwnck/files/patch-ltmain.sh45
-rw-r--r--x11-toolkits/libwnck/pkg-comment1
-rw-r--r--x11-toolkits/libwnck/pkg-descr5
-rw-r--r--x11-toolkits/libwnck/pkg-plist39
6 files changed, 126 insertions, 0 deletions
diff --git a/x11-toolkits/libwnck/Makefile b/x11-toolkits/libwnck/Makefile
new file mode 100644
index 000000000000..4726153e0452
--- /dev/null
+++ b/x11-toolkits/libwnck/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: libwnck
+# Date created: 12 April 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libwnck
+PORTVERSION= 0.7
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta3
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_BISON= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
+ 's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/libwnck/distinfo b/x11-toolkits/libwnck/distinfo
new file mode 100644
index 000000000000..ffb14fc8c45d
--- /dev/null
+++ b/x11-toolkits/libwnck/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/libwnck-0.7.tar.bz2) = 9b32a1186a9ffb16c3190b1557b50d10
diff --git a/x11-toolkits/libwnck/files/patch-ltmain.sh b/x11-toolkits/libwnck/files/patch-ltmain.sh
new file mode 100644
index 000000000000..91713d2306f8
--- /dev/null
+++ b/x11-toolkits/libwnck/files/patch-ltmain.sh
@@ -0,0 +1,45 @@
+
+$FreeBSD$
+
+--- ltmain.sh.orig Wed Jan 23 11:38:40 2002
++++ ltmain.sh Sun Feb 3 01:44:17 2002
+@@ -1037,8 +1037,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -2412,6 +2420,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test "$build_libtool_need_lc" = "yes"; then
+@@ -4179,10 +4190,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/x11-toolkits/libwnck/pkg-comment b/x11-toolkits/libwnck/pkg-comment
new file mode 100644
index 000000000000..10fc713395ac
--- /dev/null
+++ b/x11-toolkits/libwnck/pkg-comment
@@ -0,0 +1 @@
+Library used for writing pagers and taskslists
diff --git a/x11-toolkits/libwnck/pkg-descr b/x11-toolkits/libwnck/pkg-descr
new file mode 100644
index 000000000000..ada0fd869e07
--- /dev/null
+++ b/x11-toolkits/libwnck/pkg-descr
@@ -0,0 +1,5 @@
+libwnck is aWindow Navigator Construction Kit, i.e. a library to use
+for writing pagers and taskslists and stuff. It is needed for the
+GNOME 2.0 desktop.
+
+WWW: http://www.gnome.org/
diff --git a/x11-toolkits/libwnck/pkg-plist b/x11-toolkits/libwnck/pkg-plist
new file mode 100644
index 000000000000..a6b67f561a87
--- /dev/null
+++ b/x11-toolkits/libwnck/pkg-plist
@@ -0,0 +1,39 @@
+include/libwnck-1.0/libwnck/application.h
+include/libwnck-1.0/libwnck/libwnck.h
+include/libwnck-1.0/libwnck/pager.h
+include/libwnck-1.0/libwnck/screen.h
+include/libwnck-1.0/libwnck/tasklist.h
+include/libwnck-1.0/libwnck/util.h
+include/libwnck-1.0/libwnck/window-action-menu.h
+include/libwnck-1.0/libwnck/window-menu.h
+include/libwnck-1.0/libwnck/window.h
+include/libwnck-1.0/libwnck/wnck-enum-types.h
+include/libwnck-1.0/libwnck/workspace.h
+lib/libwnck-1.a
+lib/libwnck-1.so
+lib/libwnck-1.so.2
+libdata/pkgconfig/libwnck-1.0.pc
+share/locale/da/LC_MESSAGES/libwnck.mo
+share/locale/de/LC_MESSAGES/libwnck.mo
+share/locale/es/LC_MESSAGES/libwnck.mo
+share/locale/et/LC_MESSAGES/libwnck.mo
+share/locale/fi/LC_MESSAGES/libwnck.mo
+share/locale/ja/LC_MESSAGES/libwnck.mo
+share/locale/ko/LC_MESSAGES/libwnck.mo
+share/locale/lv/LC_MESSAGES/libwnck.mo
+share/locale/ms/LC_MESSAGES/libwnck.mo
+share/locale/nl/LC_MESSAGES/libwnck.mo
+share/locale/nn/LC_MESSAGES/libwnck.mo
+share/locale/no/LC_MESSAGES/libwnck.mo
+share/locale/pl/LC_MESSAGES/libwnck.mo
+share/locale/pt/LC_MESSAGES/libwnck.mo
+share/locale/ru/LC_MESSAGES/libwnck.mo
+share/locale/sk/LC_MESSAGES/libwnck.mo
+share/locale/sl/LC_MESSAGES/libwnck.mo
+share/locale/sv/LC_MESSAGES/libwnck.mo
+share/locale/tr/LC_MESSAGES/libwnck.mo
+share/locale/uk/LC_MESSAGES/libwnck.mo
+share/locale/zh_CN/LC_MESSAGES/libwnck.mo
+share/locale/zh_TW/LC_MESSAGES/libwnck.mo
+@dirrm include/libwnck-1.0/libwnck
+@dirrm include/libwnck-1.0