aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libzvt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-04-24 16:05:17 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-04-24 16:05:17 +0000
commit3f6a14b8696883ecf8ad811408965690d003b58b (patch)
treeb333bb36d9768d1cada3c7a84a1e20771b61461a /x11-toolkits/libzvt
parent07390593853759547b543f09f93eb68584964b74 (diff)
downloadports-3f6a14b8696883ecf8ad811408965690d003b58b.tar.gz
ports-3f6a14b8696883ecf8ad811408965690d003b58b.zip
Add libzvt, the API for Zed's Virtual Terminal, the first of many components
of the GNOME 2.0 Desktop. Reviewed by: sobomax Approved by: sobomax
Notes
Notes: svn path=/head/; revision=58065
Diffstat (limited to 'x11-toolkits/libzvt')
-rw-r--r--x11-toolkits/libzvt/Makefile38
-rw-r--r--x11-toolkits/libzvt/distinfo1
-rw-r--r--x11-toolkits/libzvt/files/patch-ltmain.sh45
-rw-r--r--x11-toolkits/libzvt/pkg-comment1
-rw-r--r--x11-toolkits/libzvt/pkg-descr4
-rw-r--r--x11-toolkits/libzvt/pkg-plist12
6 files changed, 101 insertions, 0 deletions
diff --git a/x11-toolkits/libzvt/Makefile b/x11-toolkits/libzvt/Makefile
new file mode 100644
index 000000000000..af6a110f5cd5
--- /dev/null
+++ b/x11-toolkits/libzvt/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: libzvt
+# Date created: 12 April 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libzvt
+PORTVERSION= 1.113.0
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta3
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20 \
+ art_lgpl_2.5:${PORTSDIR}/graphics/libart_lgpl2
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_BISON= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
+ 's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
+ @find ${WRKSRC} -name "*.[ch]" | xargs ${PERL} -pi -e \
+ 's|malloc\.h|stdlib.h|g'
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/libzvt/distinfo b/x11-toolkits/libzvt/distinfo
new file mode 100644
index 000000000000..ce94fc3a777a
--- /dev/null
+++ b/x11-toolkits/libzvt/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/libzvt-1.113.0.tar.bz2) = da4ad73ac6153b845d33fc04fd5fb85a
diff --git a/x11-toolkits/libzvt/files/patch-ltmain.sh b/x11-toolkits/libzvt/files/patch-ltmain.sh
new file mode 100644
index 000000000000..91713d2306f8
--- /dev/null
+++ b/x11-toolkits/libzvt/files/patch-ltmain.sh
@@ -0,0 +1,45 @@
+
+$FreeBSD$
+
+--- ltmain.sh.orig Wed Jan 23 11:38:40 2002
++++ ltmain.sh Sun Feb 3 01:44:17 2002
+@@ -1037,8 +1037,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -2412,6 +2420,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test "$build_libtool_need_lc" = "yes"; then
+@@ -4179,10 +4190,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/x11-toolkits/libzvt/pkg-comment b/x11-toolkits/libzvt/pkg-comment
new file mode 100644
index 000000000000..370d07a2536c
--- /dev/null
+++ b/x11-toolkits/libzvt/pkg-comment
@@ -0,0 +1 @@
+Library components for Zed's Virtual Terminal
diff --git a/x11-toolkits/libzvt/pkg-descr b/x11-toolkits/libzvt/pkg-descr
new file mode 100644
index 000000000000..0639f81b2c7c
--- /dev/null
+++ b/x11-toolkits/libzvt/pkg-descr
@@ -0,0 +1,4 @@
+libzvt is the library backend of zterm, yet another virtual terminal
+program. It is needed for the application side of the GNOME 2.0 desktop.
+
+WWW: http://www.gnome.org/
diff --git a/x11-toolkits/libzvt/pkg-plist b/x11-toolkits/libzvt/pkg-plist
new file mode 100644
index 000000000000..8010139ae802
--- /dev/null
+++ b/x11-toolkits/libzvt/pkg-plist
@@ -0,0 +1,12 @@
+include/libzvt-2.0/libzvt/background.h
+include/libzvt-2.0/libzvt/libzvt.h
+include/libzvt-2.0/libzvt/lists.h
+include/libzvt-2.0/libzvt/vt.h
+include/libzvt-2.0/libzvt/vtx.h
+lib/libzvt-2.a
+lib/libzvt-2.so
+lib/libzvt-2.so.0
+libdata/pkgconfig/libzvt-2.0.pc
+sbin/gnome-pty-helper-2
+@dirrm include/libzvt-2.0/libzvt
+@dirrm include/libzvt-2.0