aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/linux-f10-tk85/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2009-04-06 14:21:09 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2009-04-06 14:21:09 +0000
commita3e022c8fb24bde46d175f4b4cdc966d74bf8094 (patch)
tree54812002886a4dac43a1e93ad11ed8e0db559a51 /x11-toolkits/linux-f10-tk85/Makefile
parentd95a2dd0e4803e0b271803b6f851b1367b42e715 (diff)
downloadports-a3e022c8fb24bde46d175f4b4cdc966d74bf8094.tar.gz
ports-a3e022c8fb24bde46d175f4b4cdc966d74bf8094.zip
Add linux-f8-tk84 8.4.17, graphical toolkit for TCL (Linux Fedora 8).
PR: ports/131805 Submitted by: Stas Timokhin <stast at bsdportal.ru>
Notes
Notes: svn path=/head/; revision=231703
Diffstat (limited to 'x11-toolkits/linux-f10-tk85/Makefile')
-rw-r--r--x11-toolkits/linux-f10-tk85/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-toolkits/linux-f10-tk85/Makefile b/x11-toolkits/linux-f10-tk85/Makefile
new file mode 100644
index 000000000000..de81daeda88a
--- /dev/null
+++ b/x11-toolkits/linux-f10-tk85/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: x11-toolkits/linux-f8-tk84
+# Date created: 11-08-2008
+# Whom: Stas Timokhin <stast@bsdportal.ru>
+# $FreeBSD$
+#
+
+PORTNAME= tk
+PORTVERSION= 8.4.17
+CATEGORIES= x11-toolkits linux
+PKGNAMEPREFIX= linux-f8-
+PKGNAMESUFFIX= 84
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
+
+MAINTAINER= stast@bsdportal.ru
+COMMENT= Graphical toolkit for TCL (Linux Fedora 8)
+
+USE_LINUX_RPM= yes
+USE_LINUX_APPS= xorglibs
+LINUX_DIST_VER= 8
+RPMVERSION= 2.fc8
+BRANELF_FILES= usr/bin/wish8.4
+USE_LDCONFIG= yes
+
+PLIST_SUB= PORTVERSION="${PORTVERSION}"
+DESCR= ${.CURDIR}/../${PORTNAME}${PKGNAMESUFFIX}/pkg-descr
+
+.include <bsd.port.pre.mk>
+
+pre-fetch:
+.if ${OSVERSION}<700055
+ IGNORE= You need at least FreeBSD>=7.0 RELEASE with Linux emulation 2.6.x
+.endif
+
+.include <bsd.port.post.mk>