aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/open-motif
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-09-21 06:58:29 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-09-21 06:58:29 +0000
commita2f0cb339a51e153ae9dcddd43d0f912e5ae78ac (patch)
tree1796df765c413ec7128823d6b519c4ed08c3bbd6 /x11-toolkits/open-motif
parent99676f798e74d5156c37641ff07be51e031df95d (diff)
downloadports-a2f0cb339a51e153ae9dcddd43d0f912e5ae78ac.tar.gz
ports-a2f0cb339a51e153ae9dcddd43d0f912e5ae78ac.zip
Unbreak by using find+xargs instead of globbing that results in
command line overflow if the length of WRKDIRPREFIX is very long.
Notes
Notes: svn path=/head/; revision=66996
Diffstat (limited to 'x11-toolkits/open-motif')
-rw-r--r--x11-toolkits/open-motif/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/x11-toolkits/open-motif/Makefile b/x11-toolkits/open-motif/Makefile
index 1a2eb5ed3029..112a5a3dcba1 100644
--- a/x11-toolkits/open-motif/Makefile
+++ b/x11-toolkits/open-motif/Makefile
@@ -53,12 +53,15 @@ post-patch:
@${FIND} ${DEMOS_SRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|^install-data-am: |install-data-am: # |g'
# fix sections
- @${REINPLACE_CMD} -e 's|user cmd|1|' ${WRKSRC}/doc/man/man1/*.1
- @${REINPLACE_CMD} -e 's|library call|3|' ${WRKSRC}/doc/man/man3/*.3
+ @${FIND} ${WRKSRC}/doc/man/man1 -name '*.1' -maxdepth 1 | \
+ ${XARGS} ${REINPLACE_CMD} -e 's|user cmd|1|'
+ @${FIND} ${WRKSRC}/doc/man/man3 -name '*.3' -maxdepth 1 | \
+ ${XARGS} ${REINPLACE_CMD} -e 's|library call|3|'
# mwmrc is not a kernel interface!!
@cd ${WRKSRC}/doc/man && ${CP} -f man4/mwmrc.4 man5/mwmrc.5
- @${REINPLACE_CMD} -e 's|special file|5| ; \
- s|file formats|5|' ${WRKSRC}/doc/man/man5/*.5
+ @${FIND} ${WRKSRC}/doc/man/man5 -name '*.5' -maxdepth 1 | \
+ ${XARGS} ${REINPLACE_CMD} -e 's|special file|5| ; \
+ s|file formats|5|'
post-install:
.if !defined(WITHOUT_OPENMOTIF_DEMOS)