aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/p5-Gtk2-Ex-PodViewer/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-12-03 16:28:14 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-12-03 16:28:14 +0000
commit4afaaa2aebcabb1b03c5ab065c72c0447b693ec2 (patch)
tree0ca09d972fee438511708e9159316d472a57b947 /x11-toolkits/p5-Gtk2-Ex-PodViewer/Makefile
parent8938a85ca96e63e1d4cd0d46327156b4b69245d1 (diff)
downloadports-4afaaa2aebcabb1b03c5ab065c72c0447b693ec2.tar.gz
ports-4afaaa2aebcabb1b03c5ab065c72c0447b693ec2.zip
- Update to 0.17
- Rename the port due to upstream changes Approved by: ports@c0decafe.net (maintainer, express-timeout) Repocopy by: marcus
Notes
Notes: svn path=/head/; revision=178701
Diffstat (limited to 'x11-toolkits/p5-Gtk2-Ex-PodViewer/Makefile')
-rw-r--r--x11-toolkits/p5-Gtk2-Ex-PodViewer/Makefile34
1 files changed, 20 insertions, 14 deletions
diff --git a/x11-toolkits/p5-Gtk2-Ex-PodViewer/Makefile b/x11-toolkits/p5-Gtk2-Ex-PodViewer/Makefile
index 1fcfca99e537..574cc018f5cc 100644
--- a/x11-toolkits/p5-Gtk2-Ex-PodViewer/Makefile
+++ b/x11-toolkits/p5-Gtk2-Ex-PodViewer/Makefile
@@ -1,29 +1,35 @@
-# New ports collection makefile for: p5-Gtk2-PodViewer
+# New ports collection makefile for: p5-Gtk2-Ex-PodViewer
# Date created: 2004-08-20
# Whom: ports@c0decafe.net
#
# $FreeBSD$
#
-PORTNAME= Gtk2-PodViewer
-PORTVERSION= 0.09
-PORTREVISION= 2
+PORTNAME= Gtk2-Ex-PodViewer
+PORTVERSION= 0.17
CATEGORIES= x11-toolkits perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= ../../authors/id/G/GB/GBROWN/
+MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
MAINTAINER= ports@c0decafe.net
-COMMENT= Gtk2-Perl widget and program for displaying POD
+COMMENT= Displays plain old documentation
-BUILD_DEPENDS= ${SITE_PERL}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy \
- ${SITE_PERL}/${PERL_ARCH}/Gtk2.pm:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
- ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
+ p5-IO-stringy>=0:${PORTSDIR}/devel/p5-IO-stringy \
+ p5-gettext>=0:${PORTSDIR}/devel/p5-Locale-gettext \
+ p5-Gtk2-Ex-Simple-List>=0.50:${PORTSDIR}/x11-toolkits/p5-Gtk2-Ex-Simple-List \
+ p5-Pod-Simple>=0:${PORTSDIR}/textproc/p5-Pod-Simple
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN1= podviewer.1
-MAN3= Gtk2::PodViewer.3 Gtk2::PodViewer::Parser.3
+MAN1= podviewer.1
+MAN3= ${PORTNAME:S/-/::/g}.3 ${PORTNAME:S/-/::/g}::Parser.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl5.8 from ports
+.endif
+
+.include <bsd.port.post.mk>