aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/p5-Gtk2-Ex-Simple-List
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-12-03 16:11:00 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-12-03 16:11:00 +0000
commit4fe097b6dc9be4dbe56bbb3564699fb75f769c2d (patch)
tree59a42172f758cec6b9055b92a4c48e804178b535 /x11-toolkits/p5-Gtk2-Ex-Simple-List
parent964faf43004045904095b5bd11c931b64220a591 (diff)
downloadports-4fe097b6dc9be4dbe56bbb3564699fb75f769c2d.tar.gz
ports-4fe097b6dc9be4dbe56bbb3564699fb75f769c2d.zip
Add port x11-toolkits/p5-Gtk2-Ex-Simple-List:
Gtk2 has a powerful, but complex MVC (Model, View, Controller) system used to implement list and tree widgets. Gtk2::Ex::Simple::List automates the complex setup work and allows you to treat the list model as a more natural list of lists structure. <...> WWW: http://search.cpan.org/dist/Gtk2-Ex-Simple-List/ Author: Ross McFarland <rmcfarla@neces.com> Justification: needed by x11-toolkits/p5-Gtk-Ex-PodViewer
Notes
Notes: svn path=/head/; revision=178694
Diffstat (limited to 'x11-toolkits/p5-Gtk2-Ex-Simple-List')
-rw-r--r--x11-toolkits/p5-Gtk2-Ex-Simple-List/Makefile24
-rw-r--r--x11-toolkits/p5-Gtk2-Ex-Simple-List/distinfo3
-rw-r--r--x11-toolkits/p5-Gtk2-Ex-Simple-List/pkg-descr20
-rw-r--r--x11-toolkits/p5-Gtk2-Ex-Simple-List/pkg-plist11
4 files changed, 58 insertions, 0 deletions
diff --git a/x11-toolkits/p5-Gtk2-Ex-Simple-List/Makefile b/x11-toolkits/p5-Gtk2-Ex-Simple-List/Makefile
new file mode 100644
index 000000000000..d2f1c42e4df9
--- /dev/null
+++ b/x11-toolkits/p5-Gtk2-Ex-Simple-List/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Gtk2-Ex-Simple-List
+# Date created: 3 December 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Gtk2-Ex-Simple-List
+PORTVERSION= 0.50
+CATEGORIES= x11-toolkits perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= A simple interface to complex MVC list widget
+
+BUILD_DEPENDS= p5-Glib2>=1.00:${PORTSDIR}/devel/p5-Glib2 \
+ p5-Gtk2>=1.060:${PORTSDIR}/x11-toolkits/p5-Gtk2
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+MAN3= ${PORTNAME:S/-/::/g}.3
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/p5-Gtk2-Ex-Simple-List/distinfo b/x11-toolkits/p5-Gtk2-Ex-Simple-List/distinfo
new file mode 100644
index 000000000000..e3a440118c38
--- /dev/null
+++ b/x11-toolkits/p5-Gtk2-Ex-Simple-List/distinfo
@@ -0,0 +1,3 @@
+MD5 (Gtk2-Ex-Simple-List-0.50.tar.gz) = f66c71bbb794b699f0c3e8ca7cebc35b
+SHA256 (Gtk2-Ex-Simple-List-0.50.tar.gz) = 62df53d0da396aba8e96aee06d869a77b8cf54af2ebd9df885b7aef2d5a207b5
+SIZE (Gtk2-Ex-Simple-List-0.50.tar.gz) = 13769
diff --git a/x11-toolkits/p5-Gtk2-Ex-Simple-List/pkg-descr b/x11-toolkits/p5-Gtk2-Ex-Simple-List/pkg-descr
new file mode 100644
index 000000000000..9c2b6c02916d
--- /dev/null
+++ b/x11-toolkits/p5-Gtk2-Ex-Simple-List/pkg-descr
@@ -0,0 +1,20 @@
+Gtk2 has a powerful, but complex MVC (Model, View, Controller) system
+used to implement list and tree widgets. Gtk2::Ex::Simple::List
+automates the complex setup work and allows you to treat the list model
+as a more natural list of lists structure.
+
+After creating a new Gtk2::Ex::Simple::List object with the desired
+columns you may set the list data with a simple Perl array assignment.
+Rows may be added or deleted with all of the normal array operations.
+You can treat the data member of the Simple::List object as an array
+reference, and manipulate the list data with perl's normal array
+operators.
+
+A mechanism has also been put into place allowing columns to be Perl
+scalars. The scalar is converted to text through Perl's normal
+mechanisms and then displayed in the list. This same mechanism can be
+expanded by defining arbitrary new column types before calling the new
+function.
+
+WWW: http://search.cpan.org/dist/Gtk2-Ex-Simple-List/
+Author: Ross McFarland <rmcfarla@neces.com>
diff --git a/x11-toolkits/p5-Gtk2-Ex-Simple-List/pkg-plist b/x11-toolkits/p5-Gtk2-Ex-Simple-List/pkg-plist
new file mode 100644
index 000000000000..bb8b4b9804a1
--- /dev/null
+++ b/x11-toolkits/p5-Gtk2-Ex-Simple-List/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Gtk2/Ex/Simple/List/.packlist
+%%SITE_PERL%%/Gtk2/Ex/Simple/List.pm
+%%SITE_PERL%%/Gtk2/Ex/Simple/TiedCommon.pm
+%%SITE_PERL%%/Gtk2/Ex/Simple/TiedList.pm
+@dirrmtry %%SITE_PERL%%/Gtk2/Ex/Simple
+@dirrmtry %%SITE_PERL%%/Gtk2/Ex
+@dirrmtry %%SITE_PERL%%/Gtk2
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Gtk2/Ex/Simple/List
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Gtk2/Ex/Simple
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Gtk2/Ex
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Gtk2