aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/p5-Tk-JComboBox
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-08-31 11:38:32 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-08-31 11:38:32 +0000
commit15ec2820588b6679fdd0d9ec91f2cefd92a743bb (patch)
tree6a3ba7c42e2419f87da45f9eb0530fb92062ee11 /x11-toolkits/p5-Tk-JComboBox
parent5f8bc532335cd9765cf66c379ddd1d88b1185b7e (diff)
downloadports-15ec2820588b6679fdd0d9ec91f2cefd92a743bb.tar.gz
ports-15ec2820588b6679fdd0d9ec91f2cefd92a743bb.zip
Add port x11-toolkits/p5-Tk-JComboBox:
JComboBox is a composite widget that contains a text Label or Entry, a Button, and a popup Listbox. It performs the same sort of tasks that can be accomplished by several other Composite widgets. Some such as BrowseEntry and Optionmenu are part of the standard Tk distribution, and there are many others available in CPAN. JComboBox borrows features from the Java Swing component bearing the same name, but falls short of being a true clone. Many of the methods and the general look and feel should be familiar to java developers. JComboBox also combines several features offered by many of the other "Combo Box" implementations, and works in two modes: editable and readonly. In readonly mode, JComboBox offers similar functionality to Optionmenu. It is basically a labeled button that activates a popup list. An item from the list is displayed on the Button when selected. When editable, JComboBox somewhat resembles BrowseEntry. That is, the widget is composed of an Entry widget with a Button to the right of it. As in the editable mode, the Button activates a popup Listbox from which a single item can be selected. WWW: http://search.cpan.org/dist/Tk-JComboBox/ Author: Rob Seegel <RobSeegel@comcast.net> Justification: sysutils/namefix dep
Notes
Notes: svn path=/head/; revision=171712
Diffstat (limited to 'x11-toolkits/p5-Tk-JComboBox')
-rw-r--r--x11-toolkits/p5-Tk-JComboBox/Makefile25
-rw-r--r--x11-toolkits/p5-Tk-JComboBox/distinfo3
-rw-r--r--x11-toolkits/p5-Tk-JComboBox/pkg-descr23
-rw-r--r--x11-toolkits/p5-Tk-JComboBox/pkg-plist15
4 files changed, 66 insertions, 0 deletions
diff --git a/x11-toolkits/p5-Tk-JComboBox/Makefile b/x11-toolkits/p5-Tk-JComboBox/Makefile
new file mode 100644
index 000000000000..67ac193208a1
--- /dev/null
+++ b/x11-toolkits/p5-Tk-JComboBox/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Tk-JComboBox
+# Date created: 31 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tk-JComboBox
+PORTVERSION= 1.11
+CATEGORIES= x11-toolkits perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Contains a Label or Entry, a Button, and a Listbox
+
+BUILD_DEPENDS= p5-Tk>=804.027:${PORTSDIR}/x11-toolkits/p5-Tk \
+ p5-Tie-Watch>=1.2:${PORTSDIR}/devel/p5-Tie-Watch
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= ${PORTNAME:S/-/::/g}.3 Tk::CWidget.3 Tk::JComboBox::tutorial.3
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/p5-Tk-JComboBox/distinfo b/x11-toolkits/p5-Tk-JComboBox/distinfo
new file mode 100644
index 000000000000..e2276497b9c7
--- /dev/null
+++ b/x11-toolkits/p5-Tk-JComboBox/distinfo
@@ -0,0 +1,3 @@
+MD5 (Tk-JComboBox-1.11.tar.gz) = 9ddd86670e36ca71f92d10a3354c528f
+SHA256 (Tk-JComboBox-1.11.tar.gz) = 9b741d9cfc8d60f0c242fe58886b20c26b424b541730d4482efe27b90472a210
+SIZE (Tk-JComboBox-1.11.tar.gz) = 61192
diff --git a/x11-toolkits/p5-Tk-JComboBox/pkg-descr b/x11-toolkits/p5-Tk-JComboBox/pkg-descr
new file mode 100644
index 000000000000..5dcb0ca56079
--- /dev/null
+++ b/x11-toolkits/p5-Tk-JComboBox/pkg-descr
@@ -0,0 +1,23 @@
+JComboBox is a composite widget that contains a text Label or Entry, a
+Button, and a popup Listbox. It performs the same sort of tasks that can be
+accomplished by several other Composite widgets. Some such as BrowseEntry
+and Optionmenu are part of the standard Tk distribution, and there are many
+others available in CPAN.
+
+JComboBox borrows features from the Java Swing component bearing the same
+name, but falls short of being a true clone. Many of the methods and the
+general look and feel should be familiar to java developers. JComboBox also
+combines several features offered by many of the other "Combo Box"
+implementations, and works in two modes: editable and readonly.
+
+In readonly mode, JComboBox offers similar functionality to Optionmenu. It
+is basically a labeled button that activates a popup list. An item from the
+list is displayed on the Button when selected.
+
+When editable, JComboBox somewhat resembles BrowseEntry. That is, the
+widget is composed of an Entry widget with a Button to the right of it. As
+in the editable mode, the Button activates a popup Listbox from which a
+single item can be selected.
+
+WWW: http://search.cpan.org/dist/Tk-JComboBox/
+Author: Rob Seegel <RobSeegel@comcast.net>
diff --git a/x11-toolkits/p5-Tk-JComboBox/pkg-plist b/x11-toolkits/p5-Tk-JComboBox/pkg-plist
new file mode 100644
index 000000000000..5d5c44f5e19a
--- /dev/null
+++ b/x11-toolkits/p5-Tk-JComboBox/pkg-plist
@@ -0,0 +1,15 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk/JComboBox/.packlist
+%%SITE_PERL%%/Tk/CWidget.pm
+%%SITE_PERL%%/Tk/CWidget.pod
+%%SITE_PERL%%/Tk/CWidget/Util/Boolean.pm
+%%SITE_PERL%%/Tk/JComboBox.pm
+%%SITE_PERL%%/Tk/JComboBox.pod
+%%SITE_PERL%%/Tk/JComboBox/jcb_edit.gif
+%%SITE_PERL%%/Tk/JComboBox/jcb_ro.gif
+%%SITE_PERL%%/Tk/JComboBox/tutorial.pod
+@dirrmtry %%SITE_PERL%%/Tk/JComboBox
+@dirrmtry %%SITE_PERL%%/Tk/CWidget/Util
+@dirrmtry %%SITE_PERL%%/Tk/CWidget
+@dirrmtry %%SITE_PERL%%/Tk
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk/JComboBox
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk