aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/php-gtk/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-01 23:06:03 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-01 23:06:03 +0000
commitdd3060cd59be44abe38a9979073053aa50ecf14d (patch)
tree8b520ebd3a0cd5929ce8e23d55d97d3201e3c6cd /x11-toolkits/php-gtk/Makefile
parentb3df6d1ecec2b3478f9f450e0004dfd916abfd40 (diff)
downloadports-dd3060cd59be44abe38a9979073053aa50ecf14d.tar.gz
ports-dd3060cd59be44abe38a9979073053aa50ecf14d.zip
New port: php-gtk
Great! I had planned to port this application. Here are some patches to the original submitted PR. They upgrade to v. 0.5.2, force the build of self contained extensions, install examples (all tested and working), fix some typos in the code, USE_GNOMENG, and add a BUILD_DEP towards phpize. I have also added knobs to build gdkpixbuf and gtkhtml extensions (not scintilla). They build OK, but I have been unable to test them => they are not installed. PR: ports/46201 Submitted by: Th. Thomas.
Notes
Notes: svn path=/head/; revision=77929
Diffstat (limited to 'x11-toolkits/php-gtk/Makefile')
-rw-r--r--x11-toolkits/php-gtk/Makefile106
1 files changed, 106 insertions, 0 deletions
diff --git a/x11-toolkits/php-gtk/Makefile b/x11-toolkits/php-gtk/Makefile
new file mode 100644
index 000000000000..f92df3526dcd
--- /dev/null
+++ b/x11-toolkits/php-gtk/Makefile
@@ -0,0 +1,106 @@
+# ports collection makefile for: php-gtk
+# Date created: 03 October 2002
+# Whom: Alex Kiesel <kiesel@schlund.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= php-gtk
+PORTVERSION= 0.5.2
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://gtk.php.net/distributions/ \
+ http://document-root.de/mirror/php-gtk/
+
+MAINTAINER= kiesel@schlund.de
+COMMENT= An extension to use gtk in PHP-applications
+
+# Port does only build with automake-1.4 and
+# automake-1.5 installed - what a mess
+BUILD_DEPENDS= automake:${PORTSDIR}/devel/automake \
+ automake14:${PORTSDIR}/devel/automake14 \
+ autoconf:${PORTSDIR}/devel/autoconf213 \
+ ${LOCALBASE}/bin/phpize:${PORTSDIR}/www/mod_php4
+RUN_DEPENDS= php:${PORTSDIR}/www/mod_php4
+
+# Don't call autoconf directly, ./buildconf does this
+GNU_CONFIGURE= yes
+USE_AUTOCONF= no
+USE_LIBTOOL= no
+USE_GMAKE= yes
+USE_PERL5_BUILD=yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+# Fix environment for self contained extensions
+ENVSCE= -DHAVE_PHP_GTK=1 -DCOMPILE_DL_PHP_GTK=1 \
+ -DHAVE_PIEMENU=1 \
+ -DHAVE_SCROLLPANE=1 \
+ -DHAVE_SPANED=1 \
+ -DHAVE_SQPANE=1 \
+ -DHAVE_COMBOBUTTON=1
+.if !defined(WITHOUT_LIBGLADE)
+USE_GNOME+= libglade
+ENVSCE+= -DHAVE_LIBGLADE
+.else
+CONFIGURE_ARGS+= --disable-libglade
+.endif
+.if !defined(WITHOUT_GDK_PIXBUF)
+USE_GNOME+= gdkpixbuf
+CONFIGURE_ARGS+= --enable-gdkpixbuf=shared
+ENVSCE+= -DHAVE_GDKPIXBUF=1 -DPHP_GTK_COMPILE_DL_GDKPIXBUF=1
+.endif
+.if !defined(WITHOUT_GTKHTML)
+USE_GNOME+= gtkhtml
+CONFIGURE_ARGS+= --enable-gtkhtml=shared
+ENVSCE+= -DHAVE_HTML=1 -DPHP_GTK_COMPILE_DL_GTKHTML=1 -DGTKHTML_HAVE_GCONF=1 -I${X11BASE}/include/gal-1.0
+.endif
+CONFIGURE_ENV= CPPFLAGS="${ENVSCE}"
+
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
+
+PIC2FIX= acinclude.m4 aclocal.m4 autom4te.cache configure
+
+EXAMPLES= combobutton.php fileselection.php gtk.php hello.php list.php \
+ piemenu.php scribble.php scrollpane.php spaned.php sqpane.php \
+ testgtkrc testgtkrc2 window.xpm
+
+pre-everything::
+ @${ECHO_MSG} '*********************************************************'
+ @${ECHO_MSG} '* By default php-gtk is built with several Gnome deps. *'
+ @${ECHO_MSG} '* If you do not need them, you may define: *'
+ @${ECHO_MSG} '* *'
+ @${ECHO_MSG} '* - WITHOUT_LIBGLADE *'
+ @${ECHO_MSG} '* - WITHOUT_GDK_PIXBUF *'
+ @${ECHO_MSG} '* - WITHOUT_GTKHTML *'
+ @${ECHO_MSG} '* *'
+ @${ECHO_MSG} '*********************************************************'
+
+post-patch-script:
+ @${ECHO_MSG} "===> Building configuration files for ${PKGNAME}"
+ (cd ${WRKSRC} && ./buildconf)
+
+pre-configure:
+.for FILE in ${PIC2FIX}
+ @${REINPLACE_CMD} -e "s|-prefer-pic|${CFLAGS}|g" ${WRKSRC}/${FILE}
+.endfor
+
+do-install:
+ @$(MKDIR) -p ${PREFIX}/lib/php/extensions/
+ @${INSTALL_PROGRAM} ${WRKSRC}/modules/php_gtk.so ${PREFIX}/lib/php/extensions/php_gtk.so
+# TODO: php_gtk_gdkpixbuf.so and php_gtk_gtkhtml.so are not installed
+ @${MKDIR} ${PREFIX}/etc/php.gtk
+ @${INSTALL_DATA} ${FILESDIR}/php.ini-dist ${PREFIX}/etc/php.gtk
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+.for FILE in ${EXAMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/test/${FILE} ${EXAMPLESDIR}
+.endfor
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+.endif
+ @${ECHO} ""
+ @${CAT} ${MASTERDIR}/pkg-message
+ @${ECHO} ""
+
+.include <bsd.port.mk>