aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-gtk2
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2002-10-08 08:31:52 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2002-10-08 08:31:52 +0000
commit69945ee08692e4847fa59e4cf594649ad6be98d2 (patch)
treedda5385ac3386ae3aa5f3bc27e542548b1935003 /x11-toolkits/py-gtk2
parent1b135b7acdd30017c1d84065d4eb2e35468200d9 (diff)
downloadports-69945ee08692e4847fa59e4cf594649ad6be98d2.tar.gz
ports-69945ee08692e4847fa59e4cf594649ad6be98d2.zip
Update py-gtk2 to 1.99.12
PR: 42344 Submitted by: Marc Recht <marc@informatik.uni-bremen.de> Repocopied by: joe
Notes
Notes: svn path=/head/; revision=67608
Diffstat (limited to 'x11-toolkits/py-gtk2')
-rw-r--r--x11-toolkits/py-gtk2/Makefile48
-rw-r--r--x11-toolkits/py-gtk2/distinfo2
-rw-r--r--x11-toolkits/py-gtk2/files/patch-configure61
-rw-r--r--x11-toolkits/py-gtk2/pkg-install16
-rw-r--r--x11-toolkits/py-gtk2/pkg-plist279
5 files changed, 188 insertions, 218 deletions
diff --git a/x11-toolkits/py-gtk2/Makefile b/x11-toolkits/py-gtk2/Makefile
index 9800837ed9a2..f4a2337e918a 100644
--- a/x11-toolkits/py-gtk2/Makefile
+++ b/x11-toolkits/py-gtk2/Makefile
@@ -1,53 +1,49 @@
-# New ports collection makefile for: py-gtk
-# Date created: 09/14/1999
-# Whom: nectar@FreeBSD.org
+# New ports collection makefile for: py-gtk2
+# Date created: 08/13/2002
+# Whom: marc@informatik.uni-bremen.de
#
# $FreeBSD$
-#
-PORTNAME= py-gtk
-PORTVERSION= 0.6.10
+PORTNAME= gtk
+PORTVERSION= 1.99.12
CATEGORIES= x11-toolkits python
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-python/1.4
-DISTNAME= gnome-python-1.4.4
-DIST_SUBDIR= gnome
+MASTER_SITE_SUBDIR= sources/pygtk/1.99
+DISTNAME= pygtk-${PORTVERSION}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DIST_SUBDIR= gnome2
-MAINTAINER= gnome@FreeBSD.org
+MAINTAINER= marc@informatik.uni-bremen.de
-BUILD_DEPENDS= ${PYNUMERIC}
-LIB_DEPENDS= gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
+LIB_DEPENDS= gtk-x11-2.0:${PORTSDIR}/x11-toolkits/gtk20 \
+ glade-2.0.0:${PORTSDIR}/devel/libglade2 \
+ gtkgl-2.0:${PORTSDIR}/x11-toolkits/gtkglarea2
RUN_DEPENDS= ${PYNUMERIC}
-WRKSRC= ${WRKDIR}/${DISTNAME}/pygtk
-
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOMENG= yes
-USE_GNOME= gnomelibs gdkpixbuf libglade
USE_PYTHON= yes
USE_LIBTOOL= yes
-CONFIGURE_ENV= PYTHON=${PYTHON_CMD}
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
EG_SRC_DIR= ${WRKSRC}/examples
EG_DST_DIR= ${PREFIX}/share/examples/py-gtk
+.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
+pre-build:
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+.endif
+
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${EG_DST_DIR}
- ${TAR} -C ${EG_SRC_DIR} -cf - . | ${TAR} -C ${EG_DST_DIR} -xvf -
+ ${TAR} -C ${EG_SRC_DIR} -cf - . | ${TAR} -C ${EG_DST_DIR} -xf -
${CHOWN} -R ${BINOWN}:${BINGRP} ${EG_DST_DIR}
- find ${EG_DST_DIR} -type d -print | xargs ${CHMOD} 0555
- find ${EG_DST_DIR} -type f -print | xargs ${CHMOD} 0444
+ ${FIND} ${EG_DST_DIR} -type d -print | ${XARGS} ${CHMOD} 0555
+ ${FIND} ${EG_DST_DIR} -type f -print | ${XARGS} ${CHMOD} 0444
${MKDIR} ${PREFIX}/share/doc/py-gtk
${INSTALL_DATA} ${WRKSRC}/MAPPING ${PREFIX}/share/doc/py-gtk
-.else
-PLIST= ${WRKDIR}/PLIST.nodocs
-pre-install:
- ${RM} -f ${PLIST}
- ${GREP} -E -v '^(@dirrm )?(share/examples/)|(share/doc/)' \
- ${PKGDIR}/pkg-plist > ${PLIST}
+ ${INSTALL_DATA} ${WRKSRC}/THREADS ${PREFIX}/share/doc/py-gtk
.endif
.include <bsd.port.mk>
diff --git a/x11-toolkits/py-gtk2/distinfo b/x11-toolkits/py-gtk2/distinfo
index 5df73588577b..60c919687bbf 100644
--- a/x11-toolkits/py-gtk2/distinfo
+++ b/x11-toolkits/py-gtk2/distinfo
@@ -1 +1 @@
-MD5 (gnome/gnome-python-1.4.4.tar.bz2) = b5069c8ac77ba7ad991afceeab332319
+MD5 (gnome2/pygtk-1.99.12.tar.bz2) = f6897f613d83282d69e3cf911bc23c51
diff --git a/x11-toolkits/py-gtk2/files/patch-configure b/x11-toolkits/py-gtk2/files/patch-configure
deleted file mode 100644
index f2a3b46431df..000000000000
--- a/x11-toolkits/py-gtk2/files/patch-configure
+++ /dev/null
@@ -1,61 +0,0 @@
-
-$FreeBSD$
-
---- configure.orig Sat Aug 24 10:37:08 2002
-+++ configure Wed Aug 28 20:20:53 2002
-@@ -7372,6 +7372,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -8888,6 +8889,7 @@
- #line $LINENO "configure"
- #include "confdefs.h"
- $ac_includes_default
-+#include <Python.h>
- #include <arrayobject.h>
- _ACEOF
- rm -f conftest.$ac_objext
-@@ -8918,6 +8920,7 @@
- cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
- #include "confdefs.h"
-+#include <Python.h>
- #include <arrayobject.h>
- _ACEOF
- if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
-@@ -8999,6 +9002,7 @@
- #line $LINENO "configure"
- #include "confdefs.h"
- $ac_includes_default
-+#include <Python.h>
- #include <Extensions/arrayobject.h>
- _ACEOF
- rm -f conftest.$ac_objext
-@@ -9029,6 +9033,7 @@
- cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
- #include "confdefs.h"
-+#include <Python.h>
- #include <Extensions/arrayobject.h>
- _ACEOF
- if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
-@@ -9110,6 +9115,7 @@
- #line $LINENO "configure"
- #include "confdefs.h"
- $ac_includes_default
-+#include <Python.h>
- #include <Numeric/arrayobject.h>
- _ACEOF
- rm -f conftest.$ac_objext
-@@ -9140,6 +9146,7 @@
- cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
- #include "confdefs.h"
-+#include <Python.h>
- #include <Numeric/arrayobject.h>
- _ACEOF
- if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
diff --git a/x11-toolkits/py-gtk2/pkg-install b/x11-toolkits/py-gtk2/pkg-install
new file mode 100644
index 000000000000..5bedff250f38
--- /dev/null
+++ b/x11-toolkits/py-gtk2/pkg-install
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+if [ -n "${PACKAGE_BUILDING}" ]; then
+ exit 0
+fi
+
+PATH=/bin:/usr/bin:/sbin:/usr/sbin:${PATH}
+export PATH
+
+if [ "$2" = "PRE-INSTALL" ]; then
+ if pkg_info | grep "^py-gtk-[0-9]"; then
+ echo "py-gtk for GTK+ 1.x was detected."
+ echo "This packages cannot coexist with py-gtk2."
+ false
+ fi
+fi
diff --git a/x11-toolkits/py-gtk2/pkg-plist b/x11-toolkits/py-gtk2/pkg-plist
index ca64c22a1d9d..3aa97c9f3b85 100644
--- a/x11-toolkits/py-gtk2/pkg-plist
+++ b/x11-toolkits/py-gtk2/pkg-plist
@@ -1,131 +1,150 @@
-bin/pygtk-codegen-1.2
-include/pygtk/pygdkimlib.h
-include/pygtk/pygdkpixbuf.h
-include/pygtk/pygtk.h
-%%PYTHON_SITELIBDIR%%/gtk-1.2/GDK.py
-%%PYTHON_SITELIBDIR%%/gtk-1.2/GDK.pyc
-%%PYTHON_SITELIBDIR%%/gtk-1.2/GDK.pyo
-%%PYTHON_SITELIBDIR%%/gtk-1.2/GTK.py
-%%PYTHON_SITELIBDIR%%/gtk-1.2/GTK.pyc
-%%PYTHON_SITELIBDIR%%/gtk-1.2/GTK.pyo
-%%PYTHON_SITELIBDIR%%/gtk-1.2/GdkImlib.py
-%%PYTHON_SITELIBDIR%%/gtk-1.2/GdkImlib.pyc
-%%PYTHON_SITELIBDIR%%/gtk-1.2/GdkImlib.pyo
-%%PYTHON_SITELIBDIR%%/gtk-1.2/GtkExtra.py
-%%PYTHON_SITELIBDIR%%/gtk-1.2/GtkExtra.pyc
-%%PYTHON_SITELIBDIR%%/gtk-1.2/GtkExtra.pyo
-%%PYTHON_SITELIBDIR%%/gtk-1.2/_gdkimlibmodule.so
-%%PYTHON_SITELIBDIR%%/gtk-1.2/_gtkglmodule.so
-%%PYTHON_SITELIBDIR%%/gtk-1.2/_gtkmodule.so
-%%PYTHON_SITELIBDIR%%/gtk-1.2/_libglademodule.so
-%%PYTHON_SITELIBDIR%%/gtk-1.2/gdkpixbufmodule.so
-%%PYTHON_SITELIBDIR%%/gtk-1.2/gtk.py
-%%PYTHON_SITELIBDIR%%/gtk-1.2/gtk.pyc
-%%PYTHON_SITELIBDIR%%/gtk-1.2/gtk.pyo
-%%PYTHON_SITELIBDIR%%/gtk-1.2/gtkgl.py
-%%PYTHON_SITELIBDIR%%/gtk-1.2/gtkgl.pyc
-%%PYTHON_SITELIBDIR%%/gtk-1.2/gtkgl.pyo
-%%PYTHON_SITELIBDIR%%/gtk-1.2/libglade.py
-%%PYTHON_SITELIBDIR%%/gtk-1.2/libglade.pyc
-%%PYTHON_SITELIBDIR%%/gtk-1.2/libglade.pyo
-%%PYTHON_SITELIBDIR%%/gtk-1.2/pyglade/__init__.py
-%%PYTHON_SITELIBDIR%%/gtk-1.2/pyglade/__init__.pyc
-%%PYTHON_SITELIBDIR%%/gtk-1.2/pyglade/__init__.pyo
-%%PYTHON_SITELIBDIR%%/gtk-1.2/pyglade/build.py
-%%PYTHON_SITELIBDIR%%/gtk-1.2/pyglade/build.pyc
-%%PYTHON_SITELIBDIR%%/gtk-1.2/pyglade/build.pyo
-%%PYTHON_SITELIBDIR%%/gtk-1.2/pyglade/style.py
-%%PYTHON_SITELIBDIR%%/gtk-1.2/pyglade/style.pyc
-%%PYTHON_SITELIBDIR%%/gtk-1.2/pyglade/style.pyo
-%%PYTHON_SITELIBDIR%%/gtk-1.2/pyglade/xmlparse.py
-%%PYTHON_SITELIBDIR%%/gtk-1.2/pyglade/xmlparse.pyc
-%%PYTHON_SITELIBDIR%%/gtk-1.2/pyglade/xmlparse.pyo
-%%PYTHON_SITELIBDIR%%/pygtk.pth
-%%PYTHON_SITELIBDIR%%/pygtk.py
-%%PYTHON_SITELIBDIR%%/pygtk.pyc
-%%PYTHON_SITELIBDIR%%/pygtk.pyo
-share/doc/py-gtk/MAPPING
-share/examples/py-gtk/gl/README
-share/examples/py-gtk/gl/cone.py
-share/examples/py-gtk/gl/dots.py
-share/examples/py-gtk/gl/gears.py
-share/examples/py-gtk/glade/README
-share/examples/py-gtk/glade/glade.py
-share/examples/py-gtk/glade/test.glade
-share/examples/py-gtk/glade/test2.glade
-share/examples/py-gtk/ide/README
-share/examples/py-gtk/ide/break.xpm
-share/examples/py-gtk/ide/browse.py
-share/examples/py-gtk/ide/continue.xpm
-share/examples/py-gtk/ide/edit.py
-share/examples/py-gtk/ide/edit.xpm
-share/examples/py-gtk/ide/gtkcons.py
-share/examples/py-gtk/ide/gtkdb.py
-share/examples/py-gtk/ide/gtkprof.py
-share/examples/py-gtk/ide/minibreak.xpm
-share/examples/py-gtk/ide/next.xpm
-share/examples/py-gtk/ide/pyide.py
-share/examples/py-gtk/ide/quit.xpm
-share/examples/py-gtk/ide/return.xpm
-share/examples/py-gtk/ide/run.xpm
-share/examples/py-gtk/ide/step.xpm
-share/examples/py-gtk/imlib/view.py
-share/examples/py-gtk/neil/README
-share/examples/py-gtk/neil/TAppli.py
-share/examples/py-gtk/neil/TAppli2.py
-share/examples/py-gtk/neil/TAppli3.py
-share/examples/py-gtk/neil/TAppli4.py
-share/examples/py-gtk/neil/TAppli5.py
-share/examples/py-gtk/neil/bomb.xpm
-share/examples/py-gtk/neil/gtk-logo.xpm
-share/examples/py-gtk/neil/notebook.py
-share/examples/py-gtk/neil/question.xpm
-share/examples/py-gtk/simple/README
-share/examples/py-gtk/simple/dnd.py
-share/examples/py-gtk/simple/dndpixmap.py
-share/examples/py-gtk/simple/hello1.py
-share/examples/py-gtk/simple/hello2.py
-share/examples/py-gtk/simple/scribble.py
-share/examples/py-gtk/simple/simple1.py
-share/examples/py-gtk/simple/simple2.py
-share/examples/py-gtk/simple/tooltip1.py
-share/examples/py-gtk/simple/tooltip2.py
-share/examples/py-gtk/testgtk/README
-share/examples/py-gtk/testgtk/test.xpm
-share/examples/py-gtk/testgtk/testgtk.py
-share/examples/py-gtk/testgtk/testgtkrc
-share/pygtk/1.2/codegen/generate.py
-share/pygtk/1.2/codegen/generate.pyc
-share/pygtk/1.2/codegen/generate.pyo
-share/pygtk/1.2/codegen/scmexpr.py
-share/pygtk/1.2/codegen/scmexpr.pyc
-share/pygtk/1.2/codegen/scmexpr.pyo
-share/pygtk/1.2/defs/gtk.defs
-share/pygtk/1.2/defs/gtkbase.defs
-share/pygtk/1.2/defs/gtkcontainers.defs
-share/pygtk/1.2/defs/gtkdata.defs
-share/pygtk/1.2/defs/gtkdnd.defs
-share/pygtk/1.2/defs/gtkedit.defs
-share/pygtk/1.2/defs/gtkenums.defs
-share/pygtk/1.2/defs/gtkgl.defs
-share/pygtk/1.2/defs/gtklists.defs
-share/pygtk/1.2/defs/gtkmenus.defs
-share/pygtk/1.2/defs/gtkmisc.defs
-share/pygtk/1.2/defs/gtkranges.defs
-share/pygtk/1.2/defs/libglade.defs
-@dirrm share/pygtk/1.2/defs
-@dirrm share/pygtk/1.2/codegen
-@dirrm share/pygtk/1.2
+bin/pygtk-codegen-2.0
+include/pygtk-2.0/pygtk/pygtk.h
+include/pygtk-2.0/pygobject.h
+%%PYTHON_SITELIBDIR%%/atkmodule.la
+%%PYTHON_SITELIBDIR%%/atkmodule.so
+%%PYTHON_SITELIBDIR%%/gobjectmodule.la
+%%PYTHON_SITELIBDIR%%/gobjectmodule.so
+%%PYTHON_SITELIBDIR%%/gtk/__init__.py
+%%PYTHON_SITELIBDIR%%/gtk/__init__.pyc
+%%PYTHON_SITELIBDIR%%/gtk/__init__.pyo
+%%PYTHON_SITELIBDIR%%/gtk/_gtkmodule.la
+%%PYTHON_SITELIBDIR%%/gtk/_gtkmodule.so
+%%PYTHON_SITELIBDIR%%/gtk/compat.py
+%%PYTHON_SITELIBDIR%%/gtk/compat.pyc
+%%PYTHON_SITELIBDIR%%/gtk/compat.pyo
+%%PYTHON_SITELIBDIR%%/gtk/glademodule.la
+%%PYTHON_SITELIBDIR%%/gtk/glademodule.so
+%%PYTHON_SITELIBDIR%%/gtk/keysyms.py
+%%PYTHON_SITELIBDIR%%/gtk/keysyms.pyc
+%%PYTHON_SITELIBDIR%%/gtk/keysyms.pyo
+%%PYTHON_SITELIBDIR%%/pangomodule.la
+%%PYTHON_SITELIBDIR%%/pangomodule.so
+lib/pkgconfig/pygtk-2.0.pc
+%%PORTDOCS%%share/doc/py-gtk/MAPPING
+%%PORTDOCS%%share/doc/py-gtk/THREADS
+%%PORTDOCS%%share/examples/py-gtk/atk/atk-demo.py
+%%PORTDOCS%%share/examples/py-gtk/gl/README
+%%PORTDOCS%%share/examples/py-gtk/gl/cone.py
+%%PORTDOCS%%share/examples/py-gtk/gl/dots.py
+%%PORTDOCS%%share/examples/py-gtk/gl/gears.py
+%%PORTDOCS%%share/examples/py-gtk/glade/README
+%%PORTDOCS%%share/examples/py-gtk/glade/glade-demo.py
+%%PORTDOCS%%share/examples/py-gtk/glade/test.glade
+%%PORTDOCS%%share/examples/py-gtk/gobject/properties.py
+%%PORTDOCS%%share/examples/py-gtk/gobject/signal.py
+%%PORTDOCS%%share/examples/py-gtk/ide/README
+%%PORTDOCS%%share/examples/py-gtk/ide/break.xpm
+%%PORTDOCS%%share/examples/py-gtk/ide/browse.py
+%%PORTDOCS%%share/examples/py-gtk/ide/continue.xpm
+%%PORTDOCS%%share/examples/py-gtk/ide/edit.py
+%%PORTDOCS%%share/examples/py-gtk/ide/edit.xpm
+%%PORTDOCS%%share/examples/py-gtk/ide/gtkcons.py
+%%PORTDOCS%%share/examples/py-gtk/ide/gtkdb.py
+%%PORTDOCS%%share/examples/py-gtk/ide/gtkprof.py
+%%PORTDOCS%%share/examples/py-gtk/ide/minibreak.xpm
+%%PORTDOCS%%share/examples/py-gtk/ide/next.xpm
+%%PORTDOCS%%share/examples/py-gtk/ide/pyide.py
+%%PORTDOCS%%share/examples/py-gtk/ide/quit.xpm
+%%PORTDOCS%%share/examples/py-gtk/ide/return.xpm
+%%PORTDOCS%%share/examples/py-gtk/ide/run.xpm
+%%PORTDOCS%%share/examples/py-gtk/ide/step.xpm
+%%PORTDOCS%%share/examples/py-gtk/neil/README
+%%PORTDOCS%%share/examples/py-gtk/neil/TAppli.py
+%%PORTDOCS%%share/examples/py-gtk/neil/TAppli2.py
+%%PORTDOCS%%share/examples/py-gtk/neil/TAppli3.py
+%%PORTDOCS%%share/examples/py-gtk/neil/TAppli4.py
+%%PORTDOCS%%share/examples/py-gtk/neil/TAppli5.py
+%%PORTDOCS%%share/examples/py-gtk/neil/bomb.xpm
+%%PORTDOCS%%share/examples/py-gtk/neil/gtk-logo.xpm
+%%PORTDOCS%%share/examples/py-gtk/neil/notebook.py
+%%PORTDOCS%%share/examples/py-gtk/neil/question.xpm
+%%PORTDOCS%%share/examples/py-gtk/pango/utf8-demo.py
+%%PORTDOCS%%share/examples/py-gtk/pygtk-demo/demos/__init__.py
+%%PORTDOCS%%share/examples/py-gtk/pygtk-demo/demos/appwindow.py
+%%PORTDOCS%%share/examples/py-gtk/pygtk-demo/demos/buttonbox.py
+%%PORTDOCS%%share/examples/py-gtk/pygtk-demo/demos/colorsel.py
+%%PORTDOCS%%share/examples/py-gtk/pygtk-demo/demos/dialogs.py
+%%PORTDOCS%%share/examples/py-gtk/pygtk-demo/demos/dnd.py
+%%PORTDOCS%%share/examples/py-gtk/pygtk-demo/demos/dndpixmap.py
+%%PORTDOCS%%share/examples/py-gtk/pygtk-demo/demos/itemfactory.py
+%%PORTDOCS%%share/examples/py-gtk/pygtk-demo/demos/list_store.py
+%%PORTDOCS%%share/examples/py-gtk/pygtk-demo/demos/menu.py
+%%PORTDOCS%%share/examples/py-gtk/pygtk-demo/demos/panes.py
+%%PORTDOCS%%share/examples/py-gtk/pygtk-demo/demos/sizegroup.py
+%%PORTDOCS%%share/examples/py-gtk/pygtk-demo/demos/toolbar.py
+%%PORTDOCS%%share/examples/py-gtk/pygtk-demo/demos/treemodel.py
+%%PORTDOCS%%share/examples/py-gtk/pygtk-demo/pygtk-demo.py
+%%PORTDOCS%%share/examples/py-gtk/simple/README
+%%PORTDOCS%%share/examples/py-gtk/simple/dnd.py
+%%PORTDOCS%%share/examples/py-gtk/simple/dndpixmap.py
+%%PORTDOCS%%share/examples/py-gtk/simple/hello.py
+%%PORTDOCS%%share/examples/py-gtk/simple/scribble.py
+%%PORTDOCS%%share/examples/py-gtk/simple/simple.py
+%%PORTDOCS%%share/examples/py-gtk/simple/tooltip.py
+share/pygtk/2.0/codegen/__init__.py
+share/pygtk/2.0/codegen/__init__.pyc
+share/pygtk/2.0/codegen/__init__.pyo
+share/pygtk/2.0/codegen/argtypes.py
+share/pygtk/2.0/codegen/argtypes.pyc
+share/pygtk/2.0/codegen/argtypes.pyo
+share/pygtk/2.0/codegen/codegen.py
+share/pygtk/2.0/codegen/codegen.pyc
+share/pygtk/2.0/codegen/codegen.pyo
+share/pygtk/2.0/codegen/definitions.py
+share/pygtk/2.0/codegen/definitions.pyc
+share/pygtk/2.0/codegen/definitions.pyo
+share/pygtk/2.0/codegen/defsparser.py
+share/pygtk/2.0/codegen/defsparser.pyc
+share/pygtk/2.0/codegen/defsparser.pyo
+share/pygtk/2.0/codegen/docextract.py
+share/pygtk/2.0/codegen/docextract.pyc
+share/pygtk/2.0/codegen/docextract.pyo
+share/pygtk/2.0/codegen/docgen.py
+share/pygtk/2.0/codegen/docgen.pyc
+share/pygtk/2.0/codegen/docgen.pyo
+share/pygtk/2.0/codegen/h2def.py
+share/pygtk/2.0/codegen/h2def.pyc
+share/pygtk/2.0/codegen/h2def.pyo
+share/pygtk/2.0/codegen/mergedefs.py
+share/pygtk/2.0/codegen/mergedefs.pyc
+share/pygtk/2.0/codegen/mergedefs.pyo
+share/pygtk/2.0/codegen/mkskel.py
+share/pygtk/2.0/codegen/mkskel.pyc
+share/pygtk/2.0/codegen/mkskel.pyo
+share/pygtk/2.0/codegen/override.py
+share/pygtk/2.0/codegen/override.pyc
+share/pygtk/2.0/codegen/override.pyo
+share/pygtk/2.0/codegen/scmexpr.py
+share/pygtk/2.0/codegen/scmexpr.pyc
+share/pygtk/2.0/codegen/scmexpr.pyo
+share/pygtk/2.0/defs/gtk.defs
+share/pygtk/2.0/defs/gtk-types.defs
+share/pygtk/2.0/defs/gtk-extrafuncs.defs
+share/pygtk/2.0/defs/gdk.defs
+share/pygtk/2.0/defs/gdk-types.defs
+share/pygtk/2.0/defs/libglade.defs
+share/pygtk/2.0/defs/gtkgl.defs
+share/pygtk/2.0/defs/pango.defs
+share/pygtk/2.0/defs/pango-types.defs
+share/pygtk/2.0/defs/atk.defs
+share/pygtk/2.0/defs/atk-types.defs
+@dirrm share/pygtk/2.0/defs
+@dirrm share/pygtk/2.0/codegen
+@dirrm share/pygtk/2.0
@dirrm share/pygtk
-@dirrm share/examples/py-gtk/testgtk
-@dirrm share/examples/py-gtk/simple
-@dirrm share/examples/py-gtk/neil
-@dirrm share/examples/py-gtk/imlib
-@dirrm share/examples/py-gtk/ide
-@dirrm share/examples/py-gtk/glade
-@dirrm share/examples/py-gtk/gl
-@dirrm share/examples/py-gtk
-@dirrm share/doc/py-gtk
-@dirrm %%PYTHON_SITELIBDIR%%/gtk-1.2/pyglade
-@dirrm %%PYTHON_SITELIBDIR%%/gtk-1.2
-@dirrm include/pygtk
+%%PORTDOCS%%@dirrm share/examples/py-gtk/simple
+%%PORTDOCS%%@dirrm share/examples/py-gtk/pygtk-demo/demos
+%%PORTDOCS%%@dirrm share/examples/py-gtk/pygtk-demo
+%%PORTDOCS%%@dirrm share/examples/py-gtk/pango
+%%PORTDOCS%%@dirrm share/examples/py-gtk/neil
+%%PORTDOCS%%@dirrm share/examples/py-gtk/ide
+%%PORTDOCS%%@dirrm share/examples/py-gtk/gobject
+%%PORTDOCS%%@dirrm share/examples/py-gtk/glade
+%%PORTDOCS%%@dirrm share/examples/py-gtk/gl
+%%PORTDOCS%%@dirrm share/examples/py-gtk/atk
+%%PORTDOCS%%@dirrm share/examples/py-gtk
+%%PORTDOCS%%@dirrm share/doc/py-gtk
+@dirrm %%PYTHON_SITELIBDIR%%/gtk
+@dirrm include/pygtk-2.0/pygtk
+@dirrm include/pygtk-2.0