aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-gtk2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-01-15 04:43:10 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-01-15 04:43:10 +0000
commit9db400d986af9d91220bd7557386994701e098b7 (patch)
tree3483b023fdb0e062bb784d344ba741ffdade05bd /x11-toolkits/py-gtk2
parent98d23a76be3ee624c3020ab6b94a43f4f0a7aedd (diff)
downloadports-9db400d986af9d91220bd7557386994701e098b7.tar.gz
ports-9db400d986af9d91220bd7557386994701e098b7.zip
Update to 1.99.14.
Notes
Notes: svn path=/head/; revision=73152
Diffstat (limited to 'x11-toolkits/py-gtk2')
-rw-r--r--x11-toolkits/py-gtk2/Makefile3
-rw-r--r--x11-toolkits/py-gtk2/distinfo2
-rw-r--r--x11-toolkits/py-gtk2/files/patch-pygtkcellrenderer.c38
3 files changed, 2 insertions, 41 deletions
diff --git a/x11-toolkits/py-gtk2/Makefile b/x11-toolkits/py-gtk2/Makefile
index 1b1fb14ee3ac..6c2c605270e1 100644
--- a/x11-toolkits/py-gtk2/Makefile
+++ b/x11-toolkits/py-gtk2/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= gtk
-PORTVERSION= 1.99.13
-PORTREVISION= 1
+PORTVERSION= 1.99.14
CATEGORIES= x11-toolkits python
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/pygtk/1.99
diff --git a/x11-toolkits/py-gtk2/distinfo b/x11-toolkits/py-gtk2/distinfo
index e58fa8f0b2c3..f66662181574 100644
--- a/x11-toolkits/py-gtk2/distinfo
+++ b/x11-toolkits/py-gtk2/distinfo
@@ -1 +1 @@
-MD5 (gnome2/pygtk-1.99.13.tar.bz2) = 1c774e143704a2755fc25b19399775a8
+MD5 (gnome2/pygtk-1.99.14.tar.bz2) = c5614d17d0642403ef298a50d1e0d220
diff --git a/x11-toolkits/py-gtk2/files/patch-pygtkcellrenderer.c b/x11-toolkits/py-gtk2/files/patch-pygtkcellrenderer.c
deleted file mode 100644
index d2d2460207e6..000000000000
--- a/x11-toolkits/py-gtk2/files/patch-pygtkcellrenderer.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- ./gtk/pygtkcellrenderer.c.orig Sat Jul 20 07:37:29 2002
-+++ ./gtk/pygtkcellrenderer.c Fri Nov 8 21:01:20 2002
-@@ -94,6 +94,7 @@
- gint *height)
- {
- PyObject *self, *py_ret, *py_widget, *py_cell_area;
-+ gint my_x, my_y, my_width, my_height;
-
- g_return_if_fail(PYGTK_IS_GENERIC_CELL_RENDERER (cell));
-
-@@ -117,13 +118,26 @@
- Py_DECREF(py_widget);
- Py_DECREF(py_cell_area);
-
-- if (!PyArg_ParseTuple(py_ret, "iiii", x_offset, y_offset, width, height)) {
-+ if (!PyArg_ParseTuple(py_ret, "iiii",
-+ &my_x, &my_y, &my_width, &my_height)) {
- PyErr_Clear();
- Py_DECREF(py_ret);
- g_warning("could not parse return value of get_size() method. "
- "Should be of form (x_offset, y_offset, width, height)");
- return;
- }
-+
-+ if (x_offset)
-+ *x_offset = my_x;
-+
-+ if (y_offset)
-+ *y_offset = my_y;
-+
-+ if (width)
-+ *width = my_width;
-+
-+ if (height)
-+ *height = my_height;
- /* success */
- }
-