aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-gtk2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-14 00:16:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-14 00:16:54 +0000
commitce93dde7c5732df634f8af40ed80082098dee270 (patch)
tree7ba27b073894062e3ae0a5cf9031557caec6f13f /x11-toolkits/py-gtk2
parent5ac398ba007e658a3e950a2331be036888b203bd (diff)
downloadports-ce93dde7c5732df634f8af40ed80082098dee270.tar.gz
ports-ce93dde7c5732df634f8af40ed80082098dee270.zip
Fix the threaad support to stay inline with the way it's done for Python.
Prompted by: kris
Notes
Notes: svn path=/head/; revision=103916
Diffstat (limited to 'x11-toolkits/py-gtk2')
-rw-r--r--x11-toolkits/py-gtk2/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/x11-toolkits/py-gtk2/Makefile b/x11-toolkits/py-gtk2/Makefile
index 289f7decedeb..b266bb53c6e1 100644
--- a/x11-toolkits/py-gtk2/Makefile
+++ b/x11-toolkits/py-gtk2/Makefile
@@ -34,13 +34,15 @@ CONFLICTS= py*-gtk-0*
# Use the same way as the Python port to determine if we want
# threading support.
#
-LIBC_R!= /sbin/ldconfig -r | grep "c_r\|pthread" || true
-.if (${LIBC_R} != "") && !defined(WITHOUT_THREADS)
+.if !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --enable-thread
CFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.else
CONFIGURE_ARGS+= --disable-thread
+.if defined(LDFLAGS)
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+.endif
.endif
.if !defined(NOPORTDOCS)