aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-wxPython26/Makefile
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-10-05 06:42:57 +0000
committerJeremy Lea <reg@FreeBSD.org>2000-10-05 06:42:57 +0000
commit99290b0d61db9bcb3c960f5507a8ccb0126a0cf9 (patch)
treebac8f356dc259524716a41398446e5c7d8f95a21 /x11-toolkits/py-wxPython26/Makefile
parentfda2e985daa21bcac7cf4e4882e560933d7ad5e8 (diff)
downloadports-99290b0d61db9bcb3c960f5507a8ccb0126a0cf9.tar.gz
ports-99290b0d61db9bcb3c960f5507a8ccb0126a0cf9.zip
Implement USE_GTK, part 2.
Notes
Notes: svn path=/head/; revision=33425
Diffstat (limited to 'x11-toolkits/py-wxPython26/Makefile')
-rw-r--r--x11-toolkits/py-wxPython26/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/x11-toolkits/py-wxPython26/Makefile b/x11-toolkits/py-wxPython26/Makefile
index 87fadb373c49..9e8a136742b9 100644
--- a/x11-toolkits/py-wxPython26/Makefile
+++ b/x11-toolkits/py-wxPython26/Makefile
@@ -18,9 +18,10 @@ LIB_DEPENDS= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk
WRKSRC= ${WRKDIR}/${DISTNAME}/src
-USE_PYTHON= YES
-USE_GMAKE= YES
-USE_NEWGCC= YES
+USE_GMAKE= yes
+USE_NEWGCC= yes
+USE_PYTHON= yes
+USE_GTK= yes
MAKE_ENV= "LN_S=${LN} -s" "INSTALL_DATA=${INSTALL_DATA}"
ALL_TARGET= default
INSTALL_TARGET= install-freebsd
@@ -30,8 +31,8 @@ TARGETDIR= ${PYTHON_SITELIBDIR}/wxPython
HELPERLIBDIR= ${PREFIX}/lib
do-configure:
- ${SED} -e "s:%CFLAGS%:${CFLAGS} `gtk12-config --cflags`:" \
- -e "s:%LFLAGS%:`gtk12-config --libs` -L${WRKSRC}:" \
+ ${SED} -e "s:%CFLAGS%:${CFLAGS} `${GTK_CONFIG} --cflags`:" \
+ -e "s:%LFLAGS%:`${GTK_CONFIG} --libs` -L${WRKSRC}:" \
-e "s:%TARGETDIR%:${TARGETDIR}:" \
-e "s:%HELPERLIBDIR%:${HELPERLIBDIR}:" \
-e "s:%CXX%:${CXX}:" -e "s:%WRKSRC%:${WRKSRC}:" \