aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-wxPython26/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-06-05 03:54:09 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-06-05 03:54:09 +0000
commitc6d1721692bf458b67466ec050614cc7e3e6989c (patch)
tree867dde346e2bffc2835877067886d1ff701094ef /x11-toolkits/py-wxPython26/Makefile
parentd6222152bde7d3bee120ba49a1e2528c2207a881 (diff)
downloadports-c6d1721692bf458b67466ec050614cc7e3e6989c.tar.gz
ports-c6d1721692bf458b67466ec050614cc7e3e6989c.zip
Fix wxgtk gtk12 or gtk20 detection code
Noticed by: Adam <blueeskimo@gmx.net>
Notes
Notes: svn path=/head/; revision=82307
Diffstat (limited to 'x11-toolkits/py-wxPython26/Makefile')
-rw-r--r--x11-toolkits/py-wxPython26/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11-toolkits/py-wxPython26/Makefile b/x11-toolkits/py-wxPython26/Makefile
index c719a2f90346..cb832c25ad56 100644
--- a/x11-toolkits/py-wxPython26/Makefile
+++ b/x11-toolkits/py-wxPython26/Makefile
@@ -51,12 +51,12 @@ post-install:
.if exists(${WX_CONFIG})
# detect if wxgtk was linked against gtk1 or gtk2
-DECISION_GTK_1_OR_2!= ${WX_CONFIG} --static --libs | ${GREP} glib-2.0
+DECISION_GTK_1_OR_2!= ${WX_CONFIG} --static --libs
.else
DECISION_GTK_1_OR_2= ""
.endif
-.if (${DECISION_GTK_1_OR_2} != "")
+.if ${DECISION_GTK_1_OR_2:M*glib-2.0} != ""
USE_GNOME+= gtk20
CONFIGURE_ARGS+= --enable-gtk2
PYDISTUTILS_BUILDARGS+= WXPORT=gtk2