aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt31/files/patch-ag
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-04-21 23:47:50 +0000
committerWill Andrews <will@FreeBSD.org>2002-04-21 23:47:50 +0000
commitd1c2f0dddd4a74a79847b017915f3482671e055c (patch)
tree31ccd02a7c0d295ec66bf2eefa0f980fbb92cb91 /x11-toolkits/qt31/files/patch-ag
parent98cff2373c59f930df3569d05871d0343d443fd8 (diff)
downloadports-d1c2f0dddd4a74a79847b017915f3482671e055c.tar.gz
ports-d1c2f0dddd4a74a79847b017915f3482671e055c.zip
Please welcome Qt3/KDE3 to our ports tree. This includes work since the
original versions of these ports, so some PORTREVISIONs were bumped. See http://freebsd.kde.org/ and mailing lists linked to from there for info on the packages generated to test these ports. bsd.kde.mk has already been updated a few days ago to work with these. Some patches applied to fix a few bugs were: deskutils/kdepim3: [1] Remove kpilot from build because it wasn't ready at release. editors/koffice-kde3: [2] Fix compile time bugs for FreeBSD. misc/kdeedu3: [3] Fix compile problem with kvoctrain. x11/kdebase3: [4] Fix KDM CPU usage and login bug. Some caveats: * All PLISTs are broken for deinstall due to script bug that I didn't notice until very recently. This will be fixed when I commit an update tomorrow. These ports should still install perfectly fine though. They should also deinstall without giving errors, but will leave directories behind. * You can't install this with any other version of QT or KDE already installed. I am not sure the checks are 100% working, but fixes for these will be forthcoming. This is mainly due to a policy decision made by kde@ to make QT/KDE ports install the way the rest of the world expects it to while also still conforming to FreeBSD's hier(7). For reference on this decision, please consult the KDE/FreeBSD mailing list archives. This decision fixes 2-year-old bug reports relating to how we handled this for KDE2 vs KDE1. Submitted by: [1] Adrian de Groot <adridg@cs.kun.nl>, [2] David Faure <faure@kde.org>, Andy Fawcett <andy@athame.co.uk> Lauri Watts <lauri@kde.org> [3] Lauri Watts <lauri@kde.org> [4] Alan Eldridge <alane@geeksrus.net> Oswald Buddenhagen <ossi@kde.org> Reviewed by: kde
Notes
Notes: svn path=/head/; revision=57964
Diffstat (limited to 'x11-toolkits/qt31/files/patch-ag')
-rw-r--r--x11-toolkits/qt31/files/patch-ag52
1 files changed, 0 insertions, 52 deletions
diff --git a/x11-toolkits/qt31/files/patch-ag b/x11-toolkits/qt31/files/patch-ag
deleted file mode 100644
index ba5e83f30d70..000000000000
--- a/x11-toolkits/qt31/files/patch-ag
+++ /dev/null
@@ -1,52 +0,0 @@
---- configs/freebsd-g++-shared-debug.orig Thu Jun 21 09:27:41 2001
-+++ configs/freebsd-g++-shared-debug Thu Jun 21 09:31:12 2001
-@@ -6,7 +6,7 @@
-
- # Compiling with support libraries
- SYSCONF_CXXFLAGS_X11 = -I/usr/X11R6/include
--SYSCONF_CXXFLAGS_QT = -I$(QTDIR)/include
-+SYSCONF_CXXFLAGS_QT = -I$(QTDIR)/include $(SYSCONF_CXXFLAGS_THREAD)
- SYSCONF_CXXFLAGS_OPENGL = -I/usr/X11R6/include
-
- # Compiling YACC output
-@@ -23,7 +23,7 @@
- SYSCONF_LIBS_X11 = -lXext -lX11 -lm
- # Qt, Qt+OpenGL
- SYSCONF_LFLAGS_QT = -L$(QTDIR)/lib
--SYSCONF_LIBS_QT = -lqt$(QT_THREAD_SUFFIX)
-+SYSCONF_LIBS_QT = -lqt2$(QT_THREAD_SUFFIX) $(SYSCONF_LFLAGS_THREAD)
- SYSCONF_LIBS_QT_OPENGL =
- # OpenGL
- SYSCONF_LFLAGS_OPENGL = -L/usr/X11R6/lib
-@@ -46,7 +46,7 @@
- SYSCONF_LIBS_THREAD =
-
- # Meta-object compiler
--SYSCONF_MOC = $(QTDIR)/bin/moc
-+SYSCONF_MOC = $(QTDIR)/bin/moc2
-
- # UI compiler
- SYSCONF_UIC = $(QTDIR)/bin/uic
-@@ -60,1 +60,1 @@
--SYSCONF_LINK_TARGET_SHARED = lib$(TARGET).so.$(VER_MAJ).$(VER_MIN).$(VER_PATCH)
-+SYSCONF_LINK_TARGET_SHARED = lib$(TARGET).so.$(VER_MAJ)
-@@ -65,6 +65,4 @@
- cd $(DESTDIR) && \
-- rm -f lib$(TARGET).so lib$(TARGET).so.$(VER_MAJ) lib$(TARGET).so.$(VER_MAJ).$(VER_MIN); \
-- ln -s $(SYSCONF_LINK_TARGET_SHARED) lib$(TARGET).so; \
-- ln -s $(SYSCONF_LINK_TARGET_SHARED) lib$(TARGET).so.$(VER_MAJ); \
-- ln -s $(SYSCONF_LINK_TARGET_SHARED) lib$(TARGET).so.$(VER_MAJ).$(VER_MIN)
-+ rm -f lib$(TARGET).so;\
-+ ln -s $(SYSCONF_LINK_TARGET_SHARED) lib$(TARGET).so
-
-@@ -77,8 +75,8 @@
- SYSCONF_LINK_LIB_STATIC = rm -f $(DESTDIR)$(SYSCONF_LINK_TARGET_STATIC) ; \
- $(SYSCONF_AR) $(DESTDIR)$(SYSCONF_LINK_TARGET_STATIC) $(OBJECTS) $(OBJMOC)
- # Compiling application source
--SYSCONF_CXXFLAGS = -pipe -fno-exceptions -g
--SYSCONF_CFLAGS = -pipe -fno-exceptions -g
-+SYSCONF_CXXFLAGS = -DQT_PREFIX=\"${PREFIX}\" -pipe -fno-exceptions -g
-+SYSCONF_CFLAGS = -DQT_PREFIX=\"${PREFIX}\" -pipe -fno-exceptions -g
- # Default link type (static linking is still be used where required)
- SYSCONF_LINK_LIB = $(SYSCONF_LINK_LIB_SHARED)
- SYSCONF_LINK_TARGET = $(SYSCONF_LINK_TARGET_SHARED)