aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt33
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-02-05 14:06:20 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-02-05 14:06:20 +0000
commit6be45ec5f5338d9a7a109fea410a64e5d19cdac1 (patch)
tree6aba2d9646c0f454a3d45be10ed7ed5f5f237900 /x11-toolkits/qt33
parent7346a3e76696fca8e90afd3d63c4fac450234737 (diff)
downloadports-6be45ec5f5338d9a7a109fea410a64e5d19cdac1.tar.gz
ports-6be45ec5f5338d9a7a109fea410a64e5d19cdac1.zip
Update to 3.3.7
Notes
Notes: svn path=/head/; revision=184271
Diffstat (limited to 'x11-toolkits/qt33')
-rw-r--r--x11-toolkits/qt33/Makefile10
-rw-r--r--x11-toolkits/qt33/distinfo6
-rw-r--r--x11-toolkits/qt33/files/patch-CVE-2006-4811140
-rw-r--r--x11-toolkits/qt33/pkg-plist2
4 files changed, 11 insertions, 147 deletions
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index f1a4b098f9b4..49df94103f91 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= qt
-PORTVERSION= 3.3.6
-PORTREVISION= 3
+PORTVERSION= 3.3.7
CATEGORIES?= x11-toolkits ipv6
MASTER_SITES= ${MASTER_SITE_QT}
DISTNAME= qt-x11-free-${PORTVERSION}
@@ -31,7 +30,8 @@ USE_BZIP2= yes
REINPLACE_ARGS= -i ""
USE_X_PREFIX= yes
HAS_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
+NO_FILTER_SHLIBS=yes
.if defined(PACKAGE_BUILDING)
TMPDIR?= /tmp
@@ -147,6 +147,10 @@ CONFLICTS+= qt-3.3.*
CONFLICTS+= qt-copy-[0-9]*
.endif
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
+IGNORE= "The QT ${PORTVERSION} port does not support any XFree86 < 4.x"
+.endif
+
.if exists(${X11BASE}/include/qt2/qapp.h)
BROKEN= "You have QT2 headers installed! Installing this port"
BROKEN+="will result in conflicts between QT3 and QT2!"
diff --git a/x11-toolkits/qt33/distinfo b/x11-toolkits/qt33/distinfo
index 077f06548a5e..16220770609f 100644
--- a/x11-toolkits/qt33/distinfo
+++ b/x11-toolkits/qt33/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/qt-x11-free-3.3.6.tar.bz2) = dc1384c03ac08af21f6fefab32d982cf
-SHA256 (KDE/qt-x11-free-3.3.6.tar.bz2) = 04f12083f6a6f7a8fd4d34a6c1efd37db76a67580c424f4fb7b7c43c0565e6ae
-SIZE (KDE/qt-x11-free-3.3.6.tar.bz2) = 14565843
+MD5 (KDE/qt-x11-free-3.3.7.tar.bz2) = 655e21cf6a7e66daf8ec6ceda81aae1e
+SHA256 (KDE/qt-x11-free-3.3.7.tar.bz2) = 48c05b501029f0640db665fbc7f981a0efbf69ad3cf87a43c5eea4872f4f7ba1
+SIZE (KDE/qt-x11-free-3.3.7.tar.bz2) = 14564513
diff --git a/x11-toolkits/qt33/files/patch-CVE-2006-4811 b/x11-toolkits/qt33/files/patch-CVE-2006-4811
deleted file mode 100644
index 78b4beff638f..000000000000
--- a/x11-toolkits/qt33/files/patch-CVE-2006-4811
+++ /dev/null
@@ -1,140 +0,0 @@
---- src/kernel/qfontengine_x11.cpp Thu Oct 19 14:41:41 CEST 2006
-+++ src/kernel/qfontengine_x11.cpp Thu Oct 19 14:41:41 CEST 2006
-
-@@ -171,7 +171,8 @@
-
- QRect br = xmat.mapRect(QRect(x, y - si->ascent, w, h));
- QRect br2 = br & pdevRect;
-- if (br2.width() <= 0 || br2.height() <= 0)
-+ if (br2.width() <= 0 || br2.height() <= 0
-+ || br2.width() >= 32768 || br2.height() >= 32768)
- return;
- QWMatrix mat = QPixmap::trueMatrix( xmat, w, h );
- QBitmap wx_bm = ::transform(dpy, bm, br2.x() - br.x(), br2.y() - br.y(), br2.width(), br2.height(), mat);
-
---- src/kernel/qimage.cpp Thu Oct 19 14:41:41 CEST 2006
-+++ src/kernel/qimage.cpp Thu Oct 19 14:41:41 CEST 2006
-
-@@ -475,7 +475,12 @@
- Endian bitOrder )
- {
- init();
-- if ( w <= 0 || h <= 0 || depth <= 0 || numColors < 0 )
-+ int bpl = ((w*depth+31)/32)*4; // bytes per scanline
-+ if ( w <= 0 || h <= 0 || depth <= 0 || numColors < 0
-+ || INT_MAX / sizeof(uchar *) < uint(h)
-+ || INT_MAX / uint(depth) < uint(w)
-+ || bpl <= 0
-+ || INT_MAX / uint(bpl) < uint(h) )
- return; // invalid parameter(s)
- data->w = w;
- data->h = h;
-@@ -483,7 +488,6 @@
- data->ncols = depth != 32 ? numColors : 0;
- if ( !yourdata )
- return; // Image header info can be saved without needing to allocate memory.
-- int bpl = ((w*depth+31)/32)*4; // bytes per scanline
- data->nbytes = bpl*h;
- if ( colortable || !data->ncols ) {
- data->ctbl = colortable;
-@@ -525,7 +529,10 @@
- Endian bitOrder )
- {
- init();
-- if ( !yourdata || w <= 0 || h <= 0 || depth <= 0 || numColors < 0 )
-+ if ( !yourdata || w <= 0 || h <= 0 || depth <= 0 || numColors < 0
-+ || INT_MAX / sizeof(uchar *) < uint(h)
-+ || INT_MAX / uint(bpl) < uint(h)
-+ )
- return; // invalid parameter(s)
- data->w = w;
- data->h = h;
-@@ -1264,7 +1271,7 @@
- if ( data->ncols != numColors ) // could not alloc color table
- return FALSE;
-
-- if ( INT_MAX / depth < width) { // sanity check for potential overflow
-+ if ( INT_MAX / uint(depth) < uint(width) ) { // sanity check for potential overflow
- setNumColors( 0 );
- return FALSE;
- }
-@@ -1277,7 +1284,9 @@
- // #### WWA: shouldn't this be (width*depth+7)/8:
- const int pad = bpl - (width*depth)/8; // pad with zeros
- #endif
-- if (INT_MAX / bpl < height) { // sanity check for potential overflow
-+ if ( INT_MAX / uint(bpl) < uint(height)
-+ || bpl < 0
-+ || INT_MAX / sizeof(uchar *) < uint(height) ) { // sanity check for potential overflow
- setNumColors( 0 );
- return FALSE;
- }
-
---- src/kernel/qpixmap_x11.cpp Thu Oct 19 14:41:41 CEST 2006
-+++ src/kernel/qpixmap_x11.cpp Thu Oct 19 14:41:41 CEST 2006
-
-@@ -953,6 +953,9 @@
- bool force_mono = (dd == 1 || isQBitmap() ||
- (conversion_flags & ColorMode_Mask)==MonoOnly );
-
-+ if ( w >= 32768 || h >= 32768 )
-+ return FALSE;
-+
- // get rid of the mask
- delete data->mask;
- data->mask = 0;
-@@ -1678,11 +1681,11 @@
-
- QPixmap QPixmap::xForm( const QWMatrix &matrix ) const
- {
-- int w = 0;
-- int h = 0; // size of target pixmap
-- int ws, hs; // size of source pixmap
-+ uint w = 0;
-+ uint h = 0; // size of target pixmap
-+ uint ws, hs; // size of source pixmap
- uchar *dptr; // data in target pixmap
-- int dbpl, dbytes; // bytes per line/bytes total
-+ uint dbpl, dbytes; // bytes per line/bytes total
- uchar *sptr; // data in original pixmap
- int sbpl; // bytes per line in original
- int bpp; // bits per pixel
-@@ -1697,19 +1700,24 @@
-
- QWMatrix mat( matrix.m11(), matrix.m12(), matrix.m21(), matrix.m22(), 0., 0. );
-
-+ double scaledWidth;
-+ double scaledHeight;
-+
- if ( matrix.m12() == 0.0F && matrix.m21() == 0.0F ) {
- if ( matrix.m11() == 1.0F && matrix.m22() == 1.0F )
- return *this; // identity matrix
-- h = qRound( matrix.m22()*hs );
-- w = qRound( matrix.m11()*ws );
-- h = QABS( h );
-- w = QABS( w );
-+ scaledHeight = matrix.m22()*hs;
-+ scaledWidth = matrix.m11()*ws;
-+ h = QABS( qRound( scaledHeight ) );
-+ w = QABS( qRound( scaledWidth ) );
- } else { // rotation or shearing
- QPointArray a( QRect(0,0,ws+1,hs+1) );
- a = mat.map( a );
- QRect r = a.boundingRect().normalize();
- w = r.width()-1;
- h = r.height()-1;
-+ scaledWidth = w;
-+ scaledHeight = h;
- }
-
- mat = trueMatrix( mat, ws, hs ); // true matrix
-@@ -1718,7 +1726,8 @@
- bool invertible;
- mat = mat.invert( &invertible ); // invert matrix
-
-- if ( h == 0 || w == 0 || !invertible ) { // error, return null pixmap
-+ if ( h == 0 || w == 0 || !invertible
-+ || QABS(scaledWidth) >= 32768 || QABS(scaledHeight) >= 32768 ) { // error, return null pixmap
- QPixmap pm;
- pm.data->bitmap = data->bitmap;
- return pm;
diff --git a/x11-toolkits/qt33/pkg-plist b/x11-toolkits/qt33/pkg-plist
index 25937c0ce0dd..48a7f7dddbde 100644
--- a/x11-toolkits/qt33/pkg-plist
+++ b/x11-toolkits/qt33/pkg-plist
@@ -415,7 +415,7 @@ lib/libqt-mt.prl
lib/libqt-mt.so
lib/libqt-mt.so.3
lib/libqt-mt.so.3.3
-lib/libqt-mt.so.3.3.6
+lib/libqt-mt.so.3.3.7
lib/libqui.prl
lib/libqui.so
lib/libqui.so.1