aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/ruby-gtk2
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-03-20 13:24:30 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-03-20 13:24:30 +0000
commitb165f8eb6afa560d438d1a46a850935ea32cc91f (patch)
tree872a8388ef6b85133c5b989eba2ace71659cc814 /x11-toolkits/ruby-gtk2
parente023b986940969dd2c6abd342268342f6ce434ae (diff)
downloadports-b165f8eb6afa560d438d1a46a850935ea32cc91f.tar.gz
ports-b165f8eb6afa560d438d1a46a850935ea32cc91f.zip
Perform extconf.rb cleanup with no functional change.
Notes
Notes: svn path=/head/; revision=56386
Diffstat (limited to 'x11-toolkits/ruby-gtk2')
-rw-r--r--x11-toolkits/ruby-gtk2/Makefile2
-rw-r--r--x11-toolkits/ruby-gtk2/files/patch-extconf.rb32
2 files changed, 33 insertions, 1 deletions
diff --git a/x11-toolkits/ruby-gtk2/Makefile b/x11-toolkits/ruby-gtk2/Makefile
index 7a9fecaad89e..2cf5d8f511bb 100644
--- a/x11-toolkits/ruby-gtk2/Makefile
+++ b/x11-toolkits/ruby-gtk2/Makefile
@@ -24,7 +24,7 @@ USE_GTK= yes
.include "${.CURDIR}/../../x11/ruby-gnome/Makefile.common"
WRKSRC= ${RUBY_GNOME_WRKSRC}/${PORTNAME}
-CONFIGURE_ARGS= ${GTK_CONFIG}
+CONFIGURE_ARGS= --with-gtk-config=${GTK_CONFIG}
INSTALL_TARGET= site-install
DOCS_EN= BUGS \
diff --git a/x11-toolkits/ruby-gtk2/files/patch-extconf.rb b/x11-toolkits/ruby-gtk2/files/patch-extconf.rb
new file mode 100644
index 000000000000..8134afd73c31
--- /dev/null
+++ b/x11-toolkits/ruby-gtk2/files/patch-extconf.rb
@@ -0,0 +1,32 @@
+--- extconf.rb.orig Wed Jan 9 05:21:22 2002
++++ extconf.rb Wed Mar 20 22:12:37 2002
+@@ -8,24 +8,13 @@
+ # detect GTK+ configurations
+ #
+ if /mswin32/ !~ PLATFORM
+- config_cmds = ["gtk-config"]
+- while /^--/ =~ ARGV[0]
+- ARGV.shift
+- end
+- if ARGV.size > 0
+- config_cmds.unshift(ARGV[0])
+- end
++ config_cmd = with_config("gtk-config", "gtk-config")
+
+ begin
+- config_cmds.each do |config_cmd|
+- version = `#{config_cmd} --version`
+- if not version.chomp.empty?
+- config_libs, config_cflags = "--libs", "--cflags"
+- $LDFLAGS, *libs = `#{config_cmd} #{config_libs}`.chomp.split(/(-l.*)/)
+- $libs = libs.join(' ') + ' ' + $libs
+- $CFLAGS = `#{config_cmd} #{config_cflags}`.chomp
+- break
+- end
++ version = `#{config_cmd} --version`
++ if not version.chomp.empty?
++ $LDFLAGS += ' ' + `#{config_cmd} --libs`.chomp
++ $CFLAGS += ' ' + `#{config_cmd} --cflags`.chomp
+ end
+ rescue
+ $LDFLAGS = '-L/usr/X11R6/lib -L/usr/local/lib'