aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/scintilla
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-02-11 12:56:24 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-02-11 12:56:24 +0000
commit045b5aca225008fe3f354afa37244347a05687ba (patch)
treeafc2de1785ce22e813a250ea5de4c45e19557817 /x11-toolkits/scintilla
parent21db3e6f0049f47675f24a73d7b6568dc8668280 (diff)
downloadports-045b5aca225008fe3f354afa37244347a05687ba.tar.gz
ports-045b5aca225008fe3f354afa37244347a05687ba.zip
Update to 1.44.
Notes
Notes: svn path=/head/; revision=54550
Diffstat (limited to 'x11-toolkits/scintilla')
-rw-r--r--x11-toolkits/scintilla/Makefile2
-rw-r--r--x11-toolkits/scintilla/distinfo2
-rw-r--r--x11-toolkits/scintilla/files/patch-aa23
3 files changed, 17 insertions, 10 deletions
diff --git a/x11-toolkits/scintilla/Makefile b/x11-toolkits/scintilla/Makefile
index 50cea90abb06..d64d7d309f62 100644
--- a/x11-toolkits/scintilla/Makefile
+++ b/x11-toolkits/scintilla/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scintilla
-PORTVERSION= 1.42
+PORTVERSION= 1.44
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.scintilla.org/
diff --git a/x11-toolkits/scintilla/distinfo b/x11-toolkits/scintilla/distinfo
index d1b045c53cc8..a6bca76a65e6 100644
--- a/x11-toolkits/scintilla/distinfo
+++ b/x11-toolkits/scintilla/distinfo
@@ -1 +1 @@
-MD5 (scite142.tgz) = 7160ceeebb433c28ada28189823f9280
+MD5 (scite144.tgz) = 88199f52c4a337a938fff64d0eb470b0
diff --git a/x11-toolkits/scintilla/files/patch-aa b/x11-toolkits/scintilla/files/patch-aa
index f46b1bbb3d6a..e371d87add73 100644
--- a/x11-toolkits/scintilla/files/patch-aa
+++ b/x11-toolkits/scintilla/files/patch-aa
@@ -1,9 +1,9 @@
$FreeBSD$
---- makefile.orig Wed Sep 19 16:33:24 2001
-+++ makefile Thu Oct 18 18:15:16 2001
-@@ -5,10 +5,11 @@
+--- makefile.orig Fri Jan 25 02:52:32 2002
++++ makefile Mon Feb 11 11:40:38 2002
+@@ -5,8 +5,8 @@
# GNU make does not like \r\n line endings so should be saved to CVS in binary form.
.SUFFIXES: .cxx .o .h .a
@@ -11,6 +11,12 @@ $FreeBSD$
-AR = ar
+CC ?= g++
+AR = $(CC) -shared
+ RANLIB = touch
+
+ ifeq ($(OSTYPE),darwin)
+@@ -15,7 +15,8 @@
+ RANLIB = ranlib
+ endif
-COMPLIB=../bin/scintilla.a
+COMPLIB=../bin/libscintilla.so.1
@@ -18,7 +24,7 @@ $FreeBSD$
vpath %.h ../src ../include
vpath %.cxx ../src
-@@ -17,13 +18,13 @@
+@@ -24,13 +25,13 @@
CXXBASEFLAGS=-W -Wall -DGTK -DSCI_LEXER $(INCLUDEDIRS)
ifdef DEBUG
@@ -33,9 +39,9 @@ $FreeBSD$
- $(CC) `gtk-config --cflags` $(CXXFLAGS) -c $<
+ $(CC) -DPIC -fpic $(shell $(GTK_CONFIG) --cflags) $(CXXFLAGS) -c $<
- LEXOBJS=LexAda.o LexAVE.o LexConf.o LexCPP.o LexCrontab.o LexEiffel.o LexHTML.o \
- LexLisp.o LexLua.o LexOthers.o LexPascal.o LexPerl.o \
-@@ -31,7 +32,7 @@
+ LEXOBJS=LexAda.o LexAVE.o LexBaan.o LexBullant.o LexConf.o LexCPP.o \
+ LexCrontab.o LexEiffel.o LexHTML.o LexLisp.o LexLua.o LexOthers.o \
+@@ -38,7 +39,7 @@
# The LEXOBJS have to be treated specially as the functions in them are not called from external code
@@ -44,11 +50,12 @@ $FreeBSD$
clean:
rm -f *.o $(COMPLIB)
-@@ -43,7 +44,10 @@
+@@ -50,8 +51,10 @@
ScintillaBase.o ContractionState.o Editor.o PropSet.o PlatGTK.o \
KeyMap.o LineMarker.o ScintillaGTK.o CellBuffer.o ViewStyle.o \
RESearch.o Style.o Indicator.o AutoComplete.o
- $(AR) rc $@ $^
+- $(RANLIB) $@
+ $(AR) -o $@ $^
+
+$(LEXRLIB): $(LEXOBJS)