aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/scintilla
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-12 14:18:22 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-12 14:18:22 +0000
commitb18bc42b406f31c4d017ea1bad9270f5e951c51d (patch)
treea338075eabe72680ee5a9888eec9717dd05fc48d /x11-toolkits/scintilla
parent07bbe7dc820e6e173328227e764d8d70a7ae2e70 (diff)
downloadports-b18bc42b406f31c4d017ea1bad9270f5e951c51d.tar.gz
ports-b18bc42b406f31c4d017ea1bad9270f5e951c51d.zip
- Update to version 1.58
PR: 61252 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=98001
Diffstat (limited to 'x11-toolkits/scintilla')
-rw-r--r--x11-toolkits/scintilla/Makefile2
-rw-r--r--x11-toolkits/scintilla/distinfo2
-rw-r--r--x11-toolkits/scintilla/files/patch-aa34
3 files changed, 20 insertions, 18 deletions
diff --git a/x11-toolkits/scintilla/Makefile b/x11-toolkits/scintilla/Makefile
index 497d54313302..0dfe329bbbe4 100644
--- a/x11-toolkits/scintilla/Makefile
+++ b/x11-toolkits/scintilla/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scintilla
-PORTVERSION= 1.57
+PORTVERSION= 1.58
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.scintilla.org/
diff --git a/x11-toolkits/scintilla/distinfo b/x11-toolkits/scintilla/distinfo
index 3dcd2e4dbe9b..3b2cd35e6866 100644
--- a/x11-toolkits/scintilla/distinfo
+++ b/x11-toolkits/scintilla/distinfo
@@ -1 +1 @@
-MD5 (scite157.tgz) = d8d18de553555437791996daed9ff7ec
+MD5 (scite158.tgz) = 0f704b40f07aba44205621a19245847c
diff --git a/x11-toolkits/scintilla/files/patch-aa b/x11-toolkits/scintilla/files/patch-aa
index 4cff4045011c..9daa0643d016 100644
--- a/x11-toolkits/scintilla/files/patch-aa
+++ b/x11-toolkits/scintilla/files/patch-aa
@@ -1,6 +1,6 @@
---- makefile.orig Sun Sep 21 11:19:30 2003
-+++ makefile Tue Oct 7 10:52:28 2003
-@@ -8,8 +8,8 @@
+--- makefile.orig Wed Dec 24 08:45:12 2003
++++ makefile Sun Jan 11 19:50:44 2004
+@@ -8,15 +8,16 @@
# To force GTK+ 1 build, define GTK1 on the make command line.
.SUFFIXES: .cxx .o .h .a
@@ -10,8 +10,7 @@
+AR = $(CC) -shared
RANLIB = touch
- ifeq ($(OSTYPE),darwin)
-@@ -18,7 +18,8 @@
+ ifeq ($(shell uname),Darwin)
RANLIB = ranlib
endif
@@ -21,12 +20,12 @@
vpath %.h ../src ../include
vpath %.cxx ../src
-@@ -33,29 +34,29 @@
+@@ -31,29 +32,29 @@
endif
ifdef DEBUG
-CXXFLAGS=-DDEBUG -g $(CXXBASEFLAGS) $(THREADFLAGS)
-+CXXFLAGS+=-DDEBUG $(CXXBASEFLAGS) $(THREADFLAGS)
++CXXFLAGS+=-DDEBUG -g $(CXXBASEFLAGS) $(THREADFLAGS)
else
-CXXFLAGS=-DNDEBUG -Os $(CXXBASEFLAGS) $(THREADFLAGS)
+CXXFLAGS+=-DNDEBUG $(CXXBASEFLAGS) $(THREADFLAGS)
@@ -42,12 +41,12 @@
-CONFIGFLAGS=gtk-config --cflags
+CONFIGFLAGS=pkg-config --cflags gtk+ gthread
else
- ifneq (,$(findstring /,$(shell whereis -b pkg-config)))
+ ifneq (,$(findstring /,$(shell whereis pkg-config)))
-CONFIGFLAGS=pkg-config --cflags gtk+-2.0
+CONFIGFLAGS=pkg-config --cflags gtk+-2.0 gthread-2.0
else
-CONFIGFLAGS=gtk-config --cflags
-+CONFIGFLAGS=gtk-config --cflags gthread
++CONFIGFLAGS=gtk-config --cflags gtk+ gthread
endif
endif
endif
@@ -58,24 +57,27 @@
#++Autogenerated -- run src/LexGen.py to regenerate
#**LEXOBJS=\\\n\(\*.o \)
-@@ -69,7 +70,7 @@
+@@ -66,7 +67,7 @@
+ LexYAML.o
+ #--Autogenerated -- end of automatically generated section
- # The LEXOBJS have to be treated specially as the functions in them are not called from external code
-
--all: $(COMPLIB) $(LEXOBJS)
+-all: $(COMPLIB)
+all: $(COMPLIB) $(LEXRLIB)
clean:
rm -f *.o $(COMPLIB)
-@@ -81,8 +82,10 @@
+@@ -77,10 +78,11 @@
+ $(COMPLIB): DocumentAccessor.o WindowAccessor.o KeyWords.o StyleContext.o Document.o CallTip.o \
ScintillaBase.o ContractionState.o Editor.o ExternalLexer.o PropSet.o PlatGTK.o \
KeyMap.o LineMarker.o ScintillaGTK.o CellBuffer.o ViewStyle.o \
- RESearch.o Style.o Indicator.o AutoComplete.o UniConversion.o XPM.o
+- RESearch.o Style.o Indicator.o AutoComplete.o UniConversion.o XPM.o \
+- $(LEXOBJS)
- $(AR) rc $@ $^
- $(RANLIB) $@
++ RESearch.o Style.o Indicator.o AutoComplete.o UniConversion.o XPM.o
+ $(AR) `$(CONFIGFLAGS:cflags=libs)` -o $@ $^
+
-+ $(LEXRLIB): $(LEXOBJS)
++$(LEXRLIB): $(LEXOBJS)
+ $(AR) `$(CONFIGFLAGS:cflags=libs)` -o $@ $^
# Automatically generate header dependencies with "make deps"