aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/scintilla
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-04-05 17:14:21 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-04-05 17:14:21 +0000
commit714891e037317e5a0964aaedb5385b4d81cb6ebf (patch)
treea7f9992a48ad00068c09ca288de1a7d0ef83b4ab /x11-toolkits/scintilla
parentaa222d4598c67bdb2a869b06dc4501efc73bde89 (diff)
downloadports-714891e037317e5a0964aaedb5385b4d81cb6ebf.tar.gz
ports-714891e037317e5a0964aaedb5385b4d81cb6ebf.zip
- Update to 2.10
PR: 145406 Submitted by: Naram Qashat <cyberbotx@cyberbotx.com> (maintainer)
Notes
Notes: svn path=/head/; revision=252250
Diffstat (limited to 'x11-toolkits/scintilla')
-rw-r--r--x11-toolkits/scintilla/Makefile4
-rw-r--r--x11-toolkits/scintilla/distinfo6
-rw-r--r--x11-toolkits/scintilla/files/patch-aa39
3 files changed, 16 insertions, 33 deletions
diff --git a/x11-toolkits/scintilla/Makefile b/x11-toolkits/scintilla/Makefile
index 9d781c5eff89..07ddea8a8d29 100644
--- a/x11-toolkits/scintilla/Makefile
+++ b/x11-toolkits/scintilla/Makefile
@@ -6,8 +6,7 @@
# $MCom: ports/x11-toolkits/scintilla/Makefile,v 1.3 2006/09/17 21:58:56 marcus Exp $
PORTNAME= scintilla
-PORTVERSION= 2.03
-PORTREVISION= 1
+PORTVERSION= 2.10
CATEGORIES= x11-toolkits
MASTER_SITES= SF/scintilla/SciTE/${PORTVERSION}
DISTNAME= scite${PORTVERSION:S/.//g}
@@ -23,6 +22,7 @@ USE_ICONV= yes
MAKEFILE= makefile
USE_LDCONFIG= yes
USE_GNOME= gtk20
+USE_GCC= 4.2+
.include <bsd.port.pre.mk>
diff --git a/x11-toolkits/scintilla/distinfo b/x11-toolkits/scintilla/distinfo
index 678da5e75391..7c093c1a53ef 100644
--- a/x11-toolkits/scintilla/distinfo
+++ b/x11-toolkits/scintilla/distinfo
@@ -1,3 +1,3 @@
-MD5 (scite203.tgz) = f70f237180a556e287c17423b6c45a24
-SHA256 (scite203.tgz) = e81395cbafbc11d5fa3677e4b9da03ac066f740aefe6f7479918a868935bd762
-SIZE (scite203.tgz) = 1850025
+MD5 (scite210.tgz) = 91644ec613dafa3e2a0add01c42d716d
+SHA256 (scite210.tgz) = 69af703c5b9652571e7e9c040145cfbdc6c8d4f28cf9e14be5461aad08ab52d7
+SIZE (scite210.tgz) = 1783858
diff --git a/x11-toolkits/scintilla/files/patch-aa b/x11-toolkits/scintilla/files/patch-aa
index b1f50a62d548..8afbfa0db751 100644
--- a/x11-toolkits/scintilla/files/patch-aa
+++ b/x11-toolkits/scintilla/files/patch-aa
@@ -1,7 +1,7 @@
---- makefile.orig 2009-08-12 21:35:23.000000000 -0400
-+++ makefile 2009-08-21 01:58:12.000000000 -0400
-@@ -8,16 +8,17 @@
- # To force GTK+ 1 build, define GTK1 on the make command line.
+--- makefile.orig 2010-03-25 19:49:46.000000000 -0400
++++ makefile 2010-04-05 07:36:46.000000000 -0400
+@@ -7,9 +7,9 @@
+ # Also works with ming32-make on Windows.
.SUFFIXES: .cxx .c .o .h .a
-CC = g++
@@ -12,8 +12,9 @@
+AR = $(CXX) -shared
RANLIB = touch
- ifeq ($(shell uname),Darwin)
- RANLIB = ranlib
+ ifndef windir
+@@ -18,7 +18,8 @@
+ endif
endif
-COMPLIB=../bin/scintilla.a
@@ -22,7 +23,7 @@
vpath %.h ../src ../include
vpath %.cxx ../src
-@@ -32,33 +33,33 @@
+@@ -33,18 +34,18 @@
endif
ifdef DEBUG
@@ -33,27 +34,9 @@
+CXXFLAGS+=-DNDEBUG -Os $(CXXBASEFLAGS) $(THREADFLAGS)
endif
- # If explicit setting of GTK1 or GTK2 then use that else look for
- # pkg-config which is an OK indication that GTK2 is available
- ifdef GTK2
--CONFIGFLAGS:=$(shell pkg-config --cflags gtk+-2.0)
-+CONFIGFLAGS:=$(shell pkg-config --cflags gtk+-2.0 gthread-2.0)
- MARSHALLER=scintilla-marshal.o
- else
- ifdef GTK1
--CONFIGFLAGS:=$(shell gtk-config --cflags)
-+CONFIGFLAGS:=$(shell pkg-config --cflags gtk+ gthread)
- else
- ifneq (,$(findstring /,$(shell whereis pkg-config)))
-CONFIGFLAGS:=$(shell pkg-config --cflags gtk+-2.0)
+CONFIGFLAGS:=$(shell pkg-config --cflags gtk+-2.0 gthread-2.0)
MARSHALLER=scintilla-marshal.o
- else
--CONFIGFLAGS:=$(shell gtk-config --cflags)
-+CONFIGFLAGS:=$(shell pkg-config --cflags gtk+ gthread)
- endif
- endif
- endif
.cxx.o:
- $(CC) $(CONFIGFLAGS) $(CXXFLAGS) -c $<
@@ -64,8 +47,8 @@
#++Autogenerated -- run src/LexGen.py to regenerate
#**LEXOBJS=\\\n\(\*.o \)
-@@ -76,7 +77,7 @@
- LexTADS3.o LexTAL.o LexTCL.o LexTeX.o LexVB.o LexVerilog.o LexVHDL.o LexYAML.o
+@@ -63,7 +64,7 @@
+ LexVHDL.o LexYAML.o
#--Autogenerated -- end of automatically generated section
-all: $(COMPLIB)
@@ -73,7 +56,7 @@
clean:
rm -f *.o $(COMPLIB)
-@@ -89,9 +90,11 @@
+@@ -76,9 +77,11 @@
ScintillaBase.o ContractionState.o Editor.o ExternalLexer.o PropSet.o PlatGTK.o \
KeyMap.o LineMarker.o PositionCache.o ScintillaGTK.o CellBuffer.o ViewStyle.o \
RESearch.o RunStyles.o Selection.o Style.o Indicator.o AutoComplete.o UniConversion.o XPM.o \