aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/swt
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2007-10-11 18:13:08 +0000
committerRenato Botelho <garga@FreeBSD.org>2007-10-11 18:13:08 +0000
commit85a4f8fc5e14ea94bf92f07335763ed249247dc4 (patch)
treead4d83007122a4a65b0c7c46f0fe00c67f46a34a /x11-toolkits/swt
parent7690f9d607e436c2512603dccfdc38fd1fff7303 (diff)
downloadports-85a4f8fc5e14ea94bf92f07335763ed249247dc4.tar.gz
ports-85a4f8fc5e14ea94bf92f07335763ed249247dc4.zip
- Add *.propeerties files to jar file
PR: ports/117117 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=201304
Diffstat (limited to 'x11-toolkits/swt')
-rw-r--r--x11-toolkits/swt/Makefile2
-rw-r--r--x11-toolkits/swt/files/patch-build.xml9
2 files changed, 6 insertions, 5 deletions
diff --git a/x11-toolkits/swt/Makefile b/x11-toolkits/swt/Makefile
index 9ceaf533ea8e..65768d37ae02 100644
--- a/x11-toolkits/swt/Makefile
+++ b/x11-toolkits/swt/Makefile
@@ -7,7 +7,7 @@
PORTNAME= swt
DISTVERSION= 3.3
-#PORTREVISION= 1
+PORTREVISION= 1
CATEGORIES= x11-toolkits devel java
MASTER_SITES= ${MASTER_SITE_ECLIPSE}
MASTER_SITE_SUBDIR= R-${DISTVERSION}-200706251500
diff --git a/x11-toolkits/swt/files/patch-build.xml b/x11-toolkits/swt/files/patch-build.xml
index 976b89bd647d..eb6a5dacf532 100644
--- a/x11-toolkits/swt/files/patch-build.xml
+++ b/x11-toolkits/swt/files/patch-build.xml
@@ -1,6 +1,6 @@
---- build.xml.orig Mon Dec 5 15:14:46 2005
-+++ build.xml Fri Nov 17 23:48:20 2006
-@@ -1,55 +1,56 @@
+--- build.xml.orig 2005-12-05 15:14:46.000000000 -0500
++++ build.xml 2007-10-11 13:30:41.000000000 -0400
+@@ -1,55 +1,57 @@
<?xml version="1.0" encoding="UTF-8"?>
+<project name="org.eclipse.swt.gtk.freebsd.x86_64" default="build.jar" basedir=".">
@@ -12,7 +12,7 @@
+ <property name="javac.verbose" value="false"/>
+ <property name="javac.debug" value="off"/>
+ <property name="input.srcdir" value="${basedir}/org"/>
-+ <property name="output.jar" value="${basedir}/swt32.jar"/>
++ <property name="output.jar" value="${basedir}/swt.jar"/>
+ <property name="output.classes" value="${basedir}/classes"/>
+ </target>
+
@@ -38,6 +38,7 @@
+ </fileset>
+ <fileset dir="${basedir}">
+ <include name="**/version.txt"/>
++ <include name="**/*.properties"/>
+ </fileset>
+ </jar>
+ </target>