aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/tile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-10-08 11:37:15 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-10-08 11:37:15 +0000
commitea6b4bcf15629e8525de9f7eddbd4ae6f3880d8f (patch)
treeed44283b26b1c15e68330e0829832e06ab60756a /x11-toolkits/tile
parent81de54410730ce536b9675b0e8008add7ff4eb59 (diff)
downloadports-ea6b4bcf15629e8525de9f7eddbd4ae6f3880d8f.tar.gz
ports-ea6b4bcf15629e8525de9f7eddbd4ae6f3880d8f.zip
Add port x11-toolkits/tile:
The Tile Widget Set is a next-generation re-implementation of many of the core Tk widgets, along with the addition of several new widgets. With Tile, Tk applications can achieve an appearance much closer to native platform widgets, as well as take advantage of a modern, highly dynamic theme engine to produce a wide variety of alternative user interface styles. Tile widgets complement the existing Tk widgets, and Tile is currently being incorporated directly into Tk. WWW: http://tktable.sourceforge.net/tile/
Notes
Notes: svn path=/head/; revision=174921
Diffstat (limited to 'x11-toolkits/tile')
-rw-r--r--x11-toolkits/tile/Makefile33
-rw-r--r--x11-toolkits/tile/distinfo3
-rw-r--r--x11-toolkits/tile/pkg-descr8
-rw-r--r--x11-toolkits/tile/pkg-plist33
4 files changed, 77 insertions, 0 deletions
diff --git a/x11-toolkits/tile/Makefile b/x11-toolkits/tile/Makefile
new file mode 100644
index 000000000000..c2ea14e97491
--- /dev/null
+++ b/x11-toolkits/tile/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: tile
+# Date created: 18 July 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tile
+PORTVERSION= 0.7.8
+CATEGORIES= x11-toolkits tk84
+MASTER_SITES= SF/tktable
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Themed widget set for Tk
+
+LIB_DEPENDS= tk${USE_TK}.1:${PORTSDIR}/x11-toolkits/tk${USE_TK}
+
+USE_TK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl${TK_VER} \
+ --with-tk=${LOCALBASE}/lib/tk${TK_VER} \
+ --exec-prefix=${PREFIX} --enable-shared
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${TCL_INCLUDES} ${TK_INCLUDES}"
+TCL_INCLUDES= -I${LOCALBASE}/include/tcl${TK_VER} -I${LOCALBASE}/include/tcl${TK_VER}/generic
+TK_INCLUDES= -I${LOCALBASE}/include/tk${TK_VER} -I${LOCALBASE}/include/tk${TK_VER}/generic
+TKPKG= ${PORTNAME}${PORTVERSION}
+PLIST_SUB= VER=${PORTVERSION} TKPKG=${TKPKG}
+USE_LDCONFIG= ${PREFIX}/lib/${TKPKG}
+
+post-install:
+ @${LN} -sf ${USE_LDCONFIG}/lib${TKPKG}.so ${USE_LDCONFIG}/lib${TKPKG}.so.0
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/tile/distinfo b/x11-toolkits/tile/distinfo
new file mode 100644
index 000000000000..38255340767d
--- /dev/null
+++ b/x11-toolkits/tile/distinfo
@@ -0,0 +1,3 @@
+MD5 (tile-0.7.8.tar.gz) = 1172c1875ae63d7a73d8ba27835e16d4
+SHA256 (tile-0.7.8.tar.gz) = 86536244a202c1d69679ee6ae0b58a7ea64731f9a10c8cfff013774a417843bf
+SIZE (tile-0.7.8.tar.gz) = 597832
diff --git a/x11-toolkits/tile/pkg-descr b/x11-toolkits/tile/pkg-descr
new file mode 100644
index 000000000000..369db2ae8cb0
--- /dev/null
+++ b/x11-toolkits/tile/pkg-descr
@@ -0,0 +1,8 @@
+The Tile Widget Set is a next-generation re-implementation of many of the core
+Tk widgets, along with the addition of several new widgets. With Tile, Tk
+applications can achieve an appearance much closer to native platform widgets,
+as well as take advantage of a modern, highly dynamic theme engine to produce a
+wide variety of alternative user interface styles. Tile widgets complement the
+existing Tk widgets, and Tile is currently being incorporated directly into Tk.
+
+WWW: http://tktable.sourceforge.net/tile/
diff --git a/x11-toolkits/tile/pkg-plist b/x11-toolkits/tile/pkg-plist
new file mode 100644
index 000000000000..bd7a318ee3e9
--- /dev/null
+++ b/x11-toolkits/tile/pkg-plist
@@ -0,0 +1,33 @@
+include/tkTheme.h
+include/ttkDecls.h
+lib/%%TKPKG%%/lib%%TKPKG%%.so
+lib/%%TKPKG%%/lib%%TKPKG%%.so.0
+lib/libttkstub.a
+lib/%%TKPKG%%/altTheme.tcl
+lib/%%TKPKG%%/aquaTheme.tcl
+lib/%%TKPKG%%/button.tcl
+lib/%%TKPKG%%/clamTheme.tcl
+lib/%%TKPKG%%/classicTheme.tcl
+lib/%%TKPKG%%/combobox.tcl
+lib/%%TKPKG%%/cursors.tcl
+lib/%%TKPKG%%/defaults.tcl
+lib/%%TKPKG%%/dialog.tcl
+lib/%%TKPKG%%/entry.tcl
+lib/%%TKPKG%%/fonts.tcl
+lib/%%TKPKG%%/icons.tcl
+lib/%%TKPKG%%/keynav.tcl
+lib/%%TKPKG%%/menubutton.tcl
+lib/%%TKPKG%%/notebook.tcl
+lib/%%TKPKG%%/paned.tcl
+lib/%%TKPKG%%/pkgIndex.tcl
+lib/%%TKPKG%%/progress.tcl
+lib/%%TKPKG%%/scale.tcl
+lib/%%TKPKG%%/scrollbar.tcl
+lib/%%TKPKG%%/sizegrip.tcl
+lib/%%TKPKG%%/stepTheme.tcl
+lib/%%TKPKG%%/tile.tcl
+lib/%%TKPKG%%/treeview.tcl
+lib/%%TKPKG%%/utils.tcl
+lib/%%TKPKG%%/winTheme.tcl
+lib/%%TKPKG%%/xpTheme.tcl
+@dirrm lib/%%TKPKG%%