aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/tk82
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-13 10:31:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-13 10:31:54 +0000
commit0ec00af31d44a1f18a7c25f8bd0fae9196e355d1 (patch)
treec4e4f8000243ce80d914fc350b1e0b74cf3dd3ad /x11-toolkits/tk82
parent5bd95f77f5310d06d509ad4470f28ffc72752571 (diff)
downloadports-0ec00af31d44a1f18a7c25f8bd0fae9196e355d1.tar.gz
ports-0ec00af31d44a1f18a7c25f8bd0fae9196e355d1.zip
- Removed unnecessary PKGINSTALL and PKGDEINSTALL
- Improved handling of WITH_TK82_MAN - Manpages are not installed by default (default on for default TK - 8.4) PR: 110237 Submitted by: Martin Matuska <martin@matuska.org> (maintainer)
Notes
Notes: svn path=/head/; revision=187283
Diffstat (limited to 'x11-toolkits/tk82')
-rw-r--r--x11-toolkits/tk82/Makefile14
-rw-r--r--x11-toolkits/tk82/files/patch-ab13
2 files changed, 14 insertions, 13 deletions
diff --git a/x11-toolkits/tk82/Makefile b/x11-toolkits/tk82/Makefile
index e5f4fe720fa0..7805abead30d 100644
--- a/x11-toolkits/tk82/Makefile
+++ b/x11-toolkits/tk82/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tk
PORTVERSION= 8.2.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11-toolkits tk82
MASTER_SITES= ${MASTER_SITE_TCLTK}
MASTER_SITE_SUBDIR= tcl8_2
@@ -30,12 +30,10 @@ CONFIGURE_ARGS= --enable-shared --with-tcl=${PREFIX}/lib/tcl${TK_VER}
CONFIGURE_ENV= PORTSDIR=${PORTSDIR} TK_LIB_FILE=libtk${SHORT_TK_VER}.so.1
MAKE_ENV= SHORT_TK_VER=${SHORT_TK_VER}
PLIST_SUB= TK_VER=${TK_VER} SHORT_TK_VER=${SHORT_TK_VER}
-PKGINSTALL= ${PKGDIR}/pkg-install.wish
-PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.wish
TCL82_PORT?= lang/tcl82
MANCOMPRESSED= no
-OPTIONS= TK82_MAN "Install tk 8.2 manpages" on \
+OPTIONS= TK82_MAN "Install tk 8.2 manpages" off \
WISH_WRAPPER "Require wish wrapper from ports" off
.include <bsd.port.pre.mk>
@@ -320,15 +318,11 @@ post-configure:
${REINPLACE_CMD} \
-e 's|${WRKDIRPREFIX}${.CURDIR}|$${WRKDIRPREFIX}${TKBASE}|' \
${WRKSRC}/tkConfig.sh
-.if defined(NO_INSTALL_MANPAGES) || !defined(WITH_TK82_MAN)
- ${REINPLACE_CMD} -e 's|^MAN_INSTALL_DIR.*$$|MAN_INSTALL_DIR = ${WRKDIR}|' \
- ${WRKSRC}/Makefile
-.endif
post-install:
${INSTALL_DATA} ${FILESDIR}/pkgIndex.tcl ${PREFIX}/lib/tk${TK_VER}/
-.if exists(${PKGINSTALL})
- ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL}
+.if !defined(NO_INSTALL_MANPAGES) && defined(WITH_TK82_MAN)
+ @cd ${WRKSRC} && ${MAKE} -f Makefile install-doc
.endif
test:
diff --git a/x11-toolkits/tk82/files/patch-ab b/x11-toolkits/tk82/files/patch-ab
index b2d6b151397f..6642a3048b46 100644
--- a/x11-toolkits/tk82/files/patch-ab
+++ b/x11-toolkits/tk82/files/patch-ab
@@ -1,5 +1,5 @@
---- Makefile.in.orig Tue Dec 14 23:00:19 1999
-+++ Makefile.in Mon Apr 24 09:41:33 2000
+--- Makefile.in.orig Wed Dec 15 05:00:19 1999
++++ Makefile.in Mon Mar 12 17:42:52 2007
@@ -56,7 +56,9 @@
BIN_DIR = $(exec_prefix)/bin
@@ -53,7 +53,14 @@
${STUB_LIB_FILE}: ${STUB_LIB_OBJS}
rm -f ${STUB_LIB_FILE}
@MAKE_STUB_LIB@
-@@ -425,7 +433,7 @@
+@@ -419,13 +427,13 @@
+ TK_LIBRARY=@TK_SRC_DIR@/library; export TK_LIBRARY; \
+ ./tktest
+
+-install: all install-binaries install-libraries install-demos install-doc
++install: all install-binaries install-libraries install-demos
+
+ # Note: before running ranlib below, must cd to target directory because
# some ranlibs write to current directory, and this might not always be
# possible (e.g. if installing as root).