aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/wmapp
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-04-03 18:45:57 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-04-03 18:45:57 +0000
commita14211f177511754d3748f4e43e0ec025f4cd1eb (patch)
tree77c1af11e269ad1196c2656598d0b09e902a4d64 /x11-toolkits/wmapp
parent511ef527ff4a373b60f2e0ec95e3a7af4b24ef05 (diff)
downloadports-a14211f177511754d3748f4e43e0ec025f4cd1eb.tar.gz
ports-a14211f177511754d3748f4e43e0ec025f4cd1eb.zip
add wmapp 0.0.4.1
A DockApp Graphics Library
Notes
Notes: svn path=/head/; revision=78056
Diffstat (limited to 'x11-toolkits/wmapp')
-rw-r--r--x11-toolkits/wmapp/Makefile31
-rw-r--r--x11-toolkits/wmapp/distinfo1
-rw-r--r--x11-toolkits/wmapp/pkg-descr9
-rw-r--r--x11-toolkits/wmapp/pkg-plist1
4 files changed, 42 insertions, 0 deletions
diff --git a/x11-toolkits/wmapp/Makefile b/x11-toolkits/wmapp/Makefile
new file mode 100644
index 000000000000..8e19c44795d5
--- /dev/null
+++ b/x11-toolkits/wmapp/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: wmapp
+# Date Created: Apr 3, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmapp
+PORTVERSION= 0.0.4.1
+CATEGORIES= x11-toolkits windowmaker
+MASTER_SITES= http://www.princeton.edu/~kmccarty/downloads/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A DockApp Graphics Library
+
+USE_XLIB= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+CFLAGS+= -I${X11BASE}/include
+MAKE_ENV= LFLAGS="-L. -L${X11BASE}/lib -lXpm -lXext -lX11 -lwmapp"
+ALL_TARGET= # empty
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|export |#export |g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s|malloc\.h|stdlib.h|g" ${WRKSRC}/xwrapper.h
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/libwmapp.a ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/wmapp/distinfo b/x11-toolkits/wmapp/distinfo
new file mode 100644
index 000000000000..4682f368bba0
--- /dev/null
+++ b/x11-toolkits/wmapp/distinfo
@@ -0,0 +1 @@
+MD5 (wmapp-0.0.4.1.tar.gz) = 60200050e08fd57cc16a6eca38f02cb6
diff --git a/x11-toolkits/wmapp/pkg-descr b/x11-toolkits/wmapp/pkg-descr
new file mode 100644
index 000000000000..093e394afe4e
--- /dev/null
+++ b/x11-toolkits/wmapp/pkg-descr
@@ -0,0 +1,9 @@
+WMApp is a C++ based library for writing WindowMaker-style dockapps. To write
+a dockapp, it is generally necessary to perform some magic Xlib incantations,
+supply a clipping mask, and set up X event checking. Like larger graphics
+libraries such as GTK+ and Qt, WMApp automates this process by providing the
+classes and functions necessary for widget creation and callbacks. The library
+provides numerous widgets, all with the traditional dockapp appearance. Many
+common dockapps could already be rewritten to use this library.
+
+WWW: http://www.princeton.edu/~kmccarty/wmapp.html
diff --git a/x11-toolkits/wmapp/pkg-plist b/x11-toolkits/wmapp/pkg-plist
new file mode 100644
index 000000000000..a27c5f9f4549
--- /dev/null
+++ b/x11-toolkits/wmapp/pkg-plist
@@ -0,0 +1 @@
+lib/libwmapp.a