aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/xg
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-12-23 01:19:33 +0000
committerSteve Price <steve@FreeBSD.org>1998-12-23 01:19:33 +0000
commit205a5d395b94897f554a2a96e2839340882aadd9 (patch)
treeb90d3134d9cacbd831b9bd9c4b00466c79d16a21 /x11-toolkits/xg
parent6b8e9c5547788d807ada41cf63551b47a04e037a (diff)
downloadports-205a5d395b94897f554a2a96e2839340882aadd9.tar.gz
ports-205a5d395b94897f554a2a96e2839340882aadd9.zip
Initial import of xg version 1.0.
Windows(tm) controls - like widget set for Motif(tm). PR: 8950 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Notes
Notes: svn path=/head/; revision=15500
Diffstat (limited to 'x11-toolkits/xg')
-rw-r--r--x11-toolkits/xg/Makefile38
-rw-r--r--x11-toolkits/xg/distinfo1
-rw-r--r--x11-toolkits/xg/files/patch-aa13
-rw-r--r--x11-toolkits/xg/files/patch-ab22
-rw-r--r--x11-toolkits/xg/files/patch-ac12
-rw-r--r--x11-toolkits/xg/pkg-comment1
-rw-r--r--x11-toolkits/xg/pkg-descr10
-rw-r--r--x11-toolkits/xg/pkg-plist45
8 files changed, 142 insertions, 0 deletions
diff --git a/x11-toolkits/xg/Makefile b/x11-toolkits/xg/Makefile
new file mode 100644
index 000000000000..66e74914643b
--- /dev/null
+++ b/x11-toolkits/xg/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: xg
+# Version required: 1.0
+# Date created: 3 December 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= xg
+PKGNAME= xg-1.0
+CATEGORIES= x11-toolkits
+MASTER_SITES= ftp://messners.com/code/ \
+ http://www.messners.com/code/
+
+MAINTAINER= andy@icc.surw.chel.su
+
+REQUIRES_MOTIF= yes
+USE_X_PREFIX= yes
+MAKEFILE= makefile
+WRKSRC= ${WRKDIR}/Xg-1.0
+
+do-install:
+ @ ${INSTALL_DATA} ${WRKSRC}/src/libxg.a ${PREFIX}/lib
+ @ ${MKDIR} ${PREFIX}/include/xg
+ @ ${INSTALL_DATA} ${WRKSRC}/include/* ${PREFIX}/include/xg
+ @ ${MKDIR} ${PREFIX}/share/examples/xg
+ @ ${INSTALL_DATA} ${WRKSRC}/testsrc/* ${PREFIX}/share/examples/xg
+ @ ${MV} ${PREFIX}/share/examples/xg/makefile ${PREFIX}/share/examples/xg/Makefile
+ @ ${RM} ${PREFIX}/share/examples/xg/makefile.orig
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/xg
+ @ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${PREFIX}/share/doc/xg
+ @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xg
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/xg/distinfo b/x11-toolkits/xg/distinfo
new file mode 100644
index 000000000000..e911c8b27d07
--- /dev/null
+++ b/x11-toolkits/xg/distinfo
@@ -0,0 +1 @@
+MD5 (xg.tar.gz) = c9b8045a2840ad1d317968b2e389836a
diff --git a/x11-toolkits/xg/files/patch-aa b/x11-toolkits/xg/files/patch-aa
new file mode 100644
index 000000000000..268de4321a0c
--- /dev/null
+++ b/x11-toolkits/xg/files/patch-aa
@@ -0,0 +1,13 @@
+--- makefile Sat Mar 15 00:36:20 1997
++++ /home/andy/tmp/wrk/makefile Wed Dec 2 22:28:41 1998
+@@ -51,8 +51,8 @@
+ # most systems don't need to do this, ie:. -I/usr/dt/include for
+ # Solaris
+ #
+-MOTIF_INC =
+-CFLAGS = "-DUSE_XM_MWMUTIL_H -DUSE_XGPM -I../include ${MOTIF_INC}"
++MOTIF_INC = -I${X11BASE}/include -I${X11BASE}/include/X11
++CFLAGS = "-DUSE_XM_MWMUTIL_H -DUSE_XGPM -DV_USE_TM_ZONE -I../include ${MOTIF_INC}"
+
+ #
+ # If your OS doesn't use ranlib set RANLIB to true
diff --git a/x11-toolkits/xg/files/patch-ab b/x11-toolkits/xg/files/patch-ab
new file mode 100644
index 000000000000..d950aca4e459
--- /dev/null
+++ b/x11-toolkits/xg/files/patch-ab
@@ -0,0 +1,22 @@
+--- src/TimeEntry.c Fri Mar 14 21:50:04 1997
++++ /home/andy/tmp/wrk/src/TimeEntry.c Wed Dec 2 22:29:36 1998
+@@ -1549,7 +1549,9 @@
+ {
+ struct tm ts;
+ long time_value;
++#ifndef __FreeBSD__
+ extern long timezone;
++#endif
+
+ ts.tm_mon = te->timeentry.month_value - 1;
+ ts.tm_mday = te->timeentry.day_value;
+@@ -1574,7 +1576,9 @@
+ */
+ if ( te->timeentry.use_timezone == False )
+ {
++#ifndef __FreeBSD__
+ time_value -= timezone;
++#endif
+
+ /*
+ * Adjust for Daylight Savings Time
diff --git a/x11-toolkits/xg/files/patch-ac b/x11-toolkits/xg/files/patch-ac
new file mode 100644
index 000000000000..2bb15b3403d6
--- /dev/null
+++ b/x11-toolkits/xg/files/patch-ac
@@ -0,0 +1,12 @@
+--- testsrc/makefile Fri Mar 14 22:50:16 1997
++++ /home/andy/tmp/wrk/testsrc/makefile Wed Dec 2 23:05:06 1998
+@@ -43,6 +43,9 @@
+ testrow.c testtb.c testte.c testtabs.c
+ TESTPROGS = ${TESTCSRC:.c=}
+
++CFLAGS = -I/usr/X11R6/include/xg -I/usr/X11R6/include
++LDFLAGS = -L/usr/X11R6/lib -lXm -lXt -lXmu -lX11 -lxg
++
+ # ------------------------------------------------------------------------
+ # miscellaneous macros
+ #
diff --git a/x11-toolkits/xg/pkg-comment b/x11-toolkits/xg/pkg-comment
new file mode 100644
index 000000000000..2cc5ae5ac15d
--- /dev/null
+++ b/x11-toolkits/xg/pkg-comment
@@ -0,0 +1 @@
+Windows(tm) controls - like widget set for Motif(tm).
diff --git a/x11-toolkits/xg/pkg-descr b/x11-toolkits/xg/pkg-descr
new file mode 100644
index 000000000000..b35fcf08befa
--- /dev/null
+++ b/x11-toolkits/xg/pkg-descr
@@ -0,0 +1,10 @@
+In the many years that I have been developing GUIs for UNIX, I have
+always envied the controls that are commonly available for MS Windows
+applications. In attempt to rectify this situation I designed the
+"Xg Widget Set". This widget set is an extension of the Motif widget
+set and provides many of the controls found in MS Windows applications.
+
+The widget set is self contained, as such it requires no additional
+libraries other than X, Xt, and Motif (1.1, 1.2.x or 2.0).
+
+http://www.messners.com/xgwidgets/xgwidgets.html
diff --git a/x11-toolkits/xg/pkg-plist b/x11-toolkits/xg/pkg-plist
new file mode 100644
index 000000000000..5508e8ad24f4
--- /dev/null
+++ b/x11-toolkits/xg/pkg-plist
@@ -0,0 +1,45 @@
+include/xg/ClockLabel.h
+include/xg/ClockLabelP.h
+include/xg/ComboBox.h
+include/xg/ComboBoxP.h
+include/xg/ExtPushB.h
+include/xg/ExtPushBP.h
+include/xg/FastLabel.h
+include/xg/FastLabelP.h
+include/xg/NumEntry.h
+include/xg/NumEntryP.h
+include/xg/Row.h
+include/xg/RowP.h
+include/xg/Tabs.h
+include/xg/TabsP.h
+include/xg/TimeEntry.h
+include/xg/TimeEntryP.h
+include/xg/ToolBar.h
+include/xg/ToolBarP.h
+include/xg/ToolPushB.h
+include/xg/ToolPushBP.h
+include/xg/XgUtils.h
+include/xg/x_rotate.h
+include/xg/xgpm.h
+lib/libxg.a
+share/doc/xg/LICENSE
+share/doc/xg/README
+share/examples/xg/CancelPB.xpm
+share/examples/xg/HandSign.xpm
+share/examples/xg/HelpPB.xpm
+share/examples/xg/Makefile
+share/examples/xg/NoPB.xpm
+share/examples/xg/OkayPB.xpm
+share/examples/xg/YesPB.xpm
+share/examples/xg/testcb.c
+share/examples/xg/testcl.c
+share/examples/xg/testepb.c
+share/examples/xg/testfl.c
+share/examples/xg/testne.c
+share/examples/xg/testrow.c
+share/examples/xg/testtabs.c
+share/examples/xg/testtb.c
+share/examples/xg/testte.c
+@dirrm include/xg
+@dirrm share/doc/xg
+@dirrm share/examples/xg